Discussion in 'Tips/Tricks/Mods' started by domino, Sep 30, 2005.

  1. domino

    domino New Member

    HotSaNIC is a very nice tool which combines all sorts of very important system graphs into a simple and easy to understand webpage. It allows the admin to take a quick glance at the graphs to see what may or may not be working with the system. With the new APPS graph it is also possible to watch as more processes are started which can be helpful in tracking down why the server load is increasing. For instance if you see a huge load spike but you see that the number of exim processes has gone up significantly at the same time you can start to investigate.

    I built this guide on a cPanel server but it will work fine on an ensim box as well. I don't recall the plesk mailserver off the top of my head but changing that small part will make it work great fine plesk.

  2. Ovidiu

    Ovidiu Active Member

    thats an awesome howto - worked like a charm - I tried doing the same with mrtg - no chance for, but this just worked :)

    only one question remains: the howto was not for debian, so I think I can't apply the last part of it, when trying to get it to autostart with each reboot, can anyone help with that?
    Last edited: Nov 13, 2005
  3. Ovidiu

    Ovidiu Active Member

    anyone experienced in evaluating the output of the netstat module? After tweaking my apache settings I am seeing a lot of time_wait connections, an average of 188 but I don't know how to interpret it.

    I know what it means, my apache2 child proc. waiting a certain period (I set that in the apache2 cfg) to see if the conection will be reused.

    every how-to I found states that this should be done as a trade of between reusing connections and ram usage,...

    anyone got more concrete suggestions? you can have a look at my current serverstats here: h**p://w*

    !this is intentionally not a direct link!
    Last edited: Nov 24, 2005
  4. domino

    domino New Member


    I love graphs and yours looks really nice :D. Sorry I can't give feedback but I think members might can enlighten you. They are pretty helpfull when they want to be. Just don't post the link to your graph or site unless you have it tided down.
  5. heyp

    heyp New Member


    i tried the tutorial, but with the newest version of rrdtool.

    When i run ./ i get the following error:

    Can't locate in @INC (@INC contains: ./platform ../../lib /etc/perl /usr/local/lib/perl/5.8.7 /usr/local/share/perl/5.8.7 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl /usr/local/lib/perl/5.8.4 /usr/local/share/perl/5.8.4 .) at ../../lib/ line 7.
    BEGIN failed--compilation aborted at ../../lib/ line 7.
    Compilation failed in require at ./ line 14.
    Any ideas? I've already read every FAQ on this without any help :(

  6. heyp

    heyp New Member

    Anyway, got it:

    apt-get install librrds-perl solves the problem ;)
  7. Ovidiu

    Ovidiu Active Member

    I would like to upgrade to latest rrdtool too but when doing ./configure I get libpng and freetype2 not found also both are installed on my system....
    did you have to do any extra steps or did it just work?

    I also updated to latest hotsanic version, (has more modules)
  8. heyp

    heyp New Member

  9. Grizzly

    Grizzly New Member

    suse 10 ISPconfig

    Would just like to know if this would also go for a suse 10 server with ispconfig, just got my server up and running. Thanks Falco & Till
    (is it safe?)
  10. falko

    falko Super Moderator Howtoforge Staff

    I haven't tested, but I don't know why it shouldn't work. :)
  11. Ovidiu

    Ovidiu Active Member

    how to setup the diskio module if I have raid running?

    the how-to states this:

    now if I do:
    so how would the lines look like?
  12. Ovidiu

    Ovidiu Active Member

    furthermore I cannot get it running with rrdtool 1.2.14 - when running ./ I get the following errors for each module:

    and no images and neither thumbnails get created.
    Any ideas? if not I will have to convert back to rrdtool
  13. Ben

    Ben Active Member Moderator

    I only had such an error when no data was gathered, e.g. I still have that for ping, because that won't work...

    But normally setting up Hotsanic is quite easy.
    Copying anywhere, dfining webroot, binary for rrd (compiling it, locating with find / locate), install Imagemagickmodule from CPAN for Perl oder Imagemagick, configure needed services, start...
  14. Ben

    Ben Active Member Moderator

    As mentioned before, it is quite easy. I think it is independent to the fact which or even if you are using any controlpanel.

    I just installed it on my debian, but the devel packets zlib etc. did not really work so I compiled the necessary stuff for rrd manually... just keep in mind updating them and recompiling rrd manually in case of securityfixes for them
  15. Ovidiu

    Ovidiu Active Member

    @ BEN

    maybe you can help me, I first followed this guide from rrdtool and everything worked ok, as far as I understand, I had to install freetype2 and 2-3 other packages with apt-get but everything worked out.
    Then I continued with this guide: and started setting up all modules.

    I have to mention that I set up hotsanic severall times by now on different machines and I can get it running with an older version of rrdtool.

    with the latest version, when I start ./ I get the error I mentioned above and I do not know what settings to input in the disk_io module as the examples are only about sda and hda and I have raid configured.
  16. Ben

    Ben Active Member Moderator

    But you get that on all modules or not?
    So how long did you wait after starting rrdgraph and running

    what happens if you start rrdgraph and then take a look with tail -f
    at the logs of hotsanic?
  17. Ovidiu

    Ovidiu Active Member

    the error happens when running ./diagrams

    I waited more than 1 hour. the logfile output is this:

    if I start .rrdgraph and have a look at it with tail I also get these errors:Ö

  18. Ben

    Ben Active Member Moderator

  19. Ovidiu

    Ovidiu Active Member

    I deleted all *.rrd files but the result is the same. any other idea? if not I am going to use an older rrdtool version.
  20. Ben

    Ben Active Member Moderator

    I'm using on a CentOS machine 1.2.11 on an RHEL4 1.2.12 without any problems.

Share This Page