How to disable Clamav or Spamassassin check in amavis?

Discussion in 'Tips/Tricks/Mods' started by filipealvarez, Mar 31, 2011.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you uninstall clamav as I suggested and not just stopped it? I guess you get this errors just because clamav is found by amavis, so it tries to connect to it.
     
  2. tal56

    tal56 Member

    Interesting, never thought it would affect it. I just ran :
    Code:
    sudo apt-get remove --auto-remove clamav-daemon and
    sudo apt-get remove --auto-remove clamav
    to uninstall ClamAV, let's see how it goes, thanks again Till.
     
    Last edited: Feb 19, 2017
  3. tal56

    tal56 Member

    Actually just another quick question, should I have uninstalled with clamav-freshclam instead as per below ?
    Code:
    sudo apt-get remove --auto-remove clamav-freshclam
    Thanks

    hmm so after all said and done, I used this to clear out all the Clamav stuff
    Code:
    apt-get remove --purge clamav*
    But after that I restarted amavis and still got this in my mail-warn-log
    Code:
    Feb 19 21:57:47 server1 amavis[10471]: (10471-01) (!)connect to /var/run/clamav/clamd.ctl failed, attempt #1: Can't connect to a UNIX socket /var/run/clamav/clamd.ctl: No such file or directory
    Feb 19 21:57:48 server1 amavis[10471]: (10471-01) (!)connect to /var/run/clamav/clamd.ctl failed, attempt #1: Can't connect to a UNIX socket /var/run/clamav/clamd.ctl: No such file or directory
    Feb 19 21:57:48 server1 amavis[10471]: (10471-01) (!)ClamAV-clamd: All attempts (1) failed connecting to /var/run/clamav/clamd.ctl, retrying (2)
    Feb 19 21:57:54 server1 amavis[10471]: (10471-01) (!)connect to /var/run/clamav/clamd.ctl failed, attempt #1: Can't connect to a UNIX socket /var/run/clamav/clamd.ctl: No such file or directory
    Feb 19 21:57:54 server1 amavis[10471]: (10471-01) (!)ClamAV-clamd av-scanner FAILED: run_av error: Too many retries to talk to /var/run/clamav/clamd.ctl (All attempts (1) failed connecting to /var/run/clamav/clamd.ctl) at (eval 102) line 613.\n
    Feb 19 21:57:54 server1 amavis[10471]: (10471-01) (!)WARN: all primary virus scanners failed, considering backups
    Feb 19 21:57:54 server1 amavis[10471]: (10471-01) (!!)AV: ALL VIRUS SCANNERS FAILED
     
    Last edited: Feb 19, 2017
  4. MaxT

    MaxT Member

    I rescue this thread because I'm with Debian 9 in a short memory machine and I need to delete clamav although preserving amavis.

    I have followed these same steps I use for Debian 8, commenting and including the code in /etc/amavis/conf.d/15-av_scanners and /etc/amavis/conf.d/90-custom
    And later uninstalling clamav:
    apt-get remove clamav-daemon
    apt-get remove clamav-freshclam

    I reboot and all works well, except these two warnings inside /var/log/syslog:
    Code:
    host amavis-mc[1043]: Not starting amavis-mc - edit /etc/default/amavis-mc to enable it ... (warning).
    host amavisd-snmp-subagent[1052]: Not starting amavisd-snmp-subagent - edit /etc/default/amavisd-snmp-subagent to enable it ... (warning).
    inside those config files the values are 0 disabled. Not touched from the original ISPC install.

    Is there some new modification for Debian 9?

    thx,
     
  5. MaxT

    MaxT Member

Share This Page