how to reset settings for server?

Discussion in 'ISPConfig 3 Priority Support' started by ledoktre, May 13, 2014.

  1. ledoktre

    ledoktre Member


    Some background
    - - -
    I had one of the servers in my little ISP Config cluster that was installed originally with Debian Testing/Apache for purpose of webdav support.

    In a previous post, I was having issues with the webdav and using it for MS Expression Web, and ended up getting it sorted out on Nginx with Sabredav.

    I shut the server down, popped in the debian thumb drive, and reloaded it, Debian Testing / Nginx. Everything appears to work fine save one thing.

    The problem
    - - -
    Monitor shows that that server is running Apache. So it shows a failure. I tried logging onto the database and updating the server table, where it shows the global settings for that server. I changed it from apache to nginx.

    It still shows the error, and that was a few days ago. Whats the best way to resolve this? I have setup websites already on this server, so I really don't want to just scrap it.

    Please advise..


  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no way to solve this except of editing the server settings manually in mysql on the master and the slave server. The change from apache to nginx on a system that has already running websites is not supported as the settings incl. server type were written by the installer once when a server gets added initially to a cluster.
  3. ledoktre

    ledoktre Member


    Thanks for the reply. Maybe I should clarify.

    I had set it up, call it hostname web6. It was running Apache, but the only reason I had set it up on Apache was for webdav.

    That customer using Expression Web was the first one to go on "web6". When I could not make the webdav work, I figured out that we could run webdav via nginx/sabredav, and so I put him on another server, already running nginx.

    I formatted the server (web6), and reinstalled Debian Testing / Nginx (still calling it web6). I am able to create websites, etc no issue. I've got a few people on there now.

    The only issue that I am seeing so far is the monitor -- it must have retained some settings from the previous incarnation (apache).

    I did try going into the master database (server -> web6 entry -> config, global section and changing web from apache to nginx. That was a few days ago, and so far it still shows the webserver is offline.

    That was why I started this thread -- can I just copy the settings from another nginx host, change out the host names, or where did I go wrong? I did not edit anything on the web6 database itself -- just on the master.

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You hae to do this on the master and slave. the config of master and slave have to be in sync.

    as long as you exchange nly the webserver part and ensure that you do this on master and slave and not just on the master, then this should work.
  5. ledoktre

    ledoktre Member

    Thanks for the reply.

    I pulled the [web] section from another server already running nginx, put it on the master server's record for 'web6', and then made sure it looked the same on web6's database.

    Now we'll see after a few minutes what it looks like I guess.
  6. ledoktre

    ledoktre Member

    Replicating the settings worked fine. The only additional thing that I had to do was make sure nginx was listening on my private interface (I have ISPConfig communicating between servers on a private interface, public is on its own public interface and firewalled).

    So I'm good to go!!


Share This Page