https causing open_basedir error??

Discussion in 'ISPConfig 3 Priority Support' started by yupthatguy, Nov 4, 2021.

  1. yupthatguy

    yupthatguy Member

    I don't know if the title of this post is accurate, however prior to adding https to one of my sites everything worked, wp-cli connected to db, no problem, and the site was reasonably fast.. now I am getting 504 Gateway errors, slow pageloads, and when I check my wp debug log, I have the following error:

    [04-Nov-2021 08:20:49 UTC] PHP Warning:  file_exists(): open_basedir restriction in effect. File(/var/www/clients/client1/web19/web/wp-content/db.php) is not within the allowed path(s): (/var/www/clients/client1/web19/web:/var/www/clients/client1/web19/private:/var/www/clients/client1/web19/tmp:/var/www/ in /var/www/clients/client1/web19/web/wp-includes/load.php on line 545
    [04-Nov-2021 08:20:49 UTC] PHP Stack trace:
    [04-Nov-2021 08:20:49 UTC] PHP   1. {main}() /var/www/clients/client1/web19/web/wp-admin/admin-ajax.php:0
    [04-Nov-2021 08:20:49 UTC] PHP   2. require_once() /var/www/clients/client1/web19/web/wp-admin/admin-ajax.php:22
    [04-Nov-2021 08:20:49 UTC] PHP   3. require_once() /var/www/clients/client1/web19/web/wp-load.php:50
    [04-Nov-2021 08:20:49 UTC] PHP   4. require_once() /var/www/clients/client1/web19/web/wp-config.php:129
    [04-Nov-2021 08:20:49 UTC] PHP   5. require_wp_db() /var/www/clients/client1/web19/web/wp-settings.php:124
    [04-Nov-2021 08:20:49 UTC] PHP   6. file_exists($filename = '/var/www/clients/client1/web19/web/wp-content/db.php') /var/www/clients/client1/web19/web/wp-includes/load.php:545
    But when I check Domains >> Websites >> Options >> open_basedir everything looks fine:
    (the missing directory, is in fact, inside an allowed directory)
    Any recommendations?
  2. yupthatguy

    yupthatguy Member

    correction wp-cli has to play nice today and connect to the db

Share This Page