Inst. stops, MySQL passw not accepted

Discussion in 'Installation/Configuration' started by Thunderbirdsei, Jan 26, 2006.

  1. falko

    falko Super Moderator Howtoforge Staff

    Ok, you deleted /root/ispconfig and /home/admispconfig, right? You also deleted the ISPConfig database (if it was there), you deleted install_ispconfig, then you upacked the ISPConfig .tar.gz again, went to the new install_ispconfig directory and ran
    , right?

    When it asks you for the MySQL server, you enter localhost, the MySQL user must be root, and then you enter root's MySQL password.
    I guess you used another MYSQL user than root who hasn't got the privileges to create a new database, that's why the db_ispconfig database isn't there.
  2. Thunderbirdsei

    Thunderbirdsei New Member

    I did exactly what you have described. Really. I can send you one of the config files of ISPconfig (I can't remember which one^^) there are all setting in clear text...and there is the user root and the right password and the right database....but in mysql there is no database...
    Last edited: Jan 27, 2006
  3. Thunderbirdsei

    Thunderbirdsei New Member

    The data from "", I have only changed the domain name with an IP-Adress...and that works, I can access the Login page...but that's useless because, as I said, there is no database...^^

    $go_info["server"]["dir_trenner"] = "/";
    $go_info["server"]["server_root"] = "/home/admispconfig/ispconfig";
    $go_info["server"]["server_url"] = "";
    $go_info["server"]["include_root"] = $go_info["server"]["server_root"] . $go_info["server"]["dir_trenner"] ."lib";
    $go_info["server"]["classes_root"] = $go_info["server"]["include_root"] . $go_info["server"]["dir_trenner"] ."classes";
    $go_info["server"]["temp_dir"] = $go_info["server"]["server_root"] . $go_info["server"]["dir_trenner"] ."temp";
    $go_info["server"]["files_dir"] = $go_info["server"]["server_root"] . $go_info["server"]["dir_trenner"] ."files";
    $go_info["server"]["backup_dir"] = $go_info["server"]["server_root"] . $go_info["server"]["dir_trenner"] ."backup";
    $go_info["server"]["version"] = "2.1.2";
    $go_info["server"]["os"] = "linux";
    $go_info["server"]["ort"] = "local";
    $go_info["server"]["banner"] = "0";
    $go_info["server"]["db_host"] = "localhost";
    $go_info["server"]["db_name"] = "ispconfig";
    $go_info["server"]["db_user"] = "root";
    $go_info["server"]["db_password"] = "xxxxxx";
    $go_info["server"]["db_type"] = "mysql";
    $go_info["server"]["mail_server"] = "";
    $go_info["server"]["mail_user"] = "";
    $go_info["server"]["mail_password"] = "";
    $go_info["server"]["smtp_server"] = "localhost";
    $go_info["server"]["mode"] = "";
    $go_info["server"]["lang"] = "de";
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Does your mysql password contains any special characters?
  5. Thunderbirdsei

    Thunderbirdsei New Member

    No, 8 digits.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    I just wrote you a PM.
  7. adrenalinic

    adrenalinic Member

    yes the password is the same.
    and in local mode join to my sqlserver...
    i have verifyed my /etc/hosts for hostname and is ok.
    have tryed to login with phpmyadmin and login user root is ok...
    have modified my my.cnf of mysql config file and have commented # the line "bind address" for allow connection from any host but the erroe is the same!

    have verfied in the mysql database of mysql server the root user name for localhost domain and is ok!

    the line --skip-networkig in the my.cnf of my sqlserver don't exist!
    i use debian sarge.
    who is problem!
    Last edited: Jan 27, 2006
  8. adrenalinic

    adrenalinic Member

    tcp 0 0* LISTEN 984/mysqld

    server3:/home/josef# mysql -u root -p
    Enter password:
    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 11 to server version: 4.0.24_Debian-10sarge1-log

    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.


    ______________________________________________________________ localhost.localdomain localhost server3

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts


    # The MySQL database server configuration file.
    # You can copy this to one of:
    # - "/etc/mysql/my.cnf" to set global options,
    # - "/var/lib/mysql/my.cnf" to set server-specific options or
    # - "~/.my.cnf" to set user-specific options.
    # One can use all long options that the program supports.
    # Run program with --help to get a list of available options and with
    # --print-defaults to see which it would actually understand and use.
    # For explanations see

    # This will be passed to all mysql clients
    # It has been reported that passwords should be enclosed with ticks/quotes
    # escpecially if they contain "#" chars...
    # Remember to edit /etc/mysql/debian.cnf when changing the socket location.
    port = 3306
    socket = /var/run/mysqld/mysqld.sock

    # Here is entries for some specific programs
    # The following values assume you have at least 32M ram

    # This was formally known as [safe_mysqld]. Both versions are currently parsed.
    socket = /var/run/mysqld/mysqld.sock
    nice = 0

    # * Basic Settings
    user = mysql
    pid-file = /var/run/mysqld/
    socket = /var/run/mysqld/mysqld.sock
    port = 3306
    basedir = /usr
    datadir = /var/lib/mysql
    tmpdir = /tmp
    language = /usr/share/mysql/english
    # localhost which is more compatible and is not less secure.
    #bind-address =
    # * Fine Tuning
    key_buffer = 16M
    max_allowed_packet = 16M
    thread_stack = 128K
    # * Query Cache Configuration
    query_cache_limit = 1048576
    query_cache_size = 16777216
    query_cache_type = 1
    # * Logging and Replication
    # Both location gets rotated by the cronjob.
    # Be aware that this log type is a performance killer.
    #log = /var/log/mysql.log
    #log = /var/log/mysql/mysql.log
    # Error logging goes to syslog. This is a Debian improvement :)
    # Here you can see queries with especially long duration
    #log-slow-queries = /var/log/mysql/mysql-slow.log
    # The following can be used as easy to replay backup logs or for replication.
    #server-id = 1
    log-bin = /var/log/mysql/mysql-bin.log
    # See /etc/mysql/debian-log-rotate.conf for the number of files kept.
    max_binlog_size = 104857600
    #binlog-do-db = include_database_name
    #binlog-ignore-db = include_database_name
    # * BerkeleyDB
    # The use of BerkeleyDB is now discouraged and support for it will probably
    # cease in the next versions.
    # * InnoDB
    # InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
    # Read the manual for more InnoDB related options. There are many!
    # * Security Feature
    # Read the manual, too, if you want chroot!
    # chroot = /var/lib/mysql/
    # If you want to enable SSL support (recommended) read the manual or my
    # HOWTO in /usr/share/doc/mysql-server/SSL-MINI-HOWTO.txt.gz
    # ssl-ca=/etc/mysql/cacert.pem
    # ssl-cert=/etc/mysql/server-cert.pem
    # ssl-key=/etc/mysql/server-key.pem

    max_allowed_packet = 16M

    #no-auto-rehash # faster start of mysql but no tab completition

    key_buffer = 16M
    Last edited: Jan 27, 2006
  9. falko

    falko Super Moderator Howtoforge Staff

    Does your MySQL password contain special characters?
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    To Thunderbirdsei's problem:

    His server has no swap partition or swap file and there where only 2.8 MB space left in RAM. There was not enough space in RAM to unpack the ISPConfig installer tar.gz completely, tar fails after about 50% of the files.
  11. adrenalinic

    adrenalinic Member

    my password is alphanumeric passphrase...!

    and i run my debian sever in vmware virtual machine.
    the virtualized machine have 200 MB RAM..
    Last edited: Jan 28, 2006
  12. Thunderbirdsei

    Thunderbirdsei New Member

    I could just login! :D Thank you very very much Till and Falko! What a great support!

    A short note: I did again a complete fresh install (Fedora 4) I run through the "The Perfect Setup - Fedora 4" but Fedora did not install the Swap partition correctly! The fstab was just...let me say..mess. By the Swap-line a strange /label with strange characters...did cost me around 30min. (I'm still a linux newbie) :D

    However, after the "Perfect Setup Guide" I did install "gcc" and "flex" (was a ispconfig hint), what would happen when you don't do this step? Perhabs others run into this trap...?
  13. Thunderbirdsei

    Thunderbirdsei New Member

    Are you sure that you typed "localhost" as the name of the mySQL-server during the ISPconfig installation? I run into this "trap".
  14. Thunderbirdsei

    Thunderbirdsei New Member

    And what is the size of the swap? Maybe that's the problem, although it's a bit strange failure point....(compared with my swap-failure-brake-point)

    Hmm..I should shut up and let the masters help...^^...good night!
  15. falko

    falko Super Moderator Howtoforge Staff

    Swap should at least have the size of your RAM. So if you have 512 MB RAM, then swap should at least be 512MB (because then you can do a Suspend-to-Disk (which you normally don't need on a server, but anyway)).

    On it reads:

    If you select these package groups, especially "Development Tools", then gcc and flex are installed during the tutorial, and you don't have to install them afterwards.
  16. adrenalinic

    adrenalinic Member

    I use LVM for the management of file system !I seem indeed improbable that the management of swap file system can influence in the compilation... and above all in the connection to the mysql server!

    in fact the compilation of mine ispconfig to proceed correctly until the demand for gives you of logon to the mysql server

    the problem, second me, are on privilege of access to the mymysql server...
    Last edited: Jan 28, 2006
  17. adrenalinic

    adrenalinic Member

    hello boys. I do not know if the installation of ispconfig or mysql is out of mind! but I have resolved! I have installed mysql without password. therefore I have installed ispconfig without password and has gone all ok. and finally I have modified the password of mysql server and then in the rows of configuration of ispconfig.

    thanks for support.
  18. Thunderbirdsei

    Thunderbirdsei New Member

    Nice! I'm glad to hear that it works now for you.

    I had a similar problem with my first Fedora Core 5t2 installation...I couldn't logon with my password, neither with the root nor with the usual user. As a Linux-Newbie I thought that I have to install all over again. Thank god I found a page with the runlevel-thing :D
  19. Thunderbirdsei

    Thunderbirdsei New Member


    Till, Falko

    Thank you for the incredible support! I would like donate some €uros...could you tell me your paypal-account?
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    Thanks. Please send me a short PM :)

Share This Page