Install question/issue

Discussion in 'Installation/Configuration' started by wr19026, Jan 11, 2006.

  1. wr19026

    wr19026 New Member


    After several (some relatively successful, some unsuccessful) tries I'm not ready to give up on ISPConfig yet :)

    What keeps confusing me is the question in the install process where it asks for the IP address: should I use my internal IP addy (e.g. 10.x.x.x) or the external one (e.g. 84.x.x.x)

    84.x.x.x points to my router and I have NAPT doing the internal forward to 10.x.x.x

    Last time I tried to set it up I entered the external one. This gave me the error message that it couldn't find the server and that the install process would stop there.

    Then it gets interesting: if I do a reinstall starting from the tar command (pretty vanilla reinstall I'd think), the process starts without any errors or warnings that something might not be right. However, pretty much to the end of the install I'm getting errors/warnings:

    Warning: main( failed to open stream: No such file or directory in /tmp/install_ispconfig/install.php on line 639

    Warning: main(): Failed opening '' for inclusion (include_path='.:/root/ispconfig/php/lib/php') in /tmp/install_ispconfig/install.php on line 639

    Warning: mysql_connect(): Access denied for user: 'root@localhost' (Using password: NO) in /tmp/install_ispconfig/install.php on line 649
    Could not connect to db
    Restarting some services...
    * Stopping Postfix Mail Transport Agent... [ ok ]
    * Starting Postfix Mail Transport Agent... [ ok ]
    Restarting ProFTPD ftp daemon.proftpd.
    ./setup2: line 974: /etc/init.d/ispconfig_server: No such file or directory
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.

    The official uninstall is not available:
    root@blablabla:~/ispconfig# ls httpd openssl php

    So, here are my two main questions:
    - What IP address do I need to enter in the install script: the internal one or the external one?
    - If the install fails/aborts, what can I do to remove all that's there and start from scratch without having to completely reinstall the server (using the excellent guide for an Ubuntu server) first?

    Thanks in advance for your help.
  2. falko

    falko Super Moderator Howtoforge Staff

    Always the one you see for your network interface when you run
    , i.e. your internal one.

    rm -fr /root/ispconfig
    rm -rf /home/admispconfig
    and also delete the ISPConfig MySQL database.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Good to hear that :)

    This must be the internal IP address (10.x.x.x).

    rm -rf /root/ispconfig
    rm -rf /home/admispconfig

    Then delete the install_ispconfig directory and the mySQL database, then unpack the installer tar.gz file again.
  4. wr19026

    wr19026 New Member

    So here's a real noob question; how do I delete the MySQL database? I tried installing phpmyadmin to help me do that but that gave errors (removing phpmyadmin did as well btw) because from my experience with XAMPP I know how to use that. But it was "close, but no cigar" in this install.

    By the way, the support from Falco and yourself is SUPERB!
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Have a look in the folder:


    If there is a folder in that directory with the name of your database, delete this folder. If your database is named e.g. db_ispconfig:

    rm -rf /var/lib/mysql/db_ispconfig
  6. falko

    falko Super Moderator Howtoforge Staff

  7. wr19026

    wr19026 New Member

    I have installed ISPConfig for what must be the 15th time and so far so good. I have a system that's up and running, I can connect and change settings etc. and I can see the first website's homepage! At first glance however e-mail will be my next problem :)

    Here's a follow up question for you:
    When connecting from a machine from the same network as the server (10.x.x.1 for the server and 10.x.x.2 for a client) it won't connect me when I use https://10.x.x.1:81 does allow me to connect. When I'm connected it does not allow me to access certain pages in the Management tab: specifically System Configuration and Server.

    All the other tabs seem to work fine.

    Now when I log in from an outside network I can log in and do everything without any issues at all. So it does work, but not quite as I had expected.

    Again, I'm using the Perfect Server Setup for Ubuntu (Breezy) as my baseline and I have not tinkered with iptables or any other type of firewall on my server. NAPT on the router has everything pointing to the server's IP address.
  8. falko

    falko Super Moderator Howtoforge Staff

  9. wr19026

    wr19026 New Member

    And again this was of great help :) In the mean time I also discovered what to fix in order to send mail (darn nameservers ;) ) so now I'll search a bit more to find how to actually be able to receive mail as well.

Share This Page