Installation of GitLab in ISPConfig

Discussion in 'Server Operation' started by xrjpk, Jan 1, 2017.

  1. xrjpk

    xrjpk New Member

    Hey there,

    i've tried to install an GitLab on an ISP Config Server, but i failed badly. I don't want to use the budled nginx, because ISPConfig had his own Apache2. But i struggled with the backgroud system of individual client und web directorys and webusers. Does anybody has expierences installing GitLab in ISPConfig?

    As a perfect solution i would like to usw a own subdomain like with his own webXX user/directory.

    I've tried the ideas mentioned in this thread

  2. Miscni

    Miscni New Member

    Hi mate
    I would gladly try to provide what I know.

    I have to warn you though, I am pretty bad at it, but in the end, the job gets done :)
    I have just recently lost our whole ISP sql, because we install Perforce.
    And because of that we had lost everything.
    Normally me and some others just sit and work in Blender and Unreal Engine 4
    And things have been going well with streaming each day from 12-5 GMT+1. (But not the last 2 days)

    But when we installed Perforce, then everything got screwed up, none of us was looking at, what would be overwritten etc.

    So now, we have setup a little VM system.
    1. Is running Perforce on Ubuntu
    2. is running it own ISPConfig3 (Would gladly show you, what we did, so it worked, and also make a tutorial, but it was abit tricky for us)
    3. we are working on the harddrive, on an different computer, we have Kubuntu and Windows 10 to help us out. (2 Different Machines)
    By doing this, we may be able to make a ghost image of the harddrive, where it is cut down in filesize, because over half on what is there i just standard images from webthemes.
    4. If you are interested, then please let me know, because I am going to start a stream later today, talking about what problems we are faceing right now. (Uploading it to youtube later)
    5. We are hopeing for, that it can be possibul to recreate the old sql.
    xrjpk likes this.
  3. xrjpk

    xrjpk New Member

    Hi Miscni,
    thanks for reply. It seems that ISPConfig and the bigger Version/Source Control System had some issues. Maybe these system are developed for running standalone.

    What was my idea:
    I wanted an instance of Gitlab running own a subdomain of an ISP managed domain ( that you can access it like
    What i've tried so far:

    First i tried to integrate it "normally" in ispconfig. I've created a new domain ( so it gets its own web directory, this works quite well. After that i've installed GitLab and customized the config.
    - disable nginx
    - use the Apache2 from ISP
    - use the /var/www/client3/web22/ directory of
    - changed the port from 8080 to 8181 (via apache vhost)

    This didnt work, it seems nothing happend. ISP shows me a site where it says: Yeah this is my domain, but not managed until now, so there's no site.

    Second try, Made it without isp.
    Pretty much the same like the first one, but this time i thinked: Ok maybe isp can't handle GitLab.

    - installed GitLab
    - disalbe nginx
    - configure Apache with new vhost

    Unfortunately the result was pretty much the same! :-( It was not possible to access any GitLab page.
    I had no problems with damaging my ISP, but i was very carefull and don't damage ISP was one of my main thoughs.


Share This Page