ISPConfig 2.2.29 released

Discussion in 'General' started by till, Dec 16, 2008.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 2.2.29 is available for download.

    This ISPConfig release updates PHP to 5.2.8 and improves the creation of SSH chroot enviroments.

    Detailed Changelog

    - Updated PHP to 5.2.8.
    - Changed: The chroot enviroment is only created when a user has Shell access enabled.



    Installation Instructions

    Download the ISPConfig-2.2.29.tar.gz from

    Installation on the shell as root user:

    tar xvfz ISPConfig-2.2.29.tar.gz
    cd install_ispconfig

    The installer automatically detects the installed ISPConfig version and
    performs an update.
    Last edited: Dec 16, 2008
  2. edge

    edge Active Member Moderator

    Once again thank you.
    I'm updating as I type this.

    ** Edit.
    I've updated all my servers (Debian Etch), and for now all is looking fine.
    Last edited: Dec 16, 2008
  3. Doug G

    Doug G Member HowtoForge Supporter

    Anybody but me try to download using a Vista machine? I tried 5 or 6 times over a couple days, using both IE7 and FF3, and every time the download got almost done (48.1mb out of 48.4mb) and hung, ending up with a message about 'server reset'. I use this computer to download stuff all the time and have never seen this kind of download problem. I just d/l a Fedora 10 DVD iso without problems from the same box.

    So I jumped over to a Fedora machine with FF3 and downloaded completely on the first try. I suspect it's something strange in my Vista computer and nothing to do with ispconfig, but I'm confused as to what's going on ??
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I dont have any problems with the download, It might be a problem with your antivirus software or firewall. Did you try a different mirror?

    I recommedn that you download the software directly with weget to the server were it shall be installed.
  5. commentator

    commentator Member

    please try an other mirror. Here no problems on vista downloading from mirror kent
  6. lubos

    lubos New Member

    Thanks for update! Installation on one server went as update without problem. On another it went trough as a new installation, I just uploaded dump file from back up and all is back and running.

    Thank you again very much.

    Note: Doug don't use IE there is another flaw and quite nasty - no fix yet. If you have apache on linux than the best is to install as follwing:

    cd /tmp
    tar xvfz ISPConfig-2.2.29.tar.gz
    cd install_ispconfig
  7. Doug G

    Doug G Member HowtoForge Supporter

    Thanks, everyone. I opened an XP VM and downloaded the new version fine, I'm off to try to figure out what new weirdness my Vista machine has come up with :)

    Oh, and thanks to the developers for all their hard work!
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    This happens if the installer was started twice e.g. because a error occured. In such a case, run the following command before you try to update again:

    mkdir /root/ispconfig/
  9. lubos

    lubos New Member

    Thanks to developers

    I'll second to that.
    You can show your appreciation by subscribing. You can find out why and how on subscription page
    Its just $5.00 per month and it will help them to focus on development even more ;). And you will get such nice stars as I have :rolleyes:

    I'll do that next time, thanks Till.
    Last edited: Dec 17, 2008
  10. hsluis

    hsluis New Member

    Update Problem

    Hello and congratulations for the new release.

    I update my server from the version 2.2.23 to 2.2.29, but I have the nexts problems:

    *) In DNS Manager, in my domains, all Domain (SOA), IP Address and others record are in blank.

    *) When I create a new website, an select Create DNS and Create DNS MX, but only created a Domain (SOA) and IP Address in DNS Manager, the others records are in blank (A Record, CNAME...).

    Thanks, and sorry for my english, I speak spanish.
  11. falko

    falko Super Moderator ISPConfig Developer

    Did you see any errors during the update?

    Are there any warnings in /home/admispconfig/ispconfig/ispconfig.log?
  12. hsluis

    hsluis New Member

    Thanks for reply Falko,

    During the update, I don't see any errors.

    But the log, have this warnings:
    08.01.2009 - 11:55:39 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2556: WARNING: could not . /etc/apache2/envvars && httpd -t  &> /dev/null
    08.01.2009 - 11:55:39 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2570: httpd syntax seems to contain errors, reloading with old configuration
    I solved modify the /ispconfig/httpd/conf/httpd.conf and change the SSL certificate information.

    When I like modify the blank "Domain (SOA)" and "IP" from dns manager, in Domain SOA I write the domain without www, but I have the message " Invalid domain name"

    I can't access to the websites, and control panel only have access for IP.

    If possible return to the version 2.2.23?
  13. hsluis

    hsluis New Member

    The problem to access to Website are resolved, I look the file "/etc/bind/named.conf" and the part:

    zone "" {
    type master;
    file "";

    Are repeat for all domain, I delete one for all domain, and restart "bind9" and domain funtion ok.

    But this error is for why?
  14. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    . /etc/apache2/envvars && httpd -t
  15. hsluis

    hsluis New Member

    I'm root but I have this message:

    hs:~# /etc/apache2/envvars && httpd -t
    bash: /etc/apache2/envvars: Permiso denegado
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to run this as root user.
  17. hsluis

    hsluis New Member

    Ok, and ready:

    hs:/etc/apache2# . /etc/apache2/envvars && httpd -t
    [Sat Jan 10 10:21:42 2009] [warn] VirtualHost overlaps with VirtualHost, the first has precedence, perhaps you need a NameVirtualHost directive
    Syntax OK
  18. falko

    falko Super Moderator ISPConfig Developer

    What's in your Vhosts_ispconfig.conf? What's at the end of your main Apache configuration?
  19. hsluis

    hsluis New Member

    Hello Falko,

    This is because I enable multiple HTTPS Sites for one IP, In my Vhosts_ispconfig.conf I have multiple <VirtualHost>.
  20. falko

    falko Super Moderator ISPConfig Developer

    You can have only one SSL web site per IP, and ISPConfig doesn't allow you to create more than one SSL web site per IP.

Share This Page