ISPConfig 2.2.36 released

Discussion in 'General' started by till, May 28, 2010.

  1. Hans

    Hans Moderator ISPConfig Developer

    Hi Till,
    I want you to know that the upgrade from ISPCOnfig 2.2.35 to 2.2.36 was flawless again.
    Thanks for your work!
  2. Hans

    Hans Moderator ISPConfig Developer

    Have a look here:
  3. rbartz

    rbartz Member HowtoForge Supporter

    Thank you Hans! I ran the update as till indicated and that solved the problem. Thanks again ispconfig developers, you guys are amazing!

    To fix the spamassassin, Till said: No downgrade nescessary. Just run:


  4. kextra1

    kextra1 ISPConfig Developer ISPConfig Developer

    XML enabled on compile?

    Can anyone confirm:

    Is XML enabled by default on compile?

    When I upgraded once from 2.2.30 to 2.2.33 I remember that the Remoting Framework did not work.

    Did someone already post the URL to the changelog?
  5. kextra1

    kextra1 ISPConfig Developer ISPConfig Developer

    Debian Lenny

    I'm running Debian Lenny, I havent performed the upgrade yet.

    However, in the Debian Lenny Repo there is no:


    There is a "libarchive-any-perl" would that work?

  6. falko

    falko Super Moderator ISPConfig Developer

  7. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Everything looks fine but I found this during the installation

    any hints?
  8. falko

    falko Super Moderator ISPConfig Developer

    I've added this to our bugtracker.
  9. xrat

    xrat Member

    Current Debian 5.0.5 not supported

    Hi folks,
    It so happened that I upgraded my Debian Lenny to 5.0.5 (released yesterday or so) before I started the ISPconfig upgrade to 2.2.36, but Debian 5.0.5 is not supported.

    Debian 5.0.5
    ERROR: Ihr Betriebssystem wird nicht unterstützt! / Your operating 
    system is not supported! / Votre systeme d'exploitation n'est pas 
    A quick and dirty fix is for instance

    sed -i.bak -e 's/debian504/debian505/' dist.txt
  10. jtheed

    jtheed Member

    I get this response from the link above:
    You have searched for packages that names contain libarchive-tar-perl in suite(s) stable, all sections, and all architectures.

    Sorry, your search gave no results

    When trying to do the apt-get install libnetaddr-ip-perl libarchive-tar-perl, it says it will install the new packages but then says
    WARNING: The following packages cannot be authenticated!
    libio-zlib-perl libarchive-tar-perl libnetaddr-ip-perl

    and when I say to install them anyway, it cannot find the files.

    sources.list contains:
    deb etch main
    deb-src etch main

    deb etch/updates main contrib
    deb-src etch/updates main contrib
  11. till

    till Super Moderator Staff Member ISPConfig Developer

  12. jtheed

    jtheed Member

    Time to move it all over to ISPCONFIG3 then.
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Or update debian etch to lenny :)
  14. jtheed

    jtheed Member

    That is an option :) but I do already have am ISPCONFIG3 box running with Lenny on it. I guess I have to figure out which would be easier, update Etch to Lenny or move 6 or 7 web sites to the other server. If I go the update to Lenny route, do I need to avoid any version of Lenny or are all ok to upgrade to?
  15. oriongr

    oriongr Member

    Everything should be fine...go ahead and do the upgrade to lenny just keep the current conf files
  16. falko

    falko Super Moderator ISPConfig Developer

    Nothing to worry about. This probably happened because of an update from a version without the customized_templates directory to a version with the customized_templates directory. The new version definitely has the customized_templates directory.

Share This Page