ISPConfig reporting FTP server offline.

Discussion in 'Installation/Configuration' started by CSsab, Jan 14, 2011.

  1. CSsab

    CSsab New Member

    I installed ISPConfig on dedicated nameservers dns1 and dns2 as per Till's how-to here:

    I didn't install any ftp packages in these VM's of course. I installed ISPConfig like this:

    >> Initial configuration

    Operating System: Debian Lenny or compatible

    Following will be a few questions for primary configuration so be careful.
    Default values are in [brackets] and can be accepted with <ENTER>.
    Tap in "quit" (without the quotes) to stop the installer.

    Select language (en,de) [en]: en

    Installation mode (standard,expert) [standard]: expert

    Full qualified hostname (FQDN) of the server, eg server1.domain.tld [ns1.cooron]: ns1.example.tld

    MySQL server hostname [localhost]: localhost

    MySQL root username [root]: root

    MySQL root password []: xxxxx

    MySQL database to create [dbispconfig]: dbispconfig

    MySQL charset [utf8]: utf8

    Shall this server join an existing ISPConfig multiserver setup (y,n) [n]: y

    MySQL master server hostname []: myhost.example.tld

    MySQL master server root username [root]: root

    MySQL master server root password []: xxxxxxx

    MySQL master server database name [dbispconfig]: dbispconfig

    Adding ISPConfig server record to database.

    Configure Mail (y,n) [y]: n

    Configure Jailkit (y,n) [y]: n

    Configure FTP Server (y,n) [y]: n

    Configure DNS Server (y,n) [y]: y

    Configuring BIND

    Hint: If this server shall run the ISPConfig interface, select 'y' in the 'Configure Apache Server' option.

    Configure Apache Server (y,n) [y]: n

    Configure Firewall Server (y,n) [y]: y

    Configuring Firewall
    Install ISPConfig Web Interface (y,n) [y]: n

    Configuring DBServer
    Installing ISPConfig crontab
    no crontab for root
    Installation completed.

    Everything is looking good except that the master server is reporting that one or more of my needed services is offline - "FTP server offline"

    I installed pure-FTP on ns2 to see if the Monitoring on the master server picked it up and stopped complained and it is now saying that all required services are online for ns2.

    Is there a part of the installation script I can modify to make it ignore FTP service?

    Thanks in advance.
  2. DKLeader

    DKLeader Member

    I had the same problem, but found out that in the control panel for some reason ftp was activated in "system".
    In "Systen" click on the server and check if fileserver is ticked.
  3. CSsab

    CSsab New Member

    Okay I see what you mean - same thing here.
    Thanks :)

Share This Page