ISPConfig Patch 2 released

Discussion in 'General' started by till, Aug 1, 2014.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    Unlikely that this is related to the update as the update did not change anything in this regard and also a ispconfig update never changes the configuration of existing websites. Please post the exact error message that you get in the browser.
  2. zbuzanic

    zbuzanic Member

    One of the websites:

    [Fri Aug 08 10:35:06 2014] [crit] [client x.x.x.x] (13)Permission denied: /var/www/ pcfg_openfile: unable to check htaccess file, ensure it is readable

    ls -all /var/www/*

    -rwxr-x--x 1 root root 127 Aug 8 10:19 .htaccess
    -rwxr-x--x 1 root root 40 Aug 8 10:19 .htpasswd_stats
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok. I'll check that on my test server.


    Yes, you're right. The issue was caused by the update. we will fix that in the p3 release next week.
    Last edited: Aug 8, 2014
  4. zbuzanic

    zbuzanic Member

    I did reconfigure permissions when updating, don't know if that's the problem?
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    It was a problem in the code, the issue is fixed now. But in any case it should have affected only websites that have been edited since the update in ispconfig as the .htaccess files get only altered when something gets changed in the site. the update itself does not trigger that.
  6. osyrixx

    osyrixx New Member

    same problem on my freshly installed ubuntu server
    thanks Till for fixing
  7. grungy

    grungy Member


    By default I disable some functions like exec in php.ini and this is a must be for 90% of hosters since I can not force users to upgrade Joomla and Wordpress. This protects a server from these outdated sites - attacker uploads a .php scripts and using exec can harm the server.

    Since exec is disabled ispconfig is useless. You can not add users, sites etc. Could you please add following patch:

    to file


    so the content of file looks like this

    export PHPRC
    export PHP_FCGI_MAX_REQUESTS=5000
    export PHP_FCGI_CHILDREN=1
    exec /usr/bin/php-cgi -d disable_functions="" -d magic_quotes_gpc=off -d session.save_path=/usr/local/ispconfig/server/temp
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    This patch is not needed as you can set already a separate php.ini file for the ispconfig server process and the ispconfig interface does not use exec, just add a file:


    with a custom php.ini that allows exec.

    This is only needed for centos servers. On Debian and Ubuntu, you have separate php.ini files by default for all php types so you just can leave the cli php.ini file untouched as it is for shall scripts only and disabling exec in a shell script would not make sense anyway.
  9. osyrixx

    osyrixx New Member

    I followed "The Perfect Server - Ubuntu 14.04 (Apache2, PHP, MySQL, PureFTPD, BIND, Dovecot, ISPConfig 3)"
    Under Webinterface E-Mail -> Mailing List I generated a maillist with name "testmich" and waited approx 5 min for the changes to take effect.
    When I try to mail to that list [email protected] from my external mailbox [email protected] (not hostet on ispconfig server) it does not work:
    Again, I followed "The Perfect Server - Ubuntu 14.04 (Apache2, PHP, MySQL, PureFTPD, BIND, Dovecot, ISPConfig 3)" step by step. This is a perfect new installation from scratch. Any other mailing is working without any problems.

    When I try to delete the list via terminal:
    The /etc/mailman/ is missing:
    When I try to create the file (found that on this forum) rmlist does it work, but the "User unknown in virtual mailbox table" error still exists. (sure I chmod x`ed it ;)):
    Running /usr/sbin/postmap /var/lib/mailman/data/transport-mailman manually after each create of a new maillist solves that error.

    As a conclusion Mailman is not working with Ubuntu running ISPConfig installed with "The Perfect Server - Ubuntu 14.04 (Apache2, PHP, MySQL, PureFTPD, BIND, Dovecot, ISPConfig 3)".
    Please fix that one.
    Last edited: Aug 11, 2014
  10. osyrixx

    osyrixx New Member

    Hi Till. Thanks for creating the Bug report about Mailman HERE and your ongoing support for this great project!

    I did some more invesigation:
    - the /etc/mailman/ script is missing on any of my installations
    - if I generate the file myself with content...
    ...I notice a
    - The files are created successfully with correct content:
    /var/lib/mailman/data/aliases ( example: dingdong: "|/var/lib/mailman/mail/mailman post dingdong" )
    /var/lib/mailman/data/transport-mailman ( example: [email protected] local: )
    /var/lib/mailman/data/virtual-mailman ( example: [email protected] dingdong )

    - The strange thing about it is that if I send a mail to the list it`s still rejected.
    - Manually running the postmap or genaliases command don`t solve the problem. Restarting both postfix and mailman don`t solve the problem either.

    - Call my crazy, but if I create A NEW ADDITIONAL LIST ([email protected]) either over ISPConfig or using command line tools the PREVIOUS CREATED ([email protected]) list does work and accept mails:
    - The new created list ([email protected]) rejects:
  11. grungy

    grungy Member

    Here is the thing I do not get. Is following a bug or a feature.

    1. Under Server Configuration/Web/Apps Vhost Settings I set Apps-vhost IP to xx.xx.xx.xx and click save
    2. I open /etc/nginx/sites-available/apps.vhost and there is
    3. I run update.php and reconfigure services
    4. I open /etc/nginx/sites-available/apps.vhost and there is
    listen 8081;
    - IP that I set in ISPConfig is missing.

    When I go to Apps Vhost Settings the IP is still showing in the field, and when I click save it is again saved to apps.vhost.

    So am I being paranoid or is this a bug?
  12. grungy

    grungy Member

    Even when I copy nginx_apps.vhost.master to /usr/local/ispconfig/server/conf-custom/install and change
    listen {apps_vhost_ip}:{apps_vhost_port};
    the IP part is ignored and NginX configuration fails.
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    ok. Please make a report in the bgtracker so we can check whats wrong.
  14. grungy

    grungy Member


    What config tempalte file is used to generate /etc/nginx/sites-available/ispconfig.vhost ?
  15. grungy

    grungy Member

  16. alpianon

    alpianon New Member

    I have followed the same guide, but even with patch 3 mailman does not work with Ubuntu 14.04 (I get the same errors as osyrixx), even if here it says "bug fixed"


Share This Page