ISPConfig Patch 5 released

Discussion in 'General' started by till, Oct 28, 2014.

Thread Status:
Not open for further replies.
  1. grungy

    grungy Member

    Hi Till,

    I think it would be a good idea to use --best compression option for gzip

    gzip -c


    gzip --best -c

    in /usr/local/ispconfig/server/cron_daily.php

    this would save some space.
  2. grungy

    grungy Member

    I added encryption to database backups on my ISPConfig server. Here is the line added to cron_daily.php after //* Compress the backup with gzip.

    if($retval == 0exec("mcrypt --keymode s2k-salted-md5 --algorithm rijndael-256 --mode cbc -p -k '".escapeshellcmd($clientdb_password)."' -u '".escapeshellcmd($db_backup_dir.'/'.$db_backup_file).".gz'");

    Could it be possible to replace gzip with mcrypt since is support compression?

    This is useful since ISPConfig support mount point for backup destinations therefore DB backup on cloud storage could be secured.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    I'll add it as feature request to the bugtracker. I dont think that its an option to replace gzip, but we might add this as an additional option.
  4. cjscully

    cjscully New Member

    I'm trying to update Ispconfig to version After extracting the archive I tried to run php -q update.php and got the following errors

    >> Update

    Operating System: 14.04.2 LTS (Trusty Tahr)

    PHP Warning: include_once(/usr/local/ispconfig/server/lib/ failed to open stream: No such file or directory in /root/ispconfig3_install/install/update.php on line 104
    PHP Warning: include_once(): Failed opening '/usr/local/ispconfig/server/lib/' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /root/ispconfig3_install/install/update.php on line 104
    PHP Notice: Undefined variable: conf in /root/ispconfig3_install/install/update.php on line 105
    Unable to resolve hostname

    I checked /usr/local/ispconfig and there is no 'server' directory. I have no idea how to fix this or why it would be missing.
    Any clues?
  5. aliazimov

    aliazimov New Member

    Hello, these days I installed - reinstalled my ubuntu 12.04 as it was written here Earlier the server worked fine, but now i`ve installed ispconfig and just added one site and reboot, it halt on "stopping configure virtual network devices [ok]". If i reboot system, it stops on when you can choose to ordinary or generic recovery mode. i choose "generic recovery mode", resume, ok and it boots fine then. i tried doing this on 2 server machines. result the same. please help and sorry for my english
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you configure the network card in ispconfig, or did you left network configuration disabled (which is recommended and the default in ispconfig)?
  7. aliazimov

    aliazimov New Member

    I've not changed anything. after installation reboot (success), then only
    1. added user
    2. added website
    then reboot. that's all
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Ubuntu 12.04 has a bug in the implementation of the _netdev option in fstab which can cause boot issues sometimes, edit /etc/fstab and remove


    from all lines where it appears. Then you should disable the network filesystem option in ispconfig system > server config to prevent that this flag is set for future websites.
  9. aliazimov

    aliazimov New Member

    thanx, i hope, this`ll help
  10. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    I don´t think that´s a good idea to use the clientdb_password.

    1. you can see the password in the process-list during the backup
    2. if you change the password, you can not restore older backups (decrypt and encrypt for older backups are not really solution)
  11. dmgeurts

    dmgeurts Member

    After updating to patch 6 my slave is reporting blank quota information. I've already manually edited "interface/web/sites/user_quota_stats.php" as per Do I need to wait until cron runs on the slave before it picks up the quotas? "repquota -avg" looks good to me...
  12. dogokientruc

    dogokientruc New Member

    PHP 5.4.34 form dotdeb and my own compilation 5.6.2 and 5.6.2 with OPC. ?
  13. dmgeurts

    dmgeurts Member

    User error... Turns out that while reconfiguring the services on the slave machine I just entered through the defaults which changed the hostname for the SQL server. Reverted the server and all is well. [doh!]
  14. aliazimov

    aliazimov New Member

    Hello, I have a problem that it is not clear how to solve. Server - Ubuntu 14.04, ISPConfig Version:, the server has multiple sites, setting at all sites are the same, but one of them runs normal a couple of days and then comes an error, ie the site stops responding to, works only with All other sites work just as before. Maybe because the site begins to admin? .htaccess changes do not help
  15. dmgeurts

    dmgeurts Member

    Best to start a new thread.
  16. aliazimov

    aliazimov New Member

    That is the problem. I have tried several times. If another domain name - no problem, if eg - the problem appears
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    This is an old release thread, I'll close that now. Please make a new thread if you need help for a current version.
Thread Status:
Not open for further replies.

Share This Page