ISPConfig 3.1.15p3 and Wordpress

Discussion in 'Server Operation' started by Dale-Hutch, Jul 17, 2020.

  1. Dale-Hutch

    Dale-Hutch New Member


    I've set up a WordPress site on my ISPConfig server. The initial setup went without issues. But I find that I can't update plugins or install anything through the Dashboard. I keep getting "Installation failed: Could not create directory" I looked on the server when when I try to uploade or update a plugin and a folder is created using the www-data:www-data username and group, not the Web##:Cleint## like the other folders.
    So I checked to see if www-data was in the client## group. Yes. it is. WordPress is connecting find using FTPwith the created FTP user on ISPConfig. Why is it using the www-data user name and group instead of Web##:Client##?
  2. Dale-Hutch

    Dale-Hutch New Member

    Nevermind. Saw an older set up thread needed to chmod the web folder to 777.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Never set the web folder to 777. Undo this change as it is really bad for security.

    The reason for your issue is that you either selected a wrong PHP mode or disabled suexec.

    The PHP mode must be PHP-FPM or PHP-FCGI and the suexec checkbox must be enabled.
  4. Dale-Hutch

    Dale-Hutch New Member

    Yea. I figured that was bad. No security... Everything works!
    I do have suexec and PHP-FCGI checked when I installed WordPress. I must have something else down.
    Since this is a new install with nothing, I'll rebuild it with PHP-FRM and see how that works out. I think I saw during the building of the server that PHP-FRM is disabled by default. If so, I'l enable that in Apache.

  5. till

    till Super Moderator Staff Member ISPConfig Developer

    No, just follow our installation instructions when installing ISPConfig, you can find them at, do not do anything else. Beside that, there is no issue with PHP-FPM on your server. You just either use a wrong PHP mode or suexec is not on as PHP just runs as a wrong user.
    Th0m likes this.

Share This Page