ispconfig 3.1 in a multiserver setup - mailman urls wrong

Discussion in 'HOWTO-Related Questions' started by Werner Polgar, Apr 9, 2017.

  1. Werner Polgar

    Werner Polgar New Member

    I followed the HOWTO and installed ispconfig 3.1 in a multiple server setup (web1, mail1, db1, dns1, dns2) using Debian 8.
    The mailing list server mailman was installed on the mail host mail1. Using the ispconfig panel I am able to create and delete mailing lists on the mailman installation. Also mailman itself seems to work without a problem. However. I have a cosmetical issue when creating mailman lists.

    When I create a new list for the domain "my.virtual.domain" the owner of the list receives a confirmation mail that the list was created. The links inside this mail pointing to the mailman installation are wrong and contain links to the webserver "web1", for example hteeteep://

    Because there is no mailman installation on "web1" (where "my.virtual.domain" is hosted) the links do not work.
    How can I change the links in the list creation notification mail, to

    a) make use of https links and not http
    b) point to the mailserver (running mailman), like this.. hteeteps://mail1/cgi-bin/mailman/admin/mylist

    I already tried setting DEFAULT_URL_PATTERN from "hteetee://%s/cgi-bin/mailman/" to "hteeteeps://mail1/cgi-bin/mailman/" in but I think the change is rolled back by the ispconfig cronjob /usr/local/ispconfig/server/, running each minute..

    (sorry: I am not allowed to post links here, so I had to think different :)
    Any hint appreciated.
  2. ledufakademy

    ledufakademy Member

  3. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    I asked you before, please don't revive old threads, but create a new one and eventually refer to a related thread.
    ledufakademy likes this.
  4. ledufakademy

    ledufakademy Member

    ok sorry.

Share This Page