ispconfig 3 url loads apache-tomcat (it works !) default page

Discussion in 'Installation/Configuration' started by makoshark, Mar 16, 2017.

  1. makoshark

    makoshark New Member

    I have tried to install ISPconfig several ways but can never get the login page to load.
    I have installed from ispconfig_setup-master and ispconfig3_install/install both from a local download and a wget URL to the /tmp folder
    I have installed and un-installed and reinstalled to no avail. The update.php does not change anything other then a chance to re-do the SSL cert.
    The closest I get is a default tomcat page with or and any attempt to use a secure address will get an error "SSL_ERROR_RX_RECORD_TOO_LONG". none of my registered URL's will do different.
    this is an page I get: [​IMG]
    I have Config-server & firewall of and I do not have Ubuntu firewall on
    My setup is a HP xw9400 workstation with 32 Gig's RAM Quad-Core AMD Opteron Processor 2380 × 8 and dual Nvidia video and NIC's
    Ubuntu 14.04.5 server/Ubuntu/Gnome for the OS as I hate not using a GUI. Since TWC want my first born for a static IP I use noip-duc-linux however It never was need to load the IP's on my extensive LAN (3 boxes at my desk, 2 phones w/4 lines and 2 PC's in other rooms)
    I had Virtualmin installed but wanted a simpler interface and not wanting a user for every email I want off the same domain, and yes virtualmin/webmin was purged before installing ISPconfig 3
    I have also removed SUexec as I have already found ISPconfig does not play nice with this. I have checked the FQDN permissions. The setup seems to be for /var/www/html but it can't get to the Apache2 Ubuntu Default Page. My apache directories seem to have multiple "NameVirtualHost" listed in the added ISPconfige .vhost files? shouldn't this have the FQDN?
    Since I an not sure of the how with ISPconfig I have not tried rel-installing a default Ubuntu LAMP server. This had been done and was working previously. Perhaps the Tomcat left by Virtualmin is a problem?, but I would not know why
    maybe I will see what happens on RHEL 6.8 ot 7.2 as I have multiple HD's and OS'es or go back to Virtualmin that does work!
    thank James Niland

    Attached Files:

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Just follow one of the installation guides that are listed here:

    The installation must fail if you did not install all the system requirements first that are described in the perfect server installation tutorials and it must fail if you don't start with a clean system. So if you had another controlpanel like virtualmin installed, then the server must be formatted, just uninstalling virtualmin will not remove the changes that virtualmin made to the system which will prevent other control panels from working.

    The exact opposite is the case, ISPConfig does not work without suexec. But that's all described in the installation tutorial that you did not seem to have followed.
  3. makoshark

    makoshark New Member

    Well I did in fact read
    and when virtualmin was removed via synaptic s I also purged all configuration files as it has an option for complete removal
    as far as starting over, absolutely no way! I have very specific needs as I am disabled and it would take days to set it all up again
    I am disappointed that the requirements never said a clean install 6 days wasted
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The problem is that this option does not work as you see on your system. If it worked, then tomcat would not be there anymore and all the changed that virtualmin made in the config files which prevent ispconfig from working would have been undone as well, but they are stil there and tomcat is still there as well, so your setup failed.

    The tutorial clearly said that you need a minimal basic installation as basis, I'll cite from the tutorial "Before proceeding further you need to have a basic minimal installation of Ubuntu 14.10 as explained in tutorial.".

Share This Page