ispconfig and mambo

Discussion in 'Installation/Configuration' started by shajazzi, Jan 2, 2006.

  1. shajazzi

    shajazzi Member

    I installed suse 9.3 and ispconfig OK
    Logged into ispconfig created reseller,client and new site.

    Then i checked to see if the folder was created srv/www/
    I then extracted Mambo V4[1].5. -stable tar gzto this folder.
    i opened a Firefox browser and typed and I then get stuck with the following error.

    The connection was refused when attempting to contact

    I then tried again with this and recieved the following:

    Object not found! :confused:

    The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again
    If you think this is a server error, please contact the webmaster.
    Error 404
    Sun Jan 1 23:57:03 2006
    Apache/2.0.53 (Linux/SUSE)

    Virtual Server Configuration
    Use the following form to add special port that you want to be opened for your special application

    ID Port Port Port Map Host Private
    (From) ~ (To) Type To IP Address Port

    1 25 ~ 25 TCP ---> *
    2 49 ~ 49 TCP ---> *
    3 80 ~ 80 TCP ---> *
    4 110 ~ 110 TCP ---> *
    5 81 ~ 81 TCP ---> 81
    6 80 ~ 80 TCP ---> *

    I have forwarded the port in my rooter box but i am still getting errors.
    Can anybody please help?
    Thanks in advance

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    All webpages in ISPConfig have to be in the web subfolder. You must extract joomla to this directory:

  3. falko

    falko Super Moderator Howtoforge Staff

    Is's DNS record pointing to the correct IP address?
  4. shajazzi

    shajazzi Member

    Thanks for the speedy response falko and till,

    When i extract mambo every thing gets duplicated and ends up in srv/www/ with the original extraction being srv/www/

    I`ve checked the DNS record in ispconfig.

    IP-Adresse ......... Hostname ........ www

    Mailserver ........ Hostname ....... www

    Last edited: Jan 2, 2006
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    How did you download and extract joomla on your server?
  6. shajazzi

    shajazzi Member

    I`ve put the zipped up folder on my desktop.
    Right clicked on the folder.....Extract to.....Select folder Ark the tree i selected srv/www/
    Clicked ok at the bottom of Ark.... this window closes and then i click ok on pop up window that is headed
    Extract files from joomla_1.0.5-Stable-full_Package.t.

  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, thats the problem. You must select:

    srv/www/ as destination, not srv/www/
  8. shajazzi

    shajazzi Member

    Ok thanks till i`ll try that.

  9. shajazzi

    shajazzi Member

    Ok i`ve installed into srv/www/ after deleting from ispconfig and the recycle bins and the remade This time a folder called web3 was made so i checked srv/www/web3/web and joomla files are duplicated in here.
    I then tried to get joomla installation page up........Nothing but errors.

    I tried the following:

    Any ideas would be appreciated.

    Last edited: Jan 2, 2006
  10. shajazzi

    shajazzi Member

    Could my router box be causing the problem?
    Is it that i am already running Windows xp server on the same router box?
    Do i have to delete the settings from the router box for windows xp for ispconfig to work?

    Has anybody got any suggestions?

  11. shajazzi

    shajazzi Member

    OK when i dele the settings for windows xp sever from the router box I sometimes get this page come up.

    Shared IP


    This IP address is shared. For access to the web site which you look for, enter its address instead of its IP.

    For questions or problems please contact the server administrator.


    powered by ISPConfig

  12. falko

    falko Super Moderator Howtoforge Staff

    You must forward all neded ports (e.g. 80 and 81) from your router to your ISPConfig box.

    In order to avoid seeing the Shared IP page, you must use in your browser's address bar to access, nothing else (e.g. IP address, ...).
  13. shajazzi

    shajazzi Member

    Yes falko spot on,:D :D
    I pointed all ports to ispconfig and deleted all ports pointing to Windows XP Pro server.
    I just had to change the permissions in web2 to allow joomla to install.

    However there must still be a permission problem because i cannot install any modules or components through Joomla back end.

  14. falko

    falko Super Moderator Howtoforge Staff

    Any error messages?
  15. shajazzi

    shajazzi Member

    Yes, the the error messages i am getting are:

    Upload component - Upload Failed
    ERROR: Could not find an XML setup file in the package.
    [ Continue ... ]
    Upload component - Failed
    Installation file not found:
    [ Continue ... ]

    I checked the component and the XML does exist

    Also i get similar errors when trying to install modules.

    Last edited: Jan 5, 2006
  16. falko

    falko Super Moderator Howtoforge Staff

    This looks as if it'S entirely related to Joomla. Did you ask the Joomla guys?
  17. shajazzi

    shajazzi Member

    I haven`t as yet,Although i still think it`s a permissions problem somewhere. I tried to load the joomla patch and it just gets kicked out. Meanwhile I`ll give joomla forums a go and let you know how I get on.:confused:

  18. falko

    falko Super Moderator Howtoforge Staff

    To which directory does Joomla try to upload the file? What are the permissions of the directory, to which owner and group does it belong?
    Who is your Apache owner and group?
  19. shajazzi

    shajazzi Member

    I`ve deleted joomla and installed a copy of mambo that installs on my windows server Ok every time.
    When i installed it to it installs ok but i still can`t install any new components or modules.

    My apache owner is root and group is root

    Owner: can view & modify content
    Goup: can view content
    Others: can view content


  20. Blu3

    Blu3 New Member

    I use Joomla on several different sites, and it works great and have never had any problems install modules or components onto it.

    How and where are you trying to upload from?

    Incase you havent tried yet, at least what works for me, download the .zip or .gz file to your Linux Desktop, then in the Install Components page in your Joomla Admin area, there are 2 options of install. 1) is "Upload Package File" and 2) is "Install from directory", obviously install from directory and use the path to the appropriate file on your desktop. You shouldnt even need to unzip/gunzip it, as Joomla will handle this for you :)

    Also under Install from directory, please be sure that yours looks like this:

    media/ Writeable
    administrator/components/ Writeable
    components/ Writeable
    images/stories/ Writeable

    And if not, then a simple chmod 700 -R to your joomla dir will fix that.

    Hope this helps.

Share This Page