ispconfig built-in backup not backing up db.

Discussion in 'General' started by blackfox123, Jun 27, 2017.

  1. blackfox123

    blackfox123 Member

    Hey all,

    For a site, I can see website backup archives done on a daily basis, but it seems the mysql db backup files stopped generating last week.. how do i debug this?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you change the MySQL root password? If yes, change it in /usr/local/ispconfig/server/mysql_clientdb.conf as well.
  3. blackfox123

    blackfox123 Member

    ls: cannot access /usr/local/ispconfig/server/mysql_clientdb.conf: No such file or directory

    this is on the db server or webserver it should backup from ?
  4. blackfox123

    blackfox123 Member

    /usr/local/ispconfig/server/lib/mysql_clientdb.conf it is - but this is the correct pass
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    ah yes, sorry. wrong path. Ok, so this is correct then. In the database settings in ispconfig, is there a website seletced to which the database belongs to?
  6. blackfox123

    blackfox123 Member

    Yeah, i can see the db is "bound" to a website. I just pressed save again to be sure.. is there anyway of "forcing" the backup to run? else all what i see is correct -
  7. till

    till Super Moderator Staff Member ISPConfig Developer

  8. blackfox123

    blackfox123 Member

    OK so having tried that, php /usr/local/ispconfig/server/cron_debug.php i can see :

    root@dba01-sysp:/usr/local/ispconfig/server/lib/classes/cron.d # php /usr/local/ispconfig/server/cron_debug.php

    The response is immediate - it doesnt really go much aside from output that..

    EDIT: Sorry this is running OK on the webserver.. but still does not create the SQL backup dump only the webfiles.
    Last edited: Jun 27, 2017
  9. Dhraax

    Dhraax New Member

    Hello, same issue here, i run:

    php /usr/local/ispconfig/server/cron_debug.php

    Does not show anything just "finished." but, in the backup list on user panel i just see

    10-07-2017 19:31 web web2312_2017-07-10_16-30.tar.gz
    But not the db files.

    How can i debug this? Seems to work for some older clients but not for this one that was not updated, but instead installed the 1.3.3 directly.
  10. renaudmanda

    renaudmanda New Member

    same story here.... I've website backup inside /var/backup but now db backup. Run the cron in debug mode but I've no more info in the log file.
    Password are OK and a manual mysqldump work.
    here my version of MariaDB:
    mysqld  Ver 10.1.26-MariaDB-1~xenial for debian-linux-gnu on x86_64 ( binary distribution)

Share This Page