ISPConfig do not use email from Wordpress setting

Discussion in 'General' started by smithjez, Apr 20, 2020.

  1. smithjez

    smithjez New Member

    ISPConfig do not use email from Wordpress settings (e.g. admin(at sign)
    It uses webmaster(at sign)
    We have our own SMTP server (MS Exchange) and webmaster(at sign) is not exist on our server.

    So, when the email send out from ISPConfig, it stuck in spam filter.

    It looks like I am not correctly configure ISPConfig. Is there any recommendations to this issue?
    Last edited: Apr 20, 2020
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    It's actually a WordPress config and not ISPConfig setting. Configure WordPress to use SMTP for sending instead of using PHP mail() function.
  3. smithjez

    smithjez New Member

    Actually, I migrate Wordpress from CentOS WebPanel (using Duplicator plugin) which used to work fine.
    It should not change any configuration.
    But I'll try to looking for it. Do you have any advise where can I change that?
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Using Internet Search Engines with
    How to Use SMTP Server to Send WordPress Emails
    seems to find promising hits.
    But on my ISPConfig wordpress can send e-mails without extra configuration. Maybe your old configuration from WebPanel confuses issues?
    smithjez likes this.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    CentOS web panel has a less strict security and spam prevention setup than ISPConfig.

    There are various plugins for that, e.g.:
    smithjez likes this.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    It is indeed working fine without extra settings. The problem of the original poster is caused by his exchange server which lacks the webmaster email account.
  7. nhybgtvfr

    nhybgtvfr Well-Known Member HowtoForge Supporter

    as already pointed out, wordpress settings are for wordpress, and nothing to do with ispconfig.

    and in fact the wordpress email settings that are being mentioned, ([email protected]) are not actually for sending mail from that address, there's an administrative address, that is an address it sends warnings/alerts etc TO
    or there's a pop account, its supposed to be for wordpress to receive and publish posts/pages via email, its not for sending email at all.
    until you install and configure a contact form, woocommerce or other plugin that requires wordpress to be a source of customer sourced/destined emails then there is nothing in wordpress to specify the sending address that wordpress uses.
    ispconfig appears to send all website generated mail as [email protected]

    that said, my opinion is all webservers should be blocked from making a connection to any external network with a destination port of 25.
    All websites should access an external smtp server using an email account under the site owners control, using port 465 or 587 only. this way all outbound mail is authenticated, not reliant on a local postfix install, or phpmail etc. this way if any site is compromised, even if the hacker installs their own smtp sender, the server is still completely unable to send out unauthenticated emails, and website generated email will not be affected by a compromised site, or unscrupulous bulk sender getting the webservers ip blacklisted.
    Last edited: Apr 20, 2020
    smithjez likes this.
  8. smithjez

    smithjez New Member

    I am using SMTP plugin which is work fine by now.
    Is this means using SMTP plugin is also not recommend?
  9. nhybgtvfr

    nhybgtvfr Well-Known Member HowtoForge Supporter

    just the opposite, it means if you want to send emails from within wordpress then an smtp plugin is required.
    it's no longer sending emails out directly from that webserver, instead wordpress would be logging into whatever mailserver you use for the from domain you choose and sending emails directly from that mailserver.
    smithjez likes this.
  10. kameleon1er

    kameleon1er Member

Share This Page