ISPConfig Installation problems ubuntu 8.04

Discussion in 'Installation/Configuration' started by Counterculture, Jun 26, 2008.

  1. Counterculture

    Counterculture New Member

    I follow the perfect setup and I'm getting a error on install . which reads as so

    Checking for program httpd...
    Checking the syntax of the httpd.conf...
    httpd: bad user name ${APACHE_RUN_USER}
    ERROR: The syntax of your httpd.conf is not ok! Please correct the error. The installation routine stops here!

    not sure what is wrong . Thanks
  2. falko

    falko Super Moderator ISPConfig Developer

    Do you use the latest ISPConfig version?
  3. biobrew

    biobrew New Member

    Since you're installing under ubuntu I'd say make sure you're doing every single command as sudo, or do sudo -i to have persistant sudo.

    I went to debian etch simply because of having to type in sudo over and over and over on ubuntu. And with the perfect server setup for debian etch I was able to copy and paste every command from this site and it worked perfectly without incident.
  4. kolipoki

    kolipoki New Member

    ISPConfig installation in Ubuntu 8.04

    Bio, the how-to was described as done with the root user, therefore removing the sudo command. If I'm wrong some one please correct me. ;)

    BTW, Im a total noob, can't find the install_ispconfig directory to delete for restarting installation procedure. Can some one point me to it? Or, what's the command line for deleting it? Thanks in advance...
    Last edited: Jun 27, 2008
  5. biobrew

    biobrew New Member

    Try this, it seems to be the same problem

    I think above from what you posted you're trying to run apache not as sudo or not as root. Maybe you rebooted your machine and then tried to run the command (not as root the way the perfect server set up does it in the beginning)

    Does it help to run the same command(s) as sudo? Or is it the same?

    For me on ubuntu machines I find it easier to just sudo -i right when I login if I know I'm going to be doing something administrative.
  6. tensor

    tensor New Member

  7. unsichtbare

    unsichtbare Member HowtoForge Supporter

    I have temporarily given up on 8.04, just too many problems, especially as a VM. I am sticking with 7.10 for now.


Share This Page