ISPconfig - installed - services issues

Discussion in 'Installation/Configuration' started by bskrakes, May 7, 2007.

  1. bskrakes

    bskrakes New Member

    Hi there,

    Well I am a newbie to this ISPconfig but so far I think it rocks. I have installed it and have it running, however I am having problems with the services. Right now my FTP, SMTP/POP3 and BIND is not running on the service. I try to do the "re-start" but nothing happens. I have made sure each program is installed but I don't know where to go from here.....

    Please help... thank you for all of your time.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Does smtp, ftp and pop3 services are listening on localhost on your server? Please post the output of:

    netstat -tap
  3. bskrakes

    bskrakes New Member

    here is the output:

    [[email protected] ~]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost:2208 *:* LISTEN 1950/hpiod
    tcp 0 0 *:mysql *:* LISTEN 2092/mysqld
    tcp 0 0 *:netbios-ssn *:* LISTEN 2220/smbd
    tcp 0 0 *:1006 *:* LISTEN 1672/rpc.statd
    tcp 0 0 localhost:783 *:* LISTEN 2123/
    tcp 0 0 *:sunrpc *:* LISTEN 1651/portmap
    tcp 0 0 *:hosts2-ns *:* LISTEN 2508/ispconfig_http
    tcp 0 0 urhostingpro.websrv:ipp *:* LISTEN 1967/cupsd
    tcp 0 0 urhostingpro.websrv:smtp *:* LISTEN 5407/master
    tcp 0 0 localhost:smtp *:* LISTEN 2143/sendmail: acce
    tcp 0 0 *:microsoft-ds *:* LISTEN 2220/smbd
    tcp 0 0 localhost:2207 *:* LISTEN 1955/python
    tcp 1 0 urhostingpro.websrv:48142 CLOSE_WAIT 2267/python
    tcp 1 0 urhostingpro.websrv:53430 CLOSE_WAIT 2267/python
    tcp 1 0 urhostingpro.websrv:36096 fpserv.fedoraproject.o:http CLOSE_WAIT 2267/python
    tcp 0 0 *:http *:* LISTEN 2537/httpd
    tcp 0 0 *:ssh *:* LISTEN 1981/sshd
    tcp 0 0 sdm.websrv:ipp *:* LISTEN 1967/cupsd
    tcp 0 0 *:https *:* LISTEN 2537/httpd
    tcp 0 148 urhostingpro.websrv:ssh ::ffff:192.168.0:whosockami ESTABLISHED 3374/0

    i am guessing we are looking for the needed ports.... i dont see them. thanks till, hope we can figure it out!
  4. kippi

    kippi New Member


    One thing that has helped me in the past is to start the services from the command and then you can see if they error or not. If they do error you can see why and maybe sort it that way,

    Its just something I have done before, may help or may not.

  5. bskrakes

    bskrakes New Member

    Hey! thanks for that tip.... but i already tried that, that was one of the first things i tried. see when a service doesn't start the way the intended program wants it to, 9 times out of 10 it is because of user input error - like a config setting is off or missing and even a dependent package. at least thats what is has been in most of the problems i've had.

    thanks for your input!
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the exact error message that you get when you try to start the service and post any errors from your syslog or messages log that appear when you try to start the services.
  7. bskrakes

    bskrakes New Member

    I don't receive any errors. If I do service vsftpd start it starts normally but the ISPconfig interface does not recognize or see that it is started, the same for the SMTP/POP3 and BIND services.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    The problem is not thet the ISPConfig interface did not recognize it, the problem is that your services are not started at all according to the netstat output. So this is not a ISPConfig problem, it is a general problem on your linux system.

    Did you install your server according to the perfect setup guides?
  9. bskrakes

    bskrakes New Member

    Yes, I used a step by step guide to install ISPconfig. I can try again, is there a specific guide you can recommend? I am installing ISPconfig on Fedora Core 6.

    Thanks Till.
  10. till

    till Super Moderator Staff Member ISPConfig Developer

  11. bskrakes

    bskrakes New Member


    So I read through that guide.... My install is almost identical minus the office and productivity applications. I did choose to install them as I wanted to use X Windows.

    Can you set netstat to have those services started? I know that if you wanted those services to start you would run a command like :services "name" start and chkconfig "name" on. When I do that it still does not change the netstat output.

    I think I am going to try reinstalling but I would like to avoid it if I can...

    Let me know, thanks again Till.
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you have SELinux disabled?
  13. bskrakes

    bskrakes New Member

    yes I have it disabled and the fire wall to....
  14. falko

    falko Super Moderator ISPConfig Developer

    Are you sure you followed the tutorial as close as possible? Because I use Proftpd in that tutorial, not vsftpd...
    Are BIND and dovecot installed on your system?
  15. bskrakes

    bskrakes New Member

    I did not have Dovecot installed but everything else was installed. The other thing I did not do was the quota settings (it is included on the main install requirements screen and I failed to read that).

    I did reinstall some what to the guides settings and got it to work. All of my services startup. I am glad that guide is there because some of it I never would have known to do if it wasn't in that guide - EXAMPLES, dovecot, quota settings, smtp rsa/key settings (thought those would be automatic). The other reason I think my first install did not work was because the services were not started before I ran the ISPCONFIG setup......

    I like ispConfig but it took a long time to install and the setup was more painful then I thought it would be - that could because I am not a LINUX GURU and still many things I don't know about. I did set it up on a Virtual Machine so I might try it again from scratch (gotta love snapshot and revert option).

    Thanks falko and till, much appreciated! This Web hosting control panel software really is top notch!


Share This Page