ISPConfig Mailman create and used

Discussion in 'General' started by andresgt2000, Oct 21, 2014.

  1. andresgt2000

    andresgt2000 Member

    Hello everyone!

    I have a doubt about mailman in ISPConfig.

    I created a test list in ISPConfig, enter the mailman administrator and add some post members.

    Priate I attempt to send an email to the list from my thunderbird I get a message saying that the account does not exist [email protected].

    Reading this article it seems that there should be a file called virtusertable in the folder / etc / postfix but this file is not.

    Article also shows that an alias be created to mailing list but does not appear.

    What am I doing wrong?

    Mi ISPConfig version is

    I remain attentive to your comments.

    Note: When I run the command list_members and list_lists, the correct information is displayed.
  2. andresgt2000

    andresgt2000 Member

    Update of thread

    I found the following error in the logs.

    warning: database /var/lib/mailman/data/virtual-mailman.db is older than source file /var/lib/mailman/data/virtual-mailman

    I started a search and found the following article HowtoForge

    The article talks CFOO the problem is due to "relay = dovecot" Till in this article indicates that it will make changes in ISPConfig to work properly.

    According to article I checked the changes and they were properly applied to my installation of ISPConfig. However, still unable to send mail to the list.

    I found another article posed an identical behavior.

    I followed the instruction on the implementation of Till postmap and it worked for me :D.

    Now I can see how it is correctly sent the mail to the list according to the log.

    mail2 postfix/local[9136]: E4552209CE: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=0.15, delays=0.01/0.01/0/0.12, dsn=2.0.0, status=sent (delivered to command: /var/lib/mailman/mail/mailman post test

    But now another error appeared; this time directly concerns the mailman, because the mail is not sent to the members of the list. :eek:

    I have reviewed the mailman error logs and found the following errors:

    ==> error <==
    Oct 21 17:50:40 2014 (2227) Uncaught runner exception: [Errno 13] Permission denied: '/var/lib/mailman/data/heldmsg-test-1.pck'
    Oct 21 17:50:40 2014 (2227) Traceback (most recent call last):
    File "/var/lib/mailman/Mailman/Queue/", line 120, in _oneloop
    self._onefile(msg, msgdata)
    File "/var/lib/mailman/Mailman/Queue/", line 191, in _onefile
    keepqueued = self._dispose(mlist, msg, msgdata)
    File "/var/lib/mailman/Mailman/Queue/", line 130, in _dispose
    more = self._dopipeline(mlist, msg, msgdata, pipeline)
    File "/var/lib/mailman/Mailman/Queue/", line 153, in _dopipeline
    sys.modules[modname].process(mlist, msg, msgdata)
    File "/var/lib/mailman/Mailman/Handlers/", line 112, in process
    Hold.hold_for_approval(mlist, msg, msgdata, Hold.NonMemberPost)
    File "/var/lib/mailman/Mailman/Handlers/", line 224, in hold_for_approval
    id = mlist.HoldMessage(msg, reason, msgdata)
    File "/var/lib/mailman/Mailman/", line 199, in HoldMessage
    fp = open(os.path.join(mm_cfg.DATA_DIR, filename), 'w')
    IOError: [Errno 13] Permission denied: '/var/lib/mailman/data/heldmsg-test-1.pck'

    Oct 21 17:50:40 2014 (2227) SHUNTING: 1413935439.919427+5746936da0a9b72bf8ecddca78e1ed6d48286c

    I suppose the error is due specifically to the permission but also see other errors regarding py file

    Some idea. :confused:
    Last edited: Oct 22, 2014
  3. andresgt2000

    andresgt2000 Member

    It's alive... the creature it's alive!!!!

    Just needed change the permissions.

    I executed this comand:

    /usr/lib/mailman/bin/check_perms -f

    I read the solution in this link.

Share This Page