ISPConfig over https has unsecured elements

Discussion in 'Installation/Configuration' started by Nap, Mar 3, 2016.

  1. Nap

    Nap Member

    I modified the "Powered by" URL to use https instead of http, and I've checked the source for the remainder of the page and everything seems to be going over https. However the browser is still indicating that some content is delivered insecurely. I'm looking at the Website list page at the moment.

    Anyone know what that content might be?
  2. Nap

    Nap Member

    Nevermind, I needed to flush my cache. Now it's fine.
    (Using FF35)
  3. Nap

    Nap Member

    I don't know why, but this is an ongoing problem.
    As I write this post in FF35, I'm showing a fully encrypted page, but after a period of time (a day or so), it becomes partially encrypted. A ctrl-F5 cache refresh fixes it. (Though it shouldn't need it.)

    On Google Chrome v48.0.2564.116, I cannot get a fully encrypted page no matter what. So the lock is always displayed with a cross through it.

    I've looked at all the url's that are on the page and they are all https, including the "Powered by...".

    Anyone know what's causing this?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you try to open the chrome developer console? Maybe you can see the reason for the issue there.
  5. Nap

    Nap Member

    Yes, and Firebug with FF. All content shows as https.
    I tried Chrome, which is a vanilla setup, because my FF is heavily loaded with addons and is my main browser. I will check my IE10 and report back later.

    I just tried Chrome again and now it's fine. This is very strange behaviour that I can't explain.

Share This Page