ispconfig proftpd login error 503 solution

Discussion in 'Installation/Configuration' started by tuyre, Nov 14, 2007.

  1. tuyre

    tuyre New Member

    I did a fresh install of ISPConfig on Fedora 8, following the Howtoforge 'Fedora 8 Server Setup: LAMP, Email, DNS, FTP, ISPConfig'.

    After creating a client and site, I was not then able to FTP to the site, and kept getting login error 503. I had previously had it working OK on another box, so didn't know what the problem was. I searched forum after forum, and none of them solved it.

    I finally solved it after simply uninstalling and re-installing the proftpd package using the following steps:

    yum remove proftpd
    yum install proftpd
    chkconfig --levels 235 proftpd on
    /etc/init.d/proftpd start

    The last 2 lines ensure that proftpd starts automatically when the server is rebooted.

    This fix may not work for everyone, but for those with the same problem as me, it's a life-saver. I think ISPConfig adds some dodgy lines to the proftpd.conf file, and a re-install does the trick.

    Last edited: Nov 14, 2007
  2. AsDsL

    AsDsL New Member

    Same problem, working now.

    Thank you!
  3. cwright55

    cwright55 New Member

    This same problem pagued me for two days, and I searched many forums and read many replies to the problem, but this is the only one that actually said what to do, and best of all, it worked!

Share This Page