ispconfig setup and mysql

Discussion in 'Installation/Configuration' started by glt50, Jun 19, 2006.

  1. glt50

    glt50 New Member


    I have done the dumbest thing and need some help. I cannot remember my MYSQL password, so in setting up ispconfig, it askes me for mysql password and every password I enter is invalid and I cannot progress my installation.

    How can I overcome this problem? Can the password be reset? And if it can, can the password be changed while the ispconfig program is halted and waiting for my password?

    Glen :mad:
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can try this:

    1) Login with a second SSH session to your server.
    2) Stop the mysql daemon:

    /etc/init.d/mysql stop

    3) Start mysql with the following command:

    mysqld --skip-grant-tables

    4) Login to mysql with the mysql command and reset the root password:

    mysql -u root
    UPDATE mysql.user SET Password=PASSWORD('MyNewPassword') WHERE User='root';

    Replace MyNewPassword in the commands with your new password.

    5) Stop mysql:

    killall mysqld

    6) start the normal mysql daemon again:

    /etc/init.d/mysql start

    7) Proceed with your ISPConfig installation.

    The steps above may vary depending on your linux distribution.
    Last edited: Jun 19, 2006
  3. stand-up

    stand-up New Member

    Same Thing But about passwd (Sorry !!!) need Help !

    I have a good installation of Ubuntu server 6, updated, and a successful installation of IspConfig: OK
    I change the password admin and I am not any more able to connect, to log on to IspConfig.
    I try to connect to phpmyadmin, I try to change the admin password, but no success at all!! (Very fun, for me!!!)
    Could somebody help me, I have been for more than 2 hours in front of the machine, and I receive the same answer when I connect to IspConfig ( Ialso try to use a null passwd, but no success):

    Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: YES) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 78

    Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: YES) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 78

    Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:78) in /home/admispconfig/ispconfig/web/login/login.php on line 56

    Thanks for the support
    Last edited: Jun 19, 2006
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The mysql user and password ISPConfig uses to connect to the database is stored in the file /home/admispconfig/ispconfig/lib/

    If this username and password are incorrect, you will get the errors that you posted above.

    Reset the mysql root password like i described in the post above and then put the new mysql root password in the ISPConfig file.
  5. Dimitriy

    Dimitriy New Member

    Can you please sticky post #2?

    Help me so many times...... :)
  6. godsdog

    godsdog New Member

    I had same MySQL problems

    Hi. I had exactly the same errors of not being able to enter either of the following commands during Perfect Fedora Core 5 Setup...
    mysqladmin -u root password yourrootsqlpassword
    mysqladmin -h -u root password yourrootsqlpassword
    Both returned the same error as explained at the root of this thread.
    At the end of ISPConfig install I encountered this and just used the user admin with no pass...
    Please enter your MySQL user:admin
    Please enter your MySQL password:
    Please enter a name for the ISPConfig database (e.g. db_ispconfig):db_ispconfig
    Then after a few lines I noticed
    Please select the protocol (http or https (SSL encryption)) to use to access the ISPConfig system:
    1) HTTPS
    2) HTTP
    Your Choice: 1
    Connected successfully to MySQL server
    ERROR 1044 (42000): Access denied for user ''@'localhost' to database 'db_ispconfig'
    Restarting some services...
    And at the end of the install I get
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/ on line 47
    No results found!ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
    Obviously I can't login to the web interface to ISPConfig. Shall I reinstall all MySQL rpms and try installing ISPConfig or is there an easier way? Thanks again.
    Last edited: Jul 17, 2006
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    It is not nescessary to reinstall mysql, just set a new mysql root password as I described in post #2.

    You got the mysql install errors beacuse you did not enter a valid mysql password.

    1) Mkae sure your mysql database is listening on localhost. You can check that with:

    netstat -tap

    as described in the perfect setup howtos.

    2) Remove the directories /home/admispconfig and /root/ispconfig and install ISPConfig again.
  8. godsdog

    godsdog New Member

    You are right and I didn't look close enough when I peformed the netstat -tap command. This is what I get
    tcp        0      0 *:mysql                     *:*                         LISTEN      3310/mysqld
    It seems the port number is wrong?!? whoops...
    At any rate, here's what I get when I attempt a password change with the way things are at the moment.
    # mysqladmin -u root password password
    mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user 'root'@'localhost' (using password: NO)'
    Here's the sniped output of /home/admispconfig/ispconfig/lib/ if it helps
    $go_info["server"]["db_host"] = "localhost";
    $go_info["server"]["db_name"] = "db_ispconfig";
    $go_info["server"]["db_user"] = "admin";
    $go_info["server"]["db_password"] = "";
    $go_info["server"]["db_type"] = "mysql";
    I tried this to see if it is functioning
    # useradd -d /dev/null -s /bin/false root
    useradd: user root exists
    # useradd -d /dev/null -s /bin/false tester
    useradd: warning: the home directory already exists.
    Not copying any file from skel directory into it.
    Then I tried to telnet into it and got some weird characters
    # telnet localhost 3306
    Connected to localhost.localdomain (
    Escape character is '^]'.
    5.0.22\?giYa\+,\pA0jJr~DwKOConnection closed by foreign host.
    I've preformed all installations after the local via putty if it's any 'consol'ation
    Last edited: Jul 17, 2006
  9. godsdog

    godsdog New Member


    At any rate, unless you are interested in how I managed to muck this up, I plan on nuking the drive and installing this wonderful new version I noticed you released today. (I should have held off yesterday) but for the sake of learning, we'll just start from square one.
  10. falko

    falko Super Moderator Howtoforge Staff

    No, the port number is correct.
    Have a look here:

Share This Page