ISPConfig setup error with Debian Sarge

Discussion in 'Installation/Configuration' started by Rocky, Nov 5, 2005.

  1. Rocky

    Rocky Member

    I've done the perfect debian sarge setup with no errors. However, when i get down to setting up ISPConfig, i run into one.

    When it ask me for the following:
    Please enter the host name: E.g. www
    Please enter the domain: E.g.
    I put in www and, replacing with my domain name. But it gives me an error about the domain cannot be found or something similiar and the install aborts. Any suggestions?
  2. domino

    domino New Member


    Are you certain that the "hosts", "hostname" and "interfaces" config files are correct? The only thing I can think of is that the script is looking for a domain and IP address that matches the hosts file.
    Last edited: Nov 5, 2005
  3. falko

    falko Super Moderator Howtoforge Staff

    The installer tries to ping the FQDN you put in to make sure it exists. In your case it tried to ping So you have to make sure that exists in DNS and that the firewall (if there's one) does not block pings.
    If you don't have proper DNS records for your FQDN you can leave the host name empty and enter the IP address as domain.
  4. Rocky

    Rocky Member

    Ok, I found the problem. My ICMP port was closed on the router therefore stopping ping replies. After opening the port on the router, I sucessfully installed Debian Sarge (Perfect Setup) and ISPConfig, however, there is a problem. I can't seem to get webmail working. Does this feature install automatically? I tried going to https://www.domain.tld:81/webmail/ and https://www.domain.tld/webmail/ and both doesn't work. Did I do something wrong? :confused:

    I've set up a client and website in ISPConfig and I can use pop3 to send and receive mails, but i would also like the webmail feature. Any suggestions?

    Also, I've installed webmin and started the service. I've also opened the port, port 10000, in the router. However, when I tried to access the page, I get the security alert and hit yes to it, but it just gives me a message saying that i'm not authorized to view this page. Should I try a reinstall? :confused:
  5. IntnsRed

    IntnsRed Member

    No, webmail doesn't install automatically. You have to download the webmail *.pkg and then install it from inside ISPConfig with the Management -> Update Manager -> Update function. From that point you should be able to access it on your port 81 /webmail.
    Honda mobilio history
    Last edited: Mar 4, 2011
  6. Rocky

    Rocky Member

    I followed your instructions and was able to get webmail and phpmyadmin loaded. Webmail seems to work fine but there is a slight problem with phpmyadmin. I downloaded the latest version and uploaded it through the update function, as instructed. It said it was successful. However, when i log into phpmyadmin it works fine but when i try to logout, it keeps asking me for a username and password, then eventually times out telling me that the username or password is wrong.

    I know something is wrong but just can't figure it out. Should i do a re-install? If yes, how would i uninstall the current phpmyadmin? :confused:
    Last edited: Nov 7, 2005
  7. domino

    domino New Member

    PHPmyadmin is just a script and the directory is accessable by web. You delete that and reinstall might not fix it.

    phpMyAdmin is located here: /home/admispconfig/ispconfig/web

    It's just a script that connects to mySQL. The editable file is It might not help you fix your problem if the database is the problem.
    Last edited: Nov 7, 2005
  8. falko

    falko Super Moderator Howtoforge Staff

    :eek: No, don't re-install phpMyAdmin, that's the normal behaviour! As soon as you click on "Exit" in phpMyAdmin, you're already logged out, then the next page loads and sees you're not logged in and therefore asks you for the login details. Nothing wrong here.
  9. domino

    domino New Member

    LOL. I just realized what he was saying. My bad. Falko, will it break anything if I disable htaccess and enable cookie login for phpMyAdmin access? Maybe that's what the original post was all about?
  10. Rocky

    Rocky Member

    So then I think I've done a successful Debian Sarge 3.1 setup. Hey thanks guys, I couldn't have done it without your help and tutorial. :)
  11. falko

    falko Super Moderator Howtoforge Staff

    No, you can change that if you like. :)
  12. domino

    domino New Member

    great! I hate htaccess when it's not really needed.
  13. drehinsi

    drehinsi New Member

    ISPconfig istall

    Hi, Ive been following the guide for ISPconfig install. And ive come across a probelm when entering domain name.

    Please enter a name for the ISPConfig database: db_database
    Please enter the IP address of the ISPConfig web: (ive entered my external address which has been accepted)

    please enter the host name (eg www) what do i put here? host name of server etc?

    Please enter the domain name (eg I used my registered domain name and get an
    ERROR: The URL is not reachable!

    what am i doing wrong, please advise.. :(
  14. falko

    falko Super Moderator Howtoforge Staff

Share This Page