ISPconfig - Usename change password -> username already in use

Discussion in 'HOWTO-Related Questions' started by klonos, Nov 22, 2008.

  1. klonos

    klonos New Member

    Using ISPconfig 2.2.27

    When I go to Customer -> Site Management -> Select IP -> User & Email ->Select user account -> enter new password -> Save ...

    It gives me:

    The following error occurred:
    The username is already in use.
    Next >>
    First time I am having issues with ISPconfig, so I don't know where to start troubleshooting from.
  2. _X_

    _X_ New Member

    Check out if there is something in Recycle Bin (both of them).
  3. klonos

    klonos New Member

    'Both of them' ???

    ... are there two recycle bins? Well, when I check under 'ISP Manager' section I see the following:

    Recycle bin: contents 0 - 30
    [Empty recycle bin]
    Note: Items remaining in recycle bin after emptying are currently in update state. Please try to delete them later.
    Hitting the 'Empty recycle bin' has no different effect (there are no items in the first place anyway).

    All the other sections' recycle bins are empty:

    Recycle bin: contents 0 - 30
    [Empty recycle bin]
    Is there any way I can double check this in the MySQL db directly?

    PS: Sorry for the late reply, but I was away.
    Last edited: Nov 29, 2008
  4. _X_

    _X_ New Member

    You can try with database check/repair/optimise.

    You can check directly in db_ispconfig database for that username but i dont suggest manual editing of database. If you want to manualy edit that database do a backup first so you can revert to previous state if anything goes wrong.
  5. klonos

    klonos New Member

    database check/repair/optimize did not work. Still getting that error :(

    I am not going to touch the db unless someone out there knows to point me to the exact thing I need to change and where I am to locate it in the db tables.

    Still waiting for any ideas on this one...
  6. _X_

    _X_ New Member

    info on users can be found in isp_isp_user table in ispconfig db.

    check if that username exists there.
  7. klonos

    klonos New Member

    Yep! The user entry is there and the only odd thing is the 'user_cron' field that is set to 0 whereas the rest of the user entries have it set to Null.

    The thing though is that the error appears for any other user I try to change the password and not just the one's that I noticed having the issue first. So I guess that this is a general problem with changing user passwords and not user specific.
  8. _X_

    _X_ New Member

    can you change any other setting for users or you cannot change only passwords?
  9. klonos

    klonos New Member

    It turns out that despite this error coming up, the password actually is changed. And you are right, trying to change other settings (I tried real name, mail address and quota) also spits this error, but actually applies the change.

    Can I safely ignore this, or should we troubleshoot further? I am using the latest stable 2.x version of ISPconfig and Ubuntu 8.10.
  10. _X_

    _X_ New Member

    well ... since those changes are done in database it points out to problem with mysql so you should take a look at log files to see if that error can be corrected.

    personaly I would try to correct that problem because you cannot delete users and that function can be usefull :)
  11. klonos

    klonos New Member

    I will look at mysql logs, but I can delete users anyways. You see, I've already tried adding a user and then deleting it before you even post your last reply. Both actions (adding & deleting) were successful.

    Thank you for your help so far.

Share This Page