IspConfig3 Mails configuration

Discussion in 'Installation/Configuration' started by kameleon1er, Jul 31, 2021.

  1. kameleon1er

    kameleon1er Member

    Hello isPers,

    I have a problem of understanding ...

    I installed ISPconfig3 on a VPS (it works fine) :

    using a subdomain for installation: isp.domain1.tld

    and I also configured the mail server with this host address = isp.domain1.tld

    Then I created a series of mailBoxes of the main domain :

    [email protected]
    [email protected] etc...

    So when I want to send a mail from one of these MailBoxes in my mail client settings:

    Type => SMTP
    Hostname of the SMTP server => isp.domain1.tld
    SMTP server port => 587
    E-mail "from" => [email protected]
    Security => STARTTLS
    Authentication => Plain
    Username => [email protected]
    Password => MyPassword

    It works fine.

    In my mind, "isp.domain1.tld" is my main mail server (postfix...)

    But then I had to create other domains with ispConfig with other email addresses... :

    domain2.tld

    I create new mail addresses :

    - [email protected]
    - holla@@domain2.tld

    And this is where I'm not sure anymore... it works but I don't know if I'm doing it correctly:

    for "domain2.tld":
    Type => SMTP
    SMTP server hostname => isp.domain1.tld
    SMTP server port => 587
    E-mail " from " => [email protected]
    Security => STARTTLS
    Authentication => Plain
    Username => [email protected] (mailBox from first domain for authentification)
    Password => MyPassword

    What I don't understand is that in the configuration of my mail client for the second domain if I put in authentication :

    Username => [email protected] (mailBox second domain)
    Password => MyPassword

    It doesn't work. In login I always have to put an email address created with the first domain.

    Is this normal or am I making a mistake somewhere?

    Thanks for your help and sorry for this long mail :)
     
  2. Chris_UK

    Chris_UK Active Member HowtoForge Supporter

    Did you add a new mail domain in ISPConfig? If so, did you select your isp.domain.tld as the server?

    Run the following command on you mail server then try to send another email with the host that is failing. Post the log here using the code box. You can increase the number if you have a high volume of requests to the mail server.
    Code:
    sudo tail -fn 50 /var/log/mail.log
     
  3. kameleon1er

    kameleon1er Member

    Hi @Cris_UK , no, I was configuring a Nextcloud on a second VPS… and config SMTP in it to outside notifications… Anyway… :
    What I'd like to understand is why I configure a mail_client for my second mail domain, I have to fill "autentification fields" for StartTLS with e-mail_adress_account + password infos from my first mail domain installed.

    Not sure to be clear :)
     
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    You don't have to if the domain/account is created and active in ispconfig, and in fact there is a setting to prohibit that from working at all, which is usually not a bad idea.
     
  5. kameleon1er

    kameleon1er Member

    Hi @Jesse Norell
    Okay, I think I understand. But then... what if I need to create a domain and a set of email addresses for a client? I'm not going to give him my "e-mail authentication + password" pair so that he can configure the smtp fields in his mail client?

    So my question is; is it possible to configure and allow other smtp authentication pairs for a client domain?
    Code:
    example : client.domain.tld
    mail adresse => [email protected]
    smtp host => ???
    -------------------------------------------------
    Authentification => STARTTLS
    Login => ???
    Password => ???
    Thanks :)
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    This must work if you created mailboxes (and not just aliases or forwarding) for these addresses as you can't use your first email address as login for the other addresses and you also should not use your first email address and password for sending for other mailboxes. Check the mail.log and double check that you made no typos in the email address and password in ISPConfig and your mail client.
     
  7. kameleon1er

    kameleon1er Member

    Hi @till :)
    Damn!!! oO … It work :cool:

     
  8. kameleon1er

    kameleon1er Member

    :: SOLVED ::
     

Share This Page