ISPConfig3=Roundcube: Soap Error

Discussion in 'Plugins/Modules/Addons' started by ZeroEnna, Apr 22, 2014.

  1. ZeroEnna

    ZeroEnna Member

    Hey everyone,

    I think I made a big, big mistake.

    So first of all my config:

    I'm using two different, individual ISPConfig Instances.
    The new instance in running on two servers in client-slave mode with no dedicated roles (all two servers serve als web, mail and db servers). The new ones have install Debian 7 and the latest ISPConfig Version (which is currently the latest stable until

    Same for the old instance, except they run on the oldstable Debian 6 and consist of three seperate servers in a master-slave-slave combination.

    My problem:

    Until recently, I ran all my "business" related websites on the old environment. It included a webmail interface for the customers and worked with the ISPConfig3-Roundcube-Plugins.
    I migrated the setup to the new environment (including all my business websites) and deleted (*) the old user on the old environment, since I thought it would not be needed anymore.

    What's working: Login to the Roundcube interface, mail-related tasks such as writing, deleting and moving mails

    What's not working: Everything related to the Roundcube-ISPConfig-plugin gives me

    soap error: there is no sys user account for this client id
    My conclusion:

    The webmail interface runs/ran (*on the old server, too, but I deleted that client since I migrated all the websites to the new environment, as mentioned above) under client id 1 on both the old and the new environment. For the mail part, it doesn't matter since I configured roundcube to look for the MX record "" (for websites that are seperated on mail and web domain, which I have a few). So it as long as it can connect to the mail servers via SMTP and IMAP, there is no problem at all (I even think I could connect to commercial mail hosters such as yahoo or gmail with my setup).

    But for the plugin, I somehow killed something that is necessary for the plugin. I didn't make any changes to the remote user I created for the plugin, but it seems that the remote user and/or the plugin tries to attach itself to the client ID '1' on the old environment, which, like I stated already, doesn't exist anymore on the old environment.

    My question:

    1. Is it because the websites runs under the client ID 1 that it tries to look for "familiar settings" on the old environment?
    2. What can I do to "make it run" again?

    Thank you in advance

    Kind Regards

    Last edited: Apr 22, 2014

Share This Page