Just a Couple of Questions

Discussion in 'Installation/Configuration' started by brainz, Feb 28, 2006.

  1. brainz

    brainz Member

    Hi all

    Im Sorry to butt in like this i have a quick question if i may....

    I have setup FC4 server running ISPconfig and i have follow the tuts probably about 4 to 5 times now as i built and rebuilt the server from scratch over and over again many wouldnt i considered a good learning curve and it was fun...

    Anyway to my question....

    I noticed that all is well on internal side of my network and all works nice...
    But when i goto work and try to access the server no go blank page server timed out type messages. Server is behind a NAT(home variety router) do i have to make sure that all these port are forwarded to the server ???

    Name Port Type Active
    FTP 21 tcp yes
    SSH 22 tcp yes
    SMTP 25 tcp yes
    DNS 53 tcp yes
    DNS 53 udp yes
    WWW 80 tcp yes
    ISPConfig 81 tcp yes
    POP3 110 tcp yes
    SSL (www)443 tcp yes
    Webmin 10000 tcp yes

    This is take directly from the iptables firewall settings in ISPconfig admin panel

    What i dont understand is this on my home variety router these port are forwarded to the server

    Virtual Server FTP 192.168.*.*TCP 21/21 always
    Virtual Server SSH 192.168.*.* TCP 22/22 always
    Virtual Server HTTP 192.168.*.* TCP 80/80 always
    Virtual Server HTTPS 192.168.*.* TCP 443/443 always
    Virtual Server DNS 192.168.*.* UDP 53/53 always
    Virtual Server SMTP 192.168.*.* TCP 25/25 always
    Virtual Server POP3 192.168.*.* TCP 110/110 always
    Virtual Server HTTP port 81 192.168.*.* TCP 81/81 always

    The 192.168.*.* is primary server ip.

    I tried this and it doesnt seem to give me access from outside it doesnt seem to work there is also a virtual server ip do i need to port forward all ports in the list above for the virtual ip ???

    I also get a message when i reboot the server about the primary internal ip address not having a virtualhost

    something like this

    [warn] NameVirtualHost 192.168.*.*:80 does not have a virtualhost

    i did read about this and you guys having very good tutorials and stuff to read on this site and it has to do with apache or php filters and this was being addressed in the next version of ISPconfig as i sore in the dev forum.

    but i was wondering if this had something to do with not being able to access the server from the outside.

    Just a brief on the setup....
    server is FC4 and built and configured exactly the way the Falko HOW-TO which is great.
    domain name forwarded to server ip and the dns servers are addressing the connection ip.

    I also did read that for SSL site you need a ip per site so as admin i created a client then a web for this client and activated the SSL and SSI but from my limited knowledge in order to have multible webs on the 1 ip do i have to deactive SSL and SSI for the clients web ???

    Im sorry but this has turned from one question to a few but while i got you i might as well ask....

    Just one other question i noticed with ProFtp when i try and access it using smartftp on another computer within the network some files are uploaded and some arnt uploaded and the ones that dont make smartftp hang and i need to restart smartftp and i have tried this with pasv auto and non pasv 10101 and all the combos it still hangs on certain files and not others.

    One thing i did notice is on this computer within my network as soon as i turn the firewall off on the computer all the files transfer but there is a lag during each file and i think there is a error message say something like this...

    550 file.ext: No such file or directory

    Anyway i have said my piece this as much as i could collect in one go....

    I would very much apreciate anyones contribution to my questions here
    Other then that you know what all the stuff on the site and the forums are A1 or A+ which ever you prefer...

    Also i did a httpd and the output is this....

    [root@xxx ~]# httpd
    [Tue Feb 28 09:03:17 2006] [warn] NameVirtualHost 192.168.*.*:80 has no VirtualHosts
    (98)Address already in use: make_sock: could not bind to address [::]:443
    no listening sockets available, shutting down
    Unable to open logs
    [root@xxx ~]#

    just wondering what this means ???

    Many Thanks
    Last edited: Feb 28, 2006
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    No. Only the ports where you want to access the server from the outside. Eg.g if you want to access the webserver, port 80 must be forwarded. For the ISPConfig interface, port 81. If you want to access all services from outside, forward all ports listed below except port 10000.

    No, just use your main server IP.

    Have you created the website in ISPConfig on this IP or on the second (virtual) IP?

    You can activate SSL only on one website per IP, you will get an error from ISPConfig i you try to activate it on another website.

    Did you get any errors in your syslog or xferlog?

    This means that there is already a webserver running. I guess you want to test your server with:

    httpd -t

    which tests the server configuration.
  3. brainz

    brainz Member


    Thankyou for your response at the moment i am at work and do not have access to the server at home. However in answer to a few of your questions.

    The website created in the admin panel was created on the main ip address for the server and not the virtual ip. As far as i understand the virtual ip is for the secondary dns if needed.

    I havent got the answer to this one at the moment but as soon as i get access to the server i will check and post findings.

    Again once i have access to the server i will post the details of the set.

    till i want to thankyou for your response i will comeback with more details once i get home...

  4. brainz

    brainz Member

    Hello till

    here are the output below from a httpd -t i did on the server

    Here is the details from the xferlog below but i dont think this looks like a error at all. Offcourse the *.*.*.* is a ip address..

    I cant seem to find any syslog that has details of any errors at all... unless you can tell me the location of the syslog offcourse.

    I dont really understand why its doing what it does its really weird some files it likes and otheres it doesnt also noticed that sometime it does like uploading a certian file structure either. This sounds to me like a permissions issue but everything is pritty much and its should be according to a howto for FD4

    I was just wondering also if i set the eth0 ip address as dynamic would this cause a issue and im not talking when the ip address changes and i cant access the server at all only when the dns has resolved the right ip address for the domain ???

    Sooner or later i will be getting a static ip address and i wont have to continuesly goto the dns server and update the ip well maybe one more time for the static ip i get but i was wondering if this could cause any issues with the ISPconfig ???

    Im sorry this is a last moment edit of this post i just wanted to add this

    I i was wondering what this meant ???

    many fanks...
    Last edited: Feb 28, 2006
  5. falko

    falko Super Moderator Howtoforge Staff

    Might be /var/log/syslog or /var/log/messages.

    Seems to be a problem with the permissions/ownerships of the directories to which you try to upload.

    Use a static IP address!

    Nothing to worry about, this is ok.
  6. brainz

    brainz Member

    Hi falko,

    I just upgraded to the latest version and i have no ftp client access to the web account at all

    Here is the output for the messages log

    This is the output from the ftp client now

    Im sorry but im at a lost at why it wont let me connect to the ftp server now that i have upgraded to the newest version...

    Please Help...

    PS... I have a static IP now and the dns has propergated it so the domain resolves.

  7. till

    till Super Moderator Staff Member ISPConfig Developer

    The error is related to the PAM authentication:

    But ISPConfig does not configure PAM, soi guess your problem is not directly related to the ISPConfig upgrade.

    Please post the line from /etc/passwd for the user web1_admin
  8. brainz

    brainz Member

    Hi till,

    Here is what you have requested below...

  9. falko

    falko Super Moderator Howtoforge Staff

  10. brainz

    brainz Member

    Hi falko,

    Thankyou i have read that thread and i do have a ftp file with the details in it



    with this code

    I have tried it and the ftp does give me access now but unfortunatly i still have this problem where i try and upload a particular php files and it freezes and disconnects.

    I think as till says there is a problem with PAM authentication and if could work this out it would be excellent. I think i have posted the output from the /etc/passwd for web1_admin.

    if i could understand what this means....

    and find a solution for it. This would be greatly aprechiated and i thankyou once again for yours and tills help.


Share This Page