Letsencrypt not working since Updating to ISPConfig 3.1.13

Discussion in 'Plugins/Modules/Addons' started by ExaconAT, Aug 31, 2018.

  1. ExaconAT

    ExaconAT New Member

    i wanted to add a new Website and always receive this error when i try to use letsencrypt as ssl provider:

    2018-08-31 11:33:04,427:DEBUG:letsencrypt.cli:Exiting abnormally:
    Traceback (most recent call last):
    File "/usr/bin/letsencrypt", line 9, in <module>
    load_entry_point('letsencrypt==0.4.1', 'console_scripts', 'letsencrypt')()
    File "/usr/lib/python2.7/dist-packages/letsencrypt/cli.py", line 1986, in main
    return config.func(config, plugins)
    File "/usr/lib/python2.7/dist-packages/letsencrypt/cli.py", line 689, in obtain_cert
    le_client = _init_le_client(config, authenticator, installer)
    File "/usr/lib/python2.7/dist-packages/letsencrypt/cli.py", line 206, in _init_le_client
    acc, acme = _determine_account(config)
    File "/usr/lib/python2.7/dist-packages/letsencrypt/cli.py", line 191, in _determine_account
    config, account_storage, tos_cb=_tos_cb)
    File "/usr/lib/python2.7/dist-packages/letsencrypt/client.py", line 116, in register
    acme = acme_from_config_key(config, key)
    File "/usr/lib/python2.7/dist-packages/letsencrypt/client.py", line 41, in acme_from_config_key
    return acme_client.Client(config.server, key=key, net=net)
    File "/usr/lib/python2.7/dist-packages/acme/client.py", line 63, in __init__
    File "/usr/lib/python2.7/dist-packages/acme/messages.py", line 169, in from_json
    raise jose.DeserializationError(str(error))
    DeserializationError: Deserialization error: Wrong directory fields

    Ispconfig 3.1.13
    Ubuntu 16.04.5 LTS - all upgraded
    letsencrypt 0.4.1

    Please help,
    Thank you in forward! - Can't post the full cfg because of links.. I'm not allowed to
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. ExaconAT

    ExaconAT New Member

    Hello, reconfiguration of services did not help.
    But the second Thread worked perfectly.
    For Apache:

    apt update
    apt install software-properties-common
    add-apt-repository ppa:certbot/certbot
    apt update
    apt upgrade -y
    apt remove letsencrypt -y
    apt install python-certbot-apache -y

    Retry obtaining a certificate in ISPConfig. Done.
    ikrudolf and ahrasis like this.
  4. ikrudolf

    ikrudolf Member

    This also solved it for me! Thank you!
    (BTW strange why this isn't mentioned yet in the Perfect Server tutorial)
  5. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    The perfect server for Ubuntu 18.04 uses cerbot instead of Let's Encrypt. The 16.04 Perfect Server quide has not been updated. I guess it is assumed new installs use Ubuntu 18.04.
  6. ikrudolf

    ikrudolf Member

    Yes but many vps company's still offer 16.04 as the highest version of Ubuntu. But glad this instruction worked for me :cool:
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    I've updated the old Ubuntu 16.04 tutorials now.
    ikrudolf likes this.

Share This Page