Local DSN generation - amavisd-new problem

Discussion in 'Installation/Configuration' started by mislav, Jan 28, 2021.

  1. mislav

    mislav Member

    Hi there.
    I'm facing a problem with delivery status notification (DSN) from local machine. My problem is that I wouldn't like to turn off amavis due to mail filtering/pros, however it's making some issues for me. So far I didn't find a way to disable DSN in amavisd-new.
    Before we start, I'd like to mention that I've configured also this: http://www.postfix.org/DSN_README.html

    Here is the situation/problem - when amavisd is enabled and configured in postfix, I get the following message:
    But I don't want that - this just means mail message was successfully relayed through amavis filters and you would think it was successful, however, if I check logs (I created problem on purpose) it says:
    So I'm wondering how to skip amavisd from sending this message? I've already played with the following two options
    No success.

    If I completely disable amavis in the postfix, then everything is as expected. DSN is sent by the MTA and not by the amavis.

    Any ideas how to by-pass DSN in amavis? Thanks
  2. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    amavis is setup as an after-queue content_filter, your MTA must accept the message for delivery in order to queue it before it gets processed by amavis - ie. this is not amavis sending a DSN, and there is no way to not accept the message in that setup. You could switch to rspamd which is a milter and will scan the message before accepting. Or you could look at setting up amavis as a before-queue content_filter (which is a non-standard setup for ISPConfig systems, and will probably run into some confusion and possible finger pointing when bringing mail delivery questions to the forum for assistance). The dns readme link you posted above shows how to stop sending DNS to external servers.
    mislav likes this.
  3. mislav

    mislav Member

    Thank you very much @Jesse Norell
    I've replaced amavisd-new with rspamd and it's working as expecting. Cheers!

Share This Page