Locked filesystem

Discussion in 'Technical' started by smelkomar, Jan 23, 2006.

  1. smelkomar

    smelkomar Guest

    Hello to everyone in this forum. I'm from Bulgaria and a newbie in administration world. That's why I need some help with a little problem with filesystem on Server installation of Ubuntu 5.10 Breezy... OK, I made all steps in ISP 5.10 guide, but after this command "shutdown -r now" I discover that the server crashed. After reboot the OS tells me that the filesystem of hard disk (9.2GB Western Digital under reiserfs) is set to read only :confused: And of course before that I tried to configure 2 nics (Realtek 8139) with two ip addresses - one real and one for local network (10.10.1.xxx). I saw that the 2 nics started in half-duplex mode... I tried to connect to the server through SSH but the nic with real IP doesn't responds... the second nic too :mad: At the moment I have installed all things from the guide, but haven't real working machine... without nics and writeable hard disk :eek: I... just want some help for this problems. Sorry for my poor English... This is my first post in professional int. forum.:D
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Where you asked during bootup sequence to repair your filesystem?

    Normally a filesystem is mounted readyonly during boot process when the filesystem has crashed ynd cannot be repaired automatically. You can also try to reboot again, maybe the automatic repair can fix the problems.
  3. smelkomar

    smelkomar Guest

    Autorepair :confused: I saw that under ext3 the system crashes too... I can log on the system but the prompt is that:


    After correct restart all is ok... (some editing in /etc/fstab) but for now the whole process that I made (step by step 5.10 Ubunto ISP) is wrong. Nothing works... there be only started and working Apache2 Postfix and Quotas (with some errors). For now I'm scared to make some changes to configure the server for it's full capabilities :eek: I don't know what could happens after some play with shell :) Ooops, I forgot... I saw that ISPConfig installation has undocumented options. And errors too. OK, I'll try to make this - after every single step I record the output of the commands. It's not hard, but you may be shocked when see every error. Hmmm, some Putty log file will be excellent decision for showing the all broken install process. Just tell me how to post the file in the forum
    Last edited by a moderator: Jan 24, 2006
  4. falko

    falko Super Moderator Howtoforge Staff

    It seems as if your hard disk is broken...

    Just post the content here.
  5. smelkomar

    smelkomar Guest

    No, the hard disk is not broken... Before I install Ubuntu I check it under Windows XP for bad sectors. For everything is fine... only when I type trafmeter.new.bg in the browser nothing happens. I'm sure that yesterday the Apache2 is working... but when I type IP address instead of domain name I enter in Apache2 rootdir, where are "webalizer" and "sharedip" folders. I open "sharedip" and found that:
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you created a website for trafmeter.new.bg in ISPConfig with the IP: ?
  7. smelkomar

    smelkomar Guest

    Yes, of course..in our DNS server... now I start the 5th ./setup of ISPConfig... for now there are some warnings. Nothing unusual
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Why did you reinstall ISPConfig? If you created the website in ISPConfig it must have been installed completely before :confused:
  9. smelkomar

    smelkomar Guest

    I saw a comment that reiserfs doesn't support quotas :eek: After new fresh install of Ubuntu I just follow again every single step from the guide. Before minutes I saw these errors:

    ./setup line 974 (or something else - I forgot to make a logfile :D ) /etc/init.d/ispconfig_server no such file or directory

    :Boring: I'm exhausted from this "cut and paste" walkthrough :(
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    If you get errors from the ISPCOnfig setup script, please post all error messages you get.

    Before you rerun the setup when it stopped, you must delete the directories:

    rm -rf /home/admispconfig
    rm -rf /root/ispconfig

    and the install_isponfig directory and unpack the installer tar.gz file again.
  11. smelkomar

    smelkomar Guest

    TiLL, thanks for these commands. Everything works... But there's another problem(s) - when i type https://trafmeter.new.bg:81 I can enter in control panel. When my friend type it (from another provider) he couldn't. He tried with and that works. The second and maybe very strange problem is when I use this command


    the machine is responding but the result is far.. far away... maybe after 2-3 hours (at the moment 32 minutes after the start).

    Before I make the second attemp of this command, I see this message:

    "LWP not available"

    I used this command:

    "perl -MCPAN -e shell"
    I used first from the list... "install HTML::parser" and there after error has a advise to use this:

    "install Bundle::CPAN"
    "reload cpan"

    Are these commands safe enough to update CPAN (I don't know what is CPAN :D )
    Last edited by a moderator: Jan 28, 2006
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Is the domain trafmeter.new.bg an officially registered domain?

    Yes it is safe, you have to install several modules from cpan. cpan is the official perl module repository.

    It is described in the installation manual:


    The ISPConfig comes with SpamAssassin, but without the Perl modules needed by
    SpamAssassin. Run the following command after the installation of the ISPConfig:
    If errors appear you have to install some Perl modules.
    perl -MCPAN -e shell
    install HTML::Parser
    install DB_File
    install Net::DNS (when prompted to enable tests, choose "no")
    install Digest::SHA1
    To leave the Perl shell type
    does not return any error everything is fine. You can then leave SpamAssassin by typing
    " CTRL + c".
  13. smelkomar

    smelkomar Guest

    Now the time is 17:05 in Sofia, Bulgaria and the command for spamassassin not yet finished (I started in about 15:00)...:mad: Yes, the domain new.bg is officialy registered. I know that "trafmeter" is subdomain of new.bg. We have own DNS server and we enter this trafmeter domain in DNS conf files. When I ping "" the name resolves... Only very strange problem is this waiting of last command in the guide. By the way when I start "install Net:: DNS (when prompted to enable tests, choose "no")" there aren't tests. This is the result

    Net:: DNS is up to date.
    Last edited by a moderator: Jan 28, 2006
  14. falko

    falko Super Moderator Howtoforge Staff

    Which URL do you have in /home/admispconfig/ispconfig/lib/config.inc.php?
    https://trafmeter.new.bg:81 or ?

    This is fine. It means that the module is already installed.
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Then everything is fine. You dont have to wait that /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin is finished as this command never finishs. Just press CTRL + C to exit spamassassin.

    Installation manual:

    Last edited: Jan 28, 2006
  16. smelkomar

    smelkomar Guest

    Is this:
    $go_info["server"]["server_url"] = "https://trafmeter.new.bg:81"; ?

    By the way which is correct - chmod 777 /home/userdir or chmod 754 /home/userdir...? Because when I tried to make a directory when logged as user who is owner of userdir I couldn't.... with chmod 754 :(

    P.S: I found the error - there's missing a line with the following synthax in our DNS server:

    "new.bg. IN NS ns
    IN NS mail
    IN MX 50 trafmeter
    IN A"
    Last edited by a moderator: Jan 28, 2006
  17. falko

    falko Super Moderator Howtoforge Staff

    A directory must always be executable for everyone - owner, group and anyone else, so chmod 754 is wrong.
  18. sbovisjb1

    sbovisjb1 Member HowtoForge Supporter

    Well here is a nifty script

    The workaround for CPU enumeration with HyperThreading CPUs allows shutdown to work properly. Simply add acpi=ht to the kernel boot line in /etc/grub.conf and reboot.

    1. su -
    2. type in password.
    3. gedit /etc/grub.conf

    >this is how mine looked<
    >dont blame me if it doesnt work<

Share This Page