Logging in to isp config

Discussion in 'General' started by Jrdgames, Feb 6, 2006.

Thread Status:
Not open for further replies.
  1. Jrdgames

    Jrdgames New Member

    Even though my server is behind a router and a hub it can still be detected without a domain or anything up?
    Well how would I go about doing that?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    No, only if you forward ports from your router to your server.

    I guess falko meaned to format and reinstall the complete linux operting system.
  3. Jrdgames

    Jrdgames New Member

    Oh theres no way to just delete the databases without a new install of linux?
  4. falko

    falko Super Moderator Howtoforge Staff

    You could uninstall MySQL and then delete the directory /var/lib/mysql and then reinstall MySQL. But I don't know if it works...
  5. Jrdgames

    Jrdgames New Member

    I wonder if they say how to delete the databases on the mysql website or the folder the databases are saved in...

    EDIT: I've posted on the mysql forums and I have asked where the databases are stored but I dont know how helpful they will be.
    Last edited: Feb 10, 2006
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    To delete the database folders, execute the command:

    rm -rf /var/lib/mysql
  7. Jrdgames

    Jrdgames New Member

    ok command executed the directory is gone now what should i do? do i continue uninstalling mysql now?
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    The directories must be removed after you uninstalled mysql, not before:

    But ok, lets try to remove it anyway :)

    Execute the command:

    apt-get remove mysql-server

    Please copy the list of packages that where uninstalled and post it here.

    Then install it again with:

    apt-get install mysql-server
    Last edited: Feb 11, 2006
  9. Jrdgames

    Jrdgames New Member

    Heres what I got when I ran the uninstall command:
    Proceeding to install mysql again we'll see how it works, im going to turn portforwarding off first though so my server cant be picked up by scans.

    EDIT mysql has installed and we'll see if the set pass word works
    Last edited: Feb 11, 2006
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, the output from uninstalling mySQL looks fine so far. I just want to be sure that apt did not uninstall any other depending packages too that we would have to reinstall again. But apt just uninstalled the mysql server.
  11. Jrdgames

    Jrdgames New Member

    ok Im going to start installing ispconfig again

    EDIT it didnt work it had the same mysql problem as before saying that my password is wrong, is there anyway to login to mysql and do database stuff without having ispconfig installed? maybe we can find the problem and fix it...
    btw do either of you have msn or yahoo or something that i could chat with you on?

    EDIT again this thing doesnt seem to like me i ran ispconfig install again after changing the mysql password the ispconfig install was going well oe atleast it seemed to be going well until it came to the mysql part:
    it didnt like the password i gave it then the install quits, so I started it again(I know i shouldnt have but i just keep forgetting that i need to remove stuff before it will work properly) and it gives me this message at the end of the install:
    but i still cant login to it.
    click here to see the installation(whats left in the terminal)
    Last edited: Feb 12, 2006
  12. falko

    falko Super Moderator Howtoforge Staff

    I don't use any messengers.

    How did you change the MySQL password?

    You should have removed the old, faulty ISPConfig installation first.
    rm -fr /root/ispconfig
    rm -fr /home/admispconfig
  13. Jrdgames

    Jrdgames New Member

    oh ok

    I followed the guide on the mysql site:
    It look like we need to get this mysql issue resolved for it to work.
  14. falko

    falko Super Moderator Howtoforge Staff

    Now that you've reset your MySQL password, can you log in to MySQL? Try
    mysql -u root -p
    and see if you get in.
  15. Jrdgames

    Jrdgames New Member

    its not working :(
  16. falko

    falko Super Moderator Howtoforge Staff

    Then resetting your password did not work. You should reinstall the whole system.
  17. Jrdgames

    Jrdgames New Member

    so I will need to wipe the whole drive again?
    EDIT could i use files from a server that was working properly instead of redoing the whole thing?

    EDIT can I change the mysql password by editing a file? or does it have to be done by running a command or using the guide on the mysql page?
    what does the code in mysql's(var/run/mysqld/mysqld.pid) .pid file stand for?

    EDIT Again: I think I found where mysql keeps the password: /etc/mysql/debian.cnf now if only we knew how to decode it then we could manually reset it. Anyone know how to decode mysql password in this file?
    Last edited: Feb 13, 2006
  18. falko

    falko Super Moderator Howtoforge Staff

    I think you're wasting your time. You should try a clean reinstall, and try to stick as close as possible to the "Perfect Setup" on HowtoForge. I don't think you can somehow recover your password or trick MySQL.

    That's the process ID of the MySQL process.
  19. Jrdgames

    Jrdgames New Member

    ok I will start reinstalling the entire os if i need any help during the install I will be posting from my windows box, I hope it all installs fine.

    EDIT ok linux is running again and things seem to be running again, although when I ran apt-get install ssh i got the following:
    I know the first 12 lines are normal and then the block further down but the other parts look like theres something wrong with the repositories or something like that I have run apt-get update and I will continue following the guide: http://www.howtoforge.com/perfect_setup_ubuntu_5.04_p3

    EDIT could not find ncftp and it is not in my synaptic package manager I need to know how to get this package/where to get.
    EDIT can't find file inetd in /etc/init.d/ so i can't reload it, proceeding to quota
    im thinking these warnings probably came up because the quota files probably didnt exist before this, right?
    what am I doing wrong here?
    [QUOTE]/etc/postfix/ssl#  openssl genrsa -des3 -rand /etc/hosts -out smtpd.key 1024
    258 semi-random bytes loaded
    Generating RSA private key, 1024 bit long modulus
    e is 65537 (0x10001)
    Enter pass phrase for smtpd.key:
    Verifying - Enter pass phrase for smtpd.key:
    Verify failure
    User interface error
    12251:error:0906906F:PEM routines:PEM_ASN1_write_bio:read key:pem_lib.c:329:[/QUOTE]
    it says verify failure user interface error so is this an error on my part or its part? im sure im typing the passphrase the same each time
    ^-- never mind about that got it working.
    Last edited: Feb 14, 2006
  20. Jrdgames

    Jrdgames New Member

    Sorry about the double post ran out of space in the last one.

    I know have some errors that MUST be fixed before I can continue with instalation: when i ran: apt-get install autoconf automake1.4 autotools-dev libapache2-mod-php4 libkrb53 php4 php4-common php4-dev php4-imagick php4-mcrypt php4-rrdtool php4-sqlite php4-curl php4-domxml php4-gd php4-imap php4-ldap php4-mcal php4-mhash php4-mysql php4-odbc php4-pear php4-xslt
    I got the error: E: Couldn't find package php4-imagick
    so i started installing them one at a time and I have a list of other packages that must be installed:
    • libapache2-mod-php4=E: Broken packages
      PHP4=E: Broken packages
      php4-domxml=E: Broken packages
      php4-gd=E: Broken packages
      php4-xslt=E: Broken packages
      php4-ldap=E: Broken packages
      php4-mcal=E: Broken packages
      php4-mhash=E: Broken packages
      php4-mysql=E: Broken packages
      php4-odbc=E: Broken packages
      php4-pear=E: Broken packages
      php4-rrdtool=E: Couldn't find package
      php4-sqlite=E: Couldn't find package
      php4-imagick=E: Couldn't find package
      php4-imap=E: Couldn't find package

    here are some screenshots whebn i try it in synaptic:

    by the way should i be trying to use php5 instead of 4? even though the guide says 4 http://www.howtoforge.com/perfect_setup_ubuntu_5.04_p5
Thread Status:
Not open for further replies.

Share This Page