Mac4Lin ver.0.2 - Mac OS X Leopard Transformation pack

Discussion in 'Desktop Operation' started by infra_red_dude, Sep 22, 2007.

  1. infra_red_dude

    infra_red_dude New Member

    I am happy to release Mac4Lin ver.1.0. I know it was long due. Was held up with my graduate school and work. Version 1.0 finally sees light!


    * Fully supports GNOME 2.26 and backwards compatible
    * Improved support for GlobalMenu, support integrated in the default GTK theme
    * Better native Xfce support
    * Icon additions
    * Statusbar is now fixed
    * New progress bars
    * New tabs
    * Improved installation and uninstallation scripts
    * Integrates well with Globus
    * Finer UI refinements
    * Metacity theme now supports different button sizes
    * Firefox 3 themes are now updated
    * Songbird plugins included
    * Pidgin AWN 64bit plugin now included
    * Fonts are now consolidated
    * Transparent top panel
    * GDM theme is now in-line with Mac OS X login window
    * Cairo dock is the default recommended dock


    * Usplash is still buggy
    * Thunderbird theme is still buggy
    * GDM theme is not automatically set by the script


    1) Mac4Lin Desktop, NOTE:Apple logo is NOT bundled with Mac4Lin

    2) Mac4Lin Login Window

    3) Mac4Lin with Nautilus File Manager

    4) Mac4Lin on Xfce!

    It is available for download at Mac4Lin Download page with immediate effect. Grab your copy now! As always, your feedback is very important. Do leave them at forums or my mailbox.

    I am eagerly waiting for the Community Awards 2009.
  2. Kenny301

    Kenny301 New Member

    us splash screen problem

    hi i am a new user becuase i am using ubuntu 9.0.4 and installed ur mac4lin. everything went smooth, but im entercountering some problems. I followed the steps on how to get the apple boot screen activated. I did everything right, when I reboot, it shows the listing of things needed for boot such as*reading files needed to boot* and the list resumes. no splash screen. what is the problem? Also I want dock with the mac os logo to the left. how do i get that? I got that workin b4. Also where do i get the mac menu thing, with the apple logo to the top left?
  3. infra_red_dude

    infra_red_dude New Member

  4. infra_red_dude

    infra_red_dude New Member

    I'm very happy to announce that Mac4Lin has been declared as one of the finalists at Community Awards 2009 in the Best Visual Design category. The final phase of voting began today and will run till July 20th 2009. Please vote for Mac4Lin, if you feel it deserves to be voted. To vote click on this image:


    Optionally, you can also click on the first box in the right frame on my blog. You do not need to login id. All you need is a valid email id. Each vote is associated with an email id, which needs confirmation that you actually voted (you will get an email giving a confirmation link, so all you need to do is click it). The whole voting process takes just 3 clicks.

    I urge patrons to vote for Mac4Lin if they feel it should win. Mac4Lin is completing with projects like Xbox Media Center (XBMC) etc. I once again thank everyone for their continued support, feedback and appreciation. Mac4Lin exists today because of you all :) Do spread the word around about this.
    Last edited: Jun 24, 2009
  5. gslams

    gslams New Member


    I was using your Mac4lin on FC11 and it was working well till yesterday.
    Now, the system did an update which I agreed to and it downloaded a few upgrade for packages like compiz, gnome-session, gnome-panel , gnome-terminal and also a kernel update to the latest Fedora kernel 6.213. No I'm not able to get the icons to show up the same with Mac effects anymore.

    I have emerald theme set so my browser seems to have the MAC effect but I have lost the cool icons, file browser look , evolution mail look and the desktop fonts. Currently when I tried to redo the things from your blog just like the way I set it up, nothing happens, I still see the theme and can select it under Appearance but it doe not seem to take effect. I was wondering if you can help me debug this or if you know of anything based on my configuration below that could have caused the problem

    By the way, very cool project , I really like it and hope to get it working again.

    Kernel: #1 SMP Tue Jul 7 20:45:17 EDT 2009 i686 i686 i386 GNU/Linux

    Since this worked before, I'll spare you the system details.

    Here are the upgrade details

    Jul 23 11:31:19 Updated: glib2-2.20.4-1.fc11.i586
    Jul 23 11:31:22 Updated: cairo-1.8.8-1.fc11.i586
    Jul 23 11:31:24 Updated: pango-1.24.4-1.fc11.i586
    Jul 23 11:31:25 Updated: libsoup-2.26.3-1.fc11.i586
    Jul 23 11:31:28 Updated: totem-pl-parser-2.26.2-2.fc11.i586
    Jul 23 11:31:29 Updated: gnome-panel-libs-2.26.3-1.fc11.i586
    Jul 23 11:31:38 Updated: glib2-devel-2.20.4-1.fc11.i586
    Jul 23 11:32:04 Updated: libgweather-
    Jul 23 11:32:07 Updated: libwnck-2.26.2-1.fc11.i586
    Jul 23 11:32:10 Updated: 2:gimp-libs-2.6.6-6.fc11.i586
    Jul 23 11:32:11 Updated: 32:bind-libs-9.6.1-3.fc11.i586
    Jul 23 11:32:12 Updated: sed-4.2.1-1.fc11.i586
    Jul 23 11:32:16 Updated: gnome-mag-0.15.7-1.fc11.i586
    Jul 23 11:32:20 Updated: gnome-menus-2.26.2-1.fc11.i586
    Jul 23 11:32:23 Updated: wxBase-2.8.10-2.fc11.i586
    Jul 23 11:33:10 Updated: foomatic-4.0.2-4.fc11.i586
    Jul 23 11:33:11 Updated: libvolume_id-141-4.fc11.i586
    Jul 23 11:33:13 Updated: udev-141-4.fc11.i586
    Jul 23 11:33:15 Updated: ptlib-2.6.4-2.fc11.i586
    Jul 23 11:33:16 Updated: opal-3.6.4-2.fc11.i586
    Jul 23 11:33:20 Updated: system-config-printer-libs-1.1.8-6.fc11.i586
    Jul 23 11:33:26 Updated: wxGTK-2.8.10-2.fc11.i586
    Jul 23 11:33:29 Updated: policycoreutils-2.0.62-12.12.fc11.i586
    Jul 23 11:33:33 Updated: 32:bind-9.6.1-3.fc11.i586
    Jul 23 11:34:00 Updated: tomboy-0.14.3-1.fc11.i586
    Jul 23 11:34:29 Updated: 1:gnome-games-2.26.3-1.fc11.i586
    Jul 23 11:34:30 Updated: ppl-0.10.2-3.fc11.i586
    Jul 23 11:34:30 Updated: libtdb-1.1.5-0.fc11.i586
    Jul 23 11:34:33 Updated: libudev0-141-4.fc11.i586
    Jul 23 11:34:34 Updated: mdadm-3.0-1.fc11.i586
    Jul 23 11:34:40 Updated: orca-2.26.3-1.fc11.i586
    Jul 23 11:34:41 Updated: 32:bind-utils-9.6.1-3.fc11.i586
    Jul 23 11:34:43 Updated: gnome-panel-devel-2.26.3-1.fc11.i586
    Jul 23 11:34:50 Updated: gcalctool-5.26.3-1.fc11.i586
    Jul 23 11:35:04 Updated: file-roller-2.26.3-1.fc11.i586
    Jul 23 11:35:30 Updated: 1:gedit-2.26.3-1.fc11.i586
    Jul 23 11:35:30 Updated: patch-2.5.4-39.fc11.i586
    Jul 23 11:35:31 Updated: sudo-1.7.1-4.fc11.i586
    Jul 23 11:35:32 Updated: libtalloc-1.3.1-0.fc11.i586
    Jul 23 11:35:32 Updated: iw-0.9.15-1.fc11.i586
    Jul 23 11:35:33 Updated: cairo-devel-1.8.8-1.fc11.i586
    Jul 23 11:35:36 Updated: pango-devel-1.24.4-1.fc11.i586
    Jul 23 11:36:02 Updated: policycoreutils-python-2.0.62-12.12.fc11.i586
    Jul 23 11:36:03 Updated: libsoup-devel-2.26.3-1.fc11.i586
    Jul 23 11:36:04 Updated: gnome-python2-extras-2.25.3-5.fc11.i586
    Jul 23 11:36:21 Updated: gnome-themes-2.26.3-1.fc11.noarch
    Jul 23 11:36:24 Updated: tzdata-java-2009k-1.fc11.noarch
    Jul 23 11:36:24 Updated: kernel-firmware-
    Jul 23 11:36:25 Updated: libgweather-devel-
    Jul 23 11:36:28 Updated: policycoreutils-gui-2.0.62-12.12.fc11.i586
    Jul 23 11:36:36 Updated: 1:gnome-games-help-2.26.3-1.fc11.noarch
    Jul 23 11:36:37 Updated: 32:bind-chroot-9.6.1-3.fc11.i586
    Jul 23 11:36:40 Updated: kernel-headers-
    Jul 23 11:36:43 Updated: fedora-packager-0.3.5-1.fc11.noarch
    Jul 23 11:36:47 Updated: tzdata-2009k-1.fc11.noarch
    Jul 23 11:36:58 Updated: 1:java-1.6.0-openjdk-
    Jul 23 11:37:05 Updated: 1:java-1.6.0-openjdk-devel-
    Jul 23 11:37:06 Updated: gnome-python2-libegg-2.25.3-5.fc11.i586
    Jul 23 11:37:06 Updated: gnome-python2-gtkhtml2-2.25.3-5.fc11.i586
    Jul 23 11:37:32 Installed: kernel-
    Jul 23 11:37:32 Updated: 1:dbus-libs-1.2.12-2.fc11.i586
    Jul 23 11:37:37 Updated: xulrunner-
    Jul 23 11:37:39 Updated: 1:dbus-1.2.12-2.fc11.i586
    Jul 23 11:37:40 Updated: brasero-libs-2.26.3-1.fc11.i586
    Jul 23 11:37:42 Updated: compiz-0.7.8-19.fc11.i586
    Jul 23 11:37:42 Updated: 1:dbus-x11-1.2.12-2.fc11.i586
    Jul 23 11:37:55 Updated: gnome-keyring-2.26.3-1.fc11.i586
    Jul 23 11:38:09 Updated: gnome-session-2.26.2-1.fc11.i586
    Jul 23 11:38:10 Updated: geoclue-
    Jul 23 11:38:14 Updated: libpurple-2.5.8-2.fc11.i586
    Jul 23 11:38:21 Updated: sane-backends-libs-1.0.20-4.fc11.i586
    Jul 23 11:38:21 Updated: gnome-python2-gtkmozembed-2.25.3-5.fc11.i586
    Jul 23 11:38:39 Updated: brasero-2.26.3-1.fc11.i586
    Jul 23 11:38:41 Updated: setroubleshoot-server-2.1.14-2.fc11.i586
    Jul 23 11:38:41 Updated: 1:eclipse-swt-3.4.2-13.fc11.i586
    Jul 23 11:38:43 Updated: 1:eclipse-rcp-3.4.2-13.fc11.i586
    Jul 23 11:38:55 Updated: 1:eclipse-platform-3.4.2-13.fc11.i586
    Jul 23 11:39:11 Updated: 2:gimp-2.6.6-6.fc11.i586
    Jul 23 11:39:15 Updated: sane-backends-1.0.20-4.fc11.i586
    Jul 23 11:39:15 Updated: 2:gimp-help-browser-2.6.6-6.fc11.i586
    Jul 23 11:39:17 Updated: setroubleshoot-2.1.14-2.fc11.i586
    Jul 23 11:39:18 Updated: brasero-nautilus-2.26.3-1.fc11.i586
    Jul 23 11:39:29 Updated: Miro-2.0.5-2.fc11.i586
    Jul 23 11:39:43 Updated: pidgin-2.5.8-2.fc11.i586
    Jul 23 11:39:57 Updated: compiz-gnome-0.7.8-19.fc11.i586
    Jul 23 11:39:57 Updated: gnome-keyring-pam-2.26.3-1.fc11.i586
    Jul 23 11:39:58 Updated: compiz-kde-0.7.8-19.fc11.i586
    Jul 23 11:40:17 Updated: ekiga-3.2.5-2.fc11.i586
    Jul 23 11:40:31 Updated: xulrunner-devel-
    Jul 23 11:40:42 Updated: yelp-2.26.0-5.fc11.i586
    Jul 23 11:40:43 Updated: 1:java-1.6.0-openjdk-plugin-
    Jul 23 11:40:54 Updated: cheese-2.26.3-1.fc11.i586
    Jul 23 11:41:06 Updated: mousetweaks-2.26.3-1.fc11.i586
    Jul 23 11:41:24 Updated: eog-2.26.3-1.fc11.i586
    Jul 23 11:41:42 Updated: gnome-terminal-
    Jul 23 11:41:42 Updated: gnome-session-xsession-2.26.2-1.fc11.i586
    Jul 23 11:41:42 Updated: 1:dbus-devel-1.2.12-2.fc11.i586
    Jul 23 11:41:44 Updated: 1:eclipse-jdt-3.4.2-13.fc11.i586
    Jul 23 11:41:48 Updated: gnome-keyring-devel-2.26.3-1.fc11.i586
    Jul 23 11:41:57 Updated: 1:eclipse-pde-3.4.2-13.fc11.i586
    Jul 23 11:41:59 Updated: geoclue-devel-
    Jul 23 11:42:03 Updated: system-config-printer-1.1.8-6.fc11.i586
    Jul 23 11:42:09 Updated: firefox-3.5.1-1.fc11.i586
    Jul 23 11:42:34 Updated: gnome-panel-2.26.3-1.fc11.i586
    Jul 23 11:43:03 Updated: 1:gnome-applets-2.26.3-1.fc11.i586
    Jul 23 11:43:04 Updated: totem-gstreamer-2.26.3-1.fc11.i586
    Jul 23 11:43:04 Updated: totem-xine-2.26.3-1.fc11.i586
    Jul 23 11:43:22 Updated: totem-2.26.3-1.fc11.i586
    Jul 23 11:43:23 Updated: totem-nautilus-2.26.3-1.fc11.i586
    Jul 23 11:43:23 Updated: totem-mozplugin-2.26.3-1.fc11.i586
    Jul 23 12:06:49 Installed: perl-Device-SerialPort-1.04-4.fc11.i586
    Jul 23 12:06:49 Installed: 1:perl-Module-Load-0.12-73.fc11.i586
    Jul 23 12:06:50 Installed: perl-PHP-Serialization-0.27-2.fc11.noarch
    Jul 23 12:06:53 Installed: zoneminder-1.24.1-3.fc11.i586
  6. infra_red_dude

    infra_red_dude New Member

    From the upgrade it looks like you installed GNOME 2.26.2. Mac4Lin should work fine. I'm at a loss of ideas on what could the problem be. Can you manually try installing the themes, icons etc.?
  7. gslams

    gslams New Member

    Thanks for the response, I think the windows borders are ok but it is just the icons which are not the same as mac and the look and feel of evolution which is not like before. I tried to manually install the tar.gz files from the appearance after removing them first but I get the error that it cannot move over the directory. When I run the .sh script as a user, it seems to work ok and then I go into appearance and select them manually.

    Should I just reinstall gnome-panel and see what happens
  8. infra_red_dude

    infra_red_dude New Member

    Are you trying to run the script as root or admin? If so then run it as a normal user.
  9. infra_red_dude

    infra_red_dude New Member

    Evolution seems to haf changed a lot since I last used it. Lemme see what more can I tweak.
    Last edited by a moderator: Aug 8, 2009
  10. infra_red_dude

    infra_red_dude New Member

  11. infra_red_dude

    infra_red_dude New Member

  12. briansmith

    briansmith New Member

    don’t doubt that there are some users legally buying copies of Mac OSX. I would more likely base my assumption on the fact that the first part of the word is HACK. It’s obvious they’re violating the EULA to begin with and having to hack the code to get it to install. So it’s not a real stretch of the imagination to assume that there are many, if not a majority of the copies of the OS being installed the machine of server side too,..
  13. infra_red_dude

    infra_red_dude New Member

    Absolutely no clue what you are talking about!
  14. infra_red_dude

    infra_red_dude New Member

    Mac4Lin is one of Lifehacker's Most Popular Linux Posts of 2009! It feels really good when you see your project figure on one of the Web's most popular tech websites! A big THANK YOU for all the support and appreciation :)

    The author writes: "Mac4Lin Gives Linux Desktops the Complete Mac Look It really, really does. If you don't mind the obvious break in your your free-as-in-speech fidelity, it's a pretty nice setup." Full story: (Mac4Lin is listed just above Jolicloud and Chrome OS)
  15. rav098

    rav098 New Member

    i visited it .... realy nice ....
  16. josefmatthews7

    josefmatthews7 New Member

    To be honest with you, the newest mac4lin compilation makes the elements of my desktop seem very awkwardly juxtaposed. This is not to say I am not a fan of the mac4lin project, but I am much more content with 0.3 as far as accuracy and streamlined looks are concerned.

    video streaming
  17. infra_red_dude

    infra_red_dude New Member

    ^^^ Well, if you are talking about the latest version of gnome and Mac4Lin, then yes a lot has changed and I haven't got a chance to update Mac4Lin.
  18. infra_red_dude

    infra_red_dude New Member

    Just an update, Mac4Lin SVN has been updated with a new version of GTK Themes' and GTK Icons' directories. They are compatible with the latest version of GNOME and distributions like Ubuntu, Fedora etc.

    To download everything goto this page: and on the botton click on "Download Tarball". If you however want to download specific components (like GTK_Theme etc.) then goto that directory and download the specific tarball. To install, you can follow any guide available online to install either the GTK theme or the GTK Icon theme.

    I am yet to make a formal release, but those who want to experiment with the latest version and file bugs are welcome to do so :)

Share This Page