mail and dns error

Discussion in 'Installation/Configuration' started by wontolla, Jul 3, 2008.

  1. wontolla

    wontolla New Member

    Hi, I'm testing ISPconfig before moving our server and I'd several troubles, I'd followed the perfect server guide and we have 2 domains, only one of them had the DNS from our ISP pointing to our IP, the another should wait till everything works ok.
    We're using Ubunt 8.0.4.
    1- configured the .eu domain it work from one to another account but couldn't receive any email form outside, mail returned to senders with a relay error "Relay access denied Mon
    2008-06-30 17:12:02: --> QUIT

    2-Deleted the domain an recreate it again, now i messed with the USER PREFIX (I'd read the boards and restore it to original) but no mail is acceptedm now with DNS error: "Jul 3 15:46:40 wesser postfix/smtp[8459]: 7E07F12FA40F: to=<[email protected]>, orig_to=<[email protected]>, relay=none, delay=0.03, delays=0.03/0/0/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for type=AAAA: Host not found)
    Jul 3 15:46:40 hostname postfix/qmgr[8431]: 7E07F12FA40F: removed"

    It's strange but no were created or defined anywhere. So no mail, what can I do/check right now?
    Last edited: Jul 3, 2008
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that the domain which is set as myhostname and mydomain in the postfix file really exists and that the domain that the command "hostname" returns really points to the IP of your server.
  3. wontolla

    wontolla New Member

    just checked and found myhostname with several aliasses one of them and servername =, both entries, there's nomyhosntame entry, changed hostname only shows the name server no IP, and I still the same error Name service error for type=AAAA: Host not found) but I've never set that domain in ISPConfig, I'd set I won't create the .es till .eu is working.

    btw I'd read the How To Run Your Own Name Servers With ISPConfig And GoDaddy and checked the DNS data so I'd matched with the how to (only one server) and nothing, still the same error.
    Last edited: Jul 4, 2008
  4. falko

    falko Super Moderator ISPConfig Developer

    Is listed in /etc/postfix/local-host-names?

    If doesn't exist in DNS, you can add it to /etc/hosts for now.
  5. wontolla

    wontolla New Member


    Is listed in /etc/postfix/local-host-names?

    Yupp, with and without www.

    If doesn't exist in DNS, you can add it to /etc/hosts for now.

    Added, / changed and still the same. localhost
    local IP alias

    it doesn't work on external and internal mail with the same error, any more help?.
  6. wontolla

    wontolla New Member

    any help? plz I don't wish to format and restart the full conf process, btw there's any guide how to fully config the mail server? It could be very handy.
  7. wontolla

    wontolla New Member

    Reaally it was a dns error, I'd created in ISPconfig and now the works, I hope when DNS are pointing here from my ISP for the .es domains works.

    Thank you very much.

Share This Page