mail config settings in multiserver set-up - roundcube - connection to storage server failed

Discussion in 'Installation/Configuration' started by 5t3f4n, Nov 2, 2021.

  1. 5t3f4n

    5t3f4n New Member

    hi all
    need your assistance to give me a direction in debugging - i have followed the perfect multiserver tutorial for debian 10.
    the issue to resolve is that when going to '' or '' i get the roundcube error message 'connection to storage server failed'

    current settings (Note: currently using external DNS provider (i.e. haven't yet set-up and started using the DNS service in ISPConfig):

    Code: with individual A record pointing to with individual A record pointing to with individual A record pointing to
    roundcube config
    $config['default_host'] = 'ssl://';
    $config['smtp_server'] = 'tls://';
    $config['smtp_port'] = 587;
    what configuration needs to get set to enable roundcube usage? what options do i have to de-bug?


    root@web01:~# lsb_release -a
    No LSB modules are available.
    Distributor ID:    Debian
    Description:    Debian GNU/Linux 10 (buster)
    Release:    10
    Codename:    buster
    php version
    root@web01:~# php -v
    PHP 7.3.31-1+0~20210923.88+debian10~1.gbpac4058 (cli) (built: Sep 23 2021 22:03:28) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.3.31, Copyright (c) 1998-2018 Zend Technologies
        with Zend OPcache v7.3.31-1+0~20210923.88+debian10~1.gbpac4058, Copyright (c) 1999-2018, by Zend Technologies
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    First thing to check is you really have followed the instructions in the tutorial accurately.
    Then do this:
    You wrote the error message is 'connection to storage server failed'. I would check the /etc/hosts file on every host in your setup is correct and has all the hosts listed. Other than that, try to see if log files give more info or use Internet Search Engines with that error message.
  3. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    The server names, ports and ssl/tls related settings vary depending on your setup. The "storage server" is the imap server(s), corresponding to the default_host setting. You could try something like $config['default_host'] = 'tls://your.server.tld'; and also read the comments for the settings in the roundcube config file to see what other options there are. If you need to ignore certificate errors (eg. for a self-signed certificate) and probably most any other config examples you'd need, search the forums here and hit search engines as @Taleman said.

Share This Page