Mail errors unknown address

Discussion in 'General' started by terryoleary1981, Jan 7, 2008.

  1. terryoleary1981

    terryoleary1981 New Member


    I've not been able to receive any emails to the email i've setup using ispconfig. I can send no problem but there seems to be a problem receiving. When I email the account i get the following error back

    5.10 - Unknown address error 550 - relay not permitted.

    Seems i may have configured something incorrectly, can anyone help and i'm new to linux.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the error messages from the mail log.
  3. terryoleary1981

    terryoleary1981 New Member

    Sure, where abouts can i find the log?

    The error i get is actually

    This is an automatically generated Delivery Status Notification

    Delivery to the following recipient failed permanently:

    [email protected]

    Technical details of permanent failure:
    PERM_FAILURE: SMTP Error (state 13): 550 relay not permitted

    (i've changed the email addy here for privacy)

    My log is:

    Last edited: Jan 7, 2008
  4. terryoleary1981

    terryoleary1981 New Member

    also this is the contents of my resolv.conf (which somewhere i read might be helpful to know?!?!)
    ------------------------------------- is the internal ip of the router.
  5. terryoleary1981

    terryoleary1981 New Member

    anyone able to help with this problem as it is still an issue.

  6. falko

    falko Super Moderator ISPConfig Developer

    Please check if the MX record of the domain that you're sending to is pointing to the right server:
    dig mx
  7. terryoleary1981

    terryoleary1981 New Member

    when i did that the MX record for the domain points at

    i've changed my domain name from the real on to here for privacy.

    think this looks odd as it has my external IP address.mydomain name? Have i messed up somewhere?
  8. falko

    falko Super Moderator ISPConfig Developer

    resolve to the right IP?
  9. terryoleary1981

    terryoleary1981 New Member


    when i run dig i get

    ;; Query time: 46 msec
    ;; SERVER:
    ;; WHEN: Thu Jan 10 00:06:14 2008
    ;; MSG SIZE rcvd: 111

    the server it resolved too is the internal IP address of the router here.

    I dont really know what i should be setting my MX and @ records to with the registrar so that is my first problem! What should it be? At the moment the @ record is set to the external ip and the mx record is

    (where my domain is my domain name)
  10. falko

    falko Super Moderator ISPConfig Developer

    That's right.

    You must also create an A record for (should point to your public IP address as well).

Share This Page