Mail server able to send but not receive

Discussion in 'Server Operation' started by anark10n, Jul 1, 2016.

  1. anark10n

    anark10n Member

    So, I've just recently set-up a web and mail server, Debian 8 with Apache 2, Dostfix, Dovecot, ISPConfig 3. I used ISPConfig control panel to create mailboxes for my domain, and I am able to send messages without a hassle. Problem is when I try to send to the email address. Gmail and Yandex complains that no such user exist, even when I reply on the message, and Yahoo reports that there's no MX or A records for the domain, even though the records exist.

    Any pointers on how to go about figuring why this happens?
    daipaahmed and ahmeddaipa like this.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the domain with a dns checker, e.g. to ensure that the domain really has an correct MX record.
    daipaahmed and ahmeddaipa like this.
  3. anark10n

    anark10n Member

    All green on MX records.
    daipaahmed and ahmeddaipa like this.
  4. Samo_slo

    Samo_slo Member

    I had the same problem. My problem was that i tried to run 2 primary servers with only 1 public IP when i was moving from old win server to new linux server. With only 1 server you should check the DNS settings. Have you ports 25 and 110 open in the firewall? I'm new to but that where my problems hope they help.
    ahmeddaipa likes this.
  5. anark10n

    anark10n Member

    I haven't configured the firewall at all, still learning how to on my test environment for now, so there rules on it are the default ones that come with Debian 8. And port 25 is open on my server, I'm going to do a more thorough test when I get time later and post the results. And I only have the one server and didn't migrate anything.
  6. Samo_slo

    Samo_slo Member

    You configure the firewall in ISPConfig under system. If your server is in the test environment and can't be reached from outside your local network than mail can't work. If you can send mail from the system than it's probablly configured ok, but until you don't configure the DNS and domain name for your server so it can be reached from outside you won't be able to recive email. That was my problem at least.
  7. anark10n

    anark10n Member

    Ok, fixed the issue, it was a problem with the mydesitnation line in /etc/postfix/, had my FQDN in it. Removing it fixed it.

    Is there a way to mark the thread as solved, or do I just edit the title?

Share This Page