mailrouting problem

Discussion in 'Installation/Configuration' started by trueshanti, May 11, 2006.

  1. trueshanti

    trueshanti New Member


    i run ispconfig 2.2.2 and am now to setting up the postfix-server finally ... i remember that the mailrouting already worked for local users .. but now no more :-( on any user-mail-account

    i always get an error like this when trying to send mail

    status=bounced (User unknown in virtual alias table

    the MX record is ok
    ;                       IN      ANY
    ;; ANSWER SECTION:                86400   IN      SOA 2006050917 28800 7200 604800 86400                86400   IN      NS                86400   IN      NS                86400   IN      MX      10                86400   IN      A
    ;; ADDITIONAL SECTION:            86400   IN      A            86400   IN      A           86400   IN      A

    the mailname is ok
    the user-email is in /etc/postfix/virtusertable
    /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php give me no errors
    ispconfig.log only shows INFOs .. no errors or Warnings
    ftp/ssh/imap ist working great

    infact not even one email is routing correctly

    since i read many postings around this topic now it seems to have something to do with DNS .. but DNS works flawlessly :-Ü ..

    badly my postconf is too long to post here
    but one entry is:
    virtual_alias_maps = $virtual_maps

    i guess thats ok

    i am rather new to postfix ..

    what do you think .. please .. i am open for any suggestions



    btw i miss a feature in postfix that was like 'exim -bt [email protected]' to trace mailrouting without sending mail .. is there a similiar function in postfix ??
  2. trueshanti

    trueshanti New Member


    aha .. ispconf is different .. so it doesnt like anykind of hosted "Virtual" host/domain as $myorigin ..

    the default FQHN by my provider did the show

    tnx 4 trying :eek:

Share This Page