Mailuser interface

Discussion in 'Plugins/Modules/Addons' started by Horfic, Aug 23, 2009.


Would you like to see a mailuser interface for Roundcube & Squirrelmail?

  1. Yes

    220 vote(s)
  2. No

    3 vote(s)
  1. Horfic

    Horfic Member

    ... :(

    You can install it whereever you want, for what you want to use it and how you configure your apache vhost file.
  2. radim_h

    radim_h Member HowtoForge Supporter

    /var/www/mail.yourdomain.tld or /var/www/webmail.yourdomain.tld
    chown www-data:root
  3. Horfic

    Horfic Member

    If you are using ISPConfig 3, just create the website load the roundcube on it and it normaly gets the right chown.
  4. Sepi

    Sepi New Member

    Thanks for this great job.

    I made Hungarian translation for ispconfig3_roundcube4 plugins.
    Please put this language files into the svn packages...

    Many thanks...

    Attached Files:

    Last edited: Aug 23, 2010
  5. Sepi

    Sepi New Member


    I have a problem with the plugins. I made the instructions what the guide are showing.
    But the roundcube says "Soap Error: Forbidden". Every time, when I click on the spam plugin option or a mail filter option get this message.
    The installed versions are: ispconfig, roundcube 0.4

    Can anybody help me, what might wrong?
    Thanks for help
  6. 007007

    007007 New Member

    Last edited: Aug 29, 2010
  7. giftsnake

    giftsnake New Member

    apt-get install subversion
  8. logicasrl

    logicasrl New Member

    Still "SOAP Error"

    Hi everybody,

    I've tried to follow the instructions to install the "mailuser interface" both with Roundcube 0.3.1 and with Roundcube 0.4 (ISPConfig on Debian 5.0.4), but in both cases I obtain a "SOAP Error: you do not have the permissions to access this function" in the "ispconfig3_pass" and in the "ispconfig3_spam" "modules".
    "Autoreply" and "Filter", instead, work perfectly (already tested).

    I suspect a problem with the "remote_functions" field syntax in the "remote_user" table in the ISPConfig DB.

    I would ask you if the following syntax (copied from the howto) is tested under ISPConfig

    UPDATE `remote_user` SET `remote_functions` = 'mail_user_get,mail_user_update,mail_alias_get,mail_forward_get,mail_forward_add,mail_forward_update,mail_spamfilter_user_get,mail_spamfilter_user_add,mail_spamfilter_user_update,mail_fetchmail_get,mail_fetchmail_add,mail_fetchmail_update,mail_fetchmail_delete,mail_user_filter_get,mail_user_filter_add,mail_user_filter_update,mail_user_filter_delete' WHERE `remote_user`.`remote_username` = 'ru_rc_webtest_admin' LIMIT 1 ;

    unfortunately I don't manage to find documentation about "remote_functions" syntax...

    Tell me and I can give you all the needed details of my installation.

    Thank you very much.

    Kind regards,
    Luca Z.
  9. HyperAtom

    HyperAtom New Member

    I also had the permission denied error, I gave access to Horfic so he fixed the problem for me. Not sure what he did but he told me to use his dev trunk for the most up to date plugin.
  10. 007007

    007007 New Member

    i have the same problem, all plugins works great, except password/spam/blackwhitelist plugins, i get this error :

    SOAP Error: you do not have the permissions to access this function

    i use : ispconfig 3.0.3 and roundcube 4


    this is a bug?
    Last edited: Aug 31, 2010
  11. logicasrl

    logicasrl New Member

    I've read this thread a little more and probably the solution has already been posted by Horfic some days ago: take a look here:

    Tomorrow I'll give these suggestions a try and make you all know the result.

  12. logicasrl

    logicasrl New Member

    NOW almost everything is working right


    I have followed the directives given by Horfic in the following link:

    and now EVERYTHING (with one exception) is working correctly. Thank you to Horfic :)
    Password, autoreply, filter and spam are ALL OK.

    The last problem is in the "white/black list" addon: in this case the "SOAP error: you do not have the permissions to access this function" remains.

    I'm using ISPConfig, Roundcube 0.4 and the addon downloaded from "" and installed by Subversion (svn).

    Here is it the content of the "remote_functions" field in the "remote_user" table of the "dbispconfig" database:

    Is there something else to control?

    Thank you again,
  13. logicasrl

    logicasrl New Member


    Solved the last problem on the "white/black list" addon :D

    Simply used the SQL suggested by Horfic here "".

    It is necessary to execute this instruction directly in the "dbispconfig" DB (through phpmyadmin, for example):
    UPDATE `remote_user` SET `remote_functions` = 'mail_domain_get,mail_domain_add,mail_domain_update,mail_domain_delete;mail_user_get,mail_user_add,mail_user_update,mail_user_delete;mail_alias_get,mail_alias_add,mail_alias_update,mail_alias_delete;mail_forward_get,mail_forward_add,mail_forward_update,mail_forward_delete;mail_spamfilter_whitelist_get,mail_spamfilter_whitelist_add,mail_spamfilter_whitelist_update,mail_spamfilter_whitelist_delete;mail_spamfilter_blacklist_get,mail_spamfilter_blacklist_add,mail_spamfilter_blacklist_update,mail_spamfilter_blacklist_delete;mail_spamfilter_user_get,mail_spamfilter_user_add,mail_spamfilter_user_update,mail_spamfilter_user_delete;mail_policy_get,mail_policy_add,mail_policy_update,mail_policy_delete;mail_fetchmail_get,mail_fetchmail_add,mail_fetchmail_update,mail_fetchmail_delete;mail_user_filter_get,mail_user_filter_add,mail_user_filter_update,mail_user_filter_delete;client_get,client_get_id,client_add,client_update,client_delete;server_get' WHERE `remote_user`.`remote_username` = '<<REMOTE USERNAME>>' LIMIT 1 ;

    For some strange reason, activate the following list in the remote user profile in ISPConfig is NOT sufficient:
    Mail domain functions
    Mail user functions
    Mail alias functions
    Mail forward functions
    Mail catchall functions
    Mail transport functions
    Mail whitelist functions
    Mail blacklist functions
    Mail spamfilter user functions
    Mail spamfilter policy functions
    Mail fetchmail functions
    Mail user filter functions
    Mail filter functions
    Client functions
    probably because in my ISPConfig version ( the voice "Server functions" is NOT present...

    In any case, now all is working perfectly :)

  14. 007007

    007007 New Member

    this is only for ispconfig3.2.2, it's not worked for me (ispconfig3.0.3) :eek::eek:
  15. letic

    letic New Member

    Hey Horfic,

    Here is my small contribution. You will find the updated French UTF-8 translation for your plugins. At the moment we are only using 3.0.2 but as soon as 3.0.3 is released I'll make sure that all plugins that do not work with 3.0.2 are correctly translated as well.

    Hope this help

    Attached Files:

  16. SeberIT

    SeberIT New Member

    adding forward clears mail filter/custom rules

    I have a problem with the forward plugin. When I fill out a forward address (without enabling it), my custom rules view in the CP for the user gets empty. When I click and save all mail filters one by one, the custom rules field is filled again.
  17. blackangel

    blackangel New Member

  18. Horfic

    Horfic Member

  19. blackangel

    blackangel New Member

    Yep, thank you for this link :)

    What I did:
    - I was on
    - I've clicked on "SPConfig 3 mailuser interface for roundcube [Info + Download]"
    - and I was redirected to

    I think they should update this link on the official website and also on sourceforge:

    Thanks again.
  20. Rupert

    Rupert New Member


    im still having problems getting the svn checkout:

    # svn checkout .
    svn: OPTIONS of '': could not connect to server (
    websvn works fine
    isnt there a packed file to download for people having svn trouble?

Share This Page