Mailuser interface

Discussion in 'Plugins/Modules/Addons' started by Horfic, Aug 23, 2009.


Would you like to see a mailuser interface for Roundcube & Squirrelmail?

  1. Yes

    220 vote(s)
  2. No

    3 vote(s)
  1. radim_h

    radim_h Member HowtoForge Supporter

  2. radim_h

    radim_h Member HowtoForge Supporter

    autoreply plugin - "set date" not working

    There is problem with autoreply config in this version

    Default Start on: and End by: dates in Roundcube plugin are 0000-00-00 00:00:00
    No matter If you set them to valid or invalid value, no error message appears...
    In both cases In Mysql table then 0000-00-00 00:00:00 is always set for both dates 0000-00-00 00:00:00. Interresting is that autoreply is working anyway then...

    If you set any value for autoreply in ISPC, then Roundcube plugin is showing this value correctly when you open it. But when you change date to different value (also if the value is valid), 0000-00-00 00:00:00 is saved to MySQL table again

    I have tried it With Czech and also English version to be sure it's not matter of localization...
    Last edited: Jan 11, 2011
  3. gOOvER

    gOOvER Member

    i got a little problem, when i install the Mailuser Interface on Rondcube 0.5, i can't login anymore with a mailuser.

    After i disable trhe Plugins, i can login. Is the Mailuser interface ready for 0.5??
    Last edited: Jan 18, 2011
  4. Horfic

    Horfic Member

    You probably activated the autoselect feature, please deselect it and it should work.
  5. Davide

    Davide Member

    Updated spanish and new galician translations


    I attach new translation (galician language, gl_ES) and updated Spain Spanish (es_ES)
    Please, add them to the plugins

    Thank you for the ISPConfig Roundcube plugins. They are terrific!

    Attached Files:

  6. Davide

    Davide Member

    Just a little correction

    One simple correction to the ispconfig3_spam gl_ES translation

    Please, apply it.

    Thank you

    Attached Files:

  7. Davide

    Davide Member

    More corrections

    Sorry for the "corrections rain".
    I'm seeing them while I use roundcube.

    These are for the "ispconfig3_pass" and "ispconfig3_forward" translations. Please apply them

    Thank you!

    Attached Files:

    Last edited: Jan 24, 2011
  8. djsmiley

    djsmiley New Member


    I'm a new user of the ispconfig3 control panel, and i ran into a problem with these plugins for roundcube.
    I have a Debian Squeeze user with the latest ispconfig (, and the latest roundcube webmail (0.5). If i activate the ispconfig3_account plugin, then it throws an error like this: SOAP error error fetching http headers.
    How can i repair this error, because everything works like a charm, but i would like to fire up this plugin, because it is a great help for my mail users.

    Thanks for the help!

  9. moglia

    moglia New Member

    I´m using RC 0.4 and Tested 0.5.
    I have latest SVN version of ISPCONFIG.

    I see only diference i´m using Debian Stable (Lenny) not Squeeze (Testing).
    Make tests using Stable. and Testing if it work. I need make some tests on Squeeze to see any diferences.

    I´m wait for official release of Squeeze.
  10. Davide

    Davide Member

    Please, follow these instructions step by step. They work for me with the same configuration as you.
  11. djsmiley

    djsmiley New Member

    Thanks for the tip, i reinstalled the whole system (roundcube, and the plugins), reconfigure the remote user name and password and then it works. I love it! :)
    Maybe i do something wrong at morning, because i migrating to ispconfig during the whole night.

    Thanks again!

  12. moglia

    moglia New Member

    Quote About Migration

    Don´t migrate accounts manually inserting data direct on database.
    IF you need migrate mass users use SOAP client to insert mail accounts.

    I experienced erase account information/data on manual inserts. Before update via panel.
  13. zigi

    zigi New Member

    updated/patched version of ispconfig3_forward for ISPConfig >3.0.3

    Hello Horfic,

    I have updated/patched ispconfig3_forward plugin to use ISPConfig's (version >3.0.3) 'Send copy to' mailbox parameter instead of generating custom mail filter rules.

    Attached Files:

  14. johjoh2k

    johjoh2k New Member

    Hi, before congratulation for this useful plugins.

    I get a warning when only when I click on "Account","General": "Soap Error: Error Fetching http headers"

    Any other plugin "Password", "Fetchmail", "Forward",..... work perfectly

    Another question in the Spam Tab I don't get the value in the box Manage Modality

    Thank you for any suggestion
  15. vStone

    vStone New Member

    [PATCH] Integrate with identities.

    I've created a patch for the ispconfig3_account plugin.

    This patch hooks into identities, changing the email field to be a select (drop down) field populated with all aliases a user has access too. There is also a check on submitting the form, to prevent naughty users to override the form html.

    Users must be allowed to 'edit' their email field for this:
    $rcmail_config['identities_level'] = 0;
    I have not tested this when using 'identities_level' = 2; *yet*

    Additionally, I moved some soap logic into a function of its own to make it more re-usable.

    Some other suggestions:
    • svn propset:eol-style native on all files.
      I'm not a big fan of windows line endings :)
    • cp

    Attached Files:

  16. stephan1024

    stephan1024 New Member

    Roundcube 0.4 mentioned as required roundcube version, has any work or testing been done with 0.5.1. Installed and followed configuration, no account tab displayed. Is there a way to get this going or remove and install older version. Thanks for the help guys.
  17. vStone

    vStone New Member

    Note. I only tested this on roundcube 0.5.x
  18. vStone

    vStone New Member

    I installed the plugins from trunk and everything seems to be working just fine.
  19. stephan1024

    stephan1024 New Member

    If I apply the following in while having an active session on roundcube, accounts tab becomes visible.

    // List of active plugins (in plugins/ directory)
    $rcmail_config['plugins'] = array("ispconfig3_account", "ispconfig3_autoreply", "ispconfig3_autoselect", "ispconfig3_pass", "ispconfig3_spam", "ispconfig3_fetchmail", "ispconfig3_filter", "ispconfig3_forward", "ispconfig3_wblist");

    But as soon as I log out, I am unable to log back in again. Any ideas?

  20. vStone

    vStone New Member

    Have you tried enabling some logging?
    This is my (maybe (ir)relevant) configuration:
    // Note: I only use this for debugging. In production, I tend to prefer using syslog :)

    // For some logging:
    $rcmail_config['debug_level'] = 1;
    $rcmail_config['log_driver'] = 'file';
    $rcmail_config['smtp_log'] = true;
    $rcmail_config['log_logins'] = true;
    $rcmail_config['sql_debug'] = true;
    $rcmail_config['imap_debug'] = true;
    $rcmail_config['ldap_debug'] = false;
    $rcmail_config['smtp_debug'] = true;
    // List of active plugins (in plugins/ directory)
    $rcmail_config['plugins'] = array(
    Also, try to check out log files in /var/log/mail.*. Maybe they will give a clue to what is going wrong.

Share This Page