Mailuser interface

Discussion in 'Plugins/Modules/Addons' started by Horfic, Aug 23, 2009.


Would you like to see a mailuser interface for Roundcube & Squirrelmail?

  1. Yes

    220 vote(s)
  2. No

    3 vote(s)
  1. stephan1024

    stephan1024 New Member

  2. girardan

    girardan New Member


    do you have succeeded to solve this pbe?? if yes could you please tell me how you have done.

  3. stephan1024

    stephan1024 New Member

    Hey there,

    as per vStone's reply here
    I replaced my plugins array with his example.

    And that did the trick.
  4. vistree

    vistree Member HowtoForge Supporter

    date and time on autoresponder

    Hi Horfic, is there any update on the time settings in the autoreply plugin? I still can't use date and time in the mailuser interface.

    Kind regards and a nice afternoon!
    Last edited: Mar 5, 2011
  5. demmtrok

    demmtrok New Member

    Hi folks,

    i am experiencing quite the same problems like stephan1024. After installing the roundcube plugin there is no account tab shown.

    The server is running a clean debian squeeze installation with ispconfig and roundcube 5.1.

     | Main configuration file                                               |
     |                                                                       |
     | This file is part of the Roundcube Webmail client                     |
     | Copyright (C) 2005-2010, Roundcube Dev. - Switzerland                 |
     | Licensed under the GNU GPL                                            |
     |                                                                       |
    //$rcmail_config = array();
    // List of active plugins (in plugins/ directory)
    $rcmail_config['plugins'] = array("ispconfig3_account", "ispconfig3_autoreply", "ispconfig3_pass", "ispconfig3_spam", "ispconfig3_fetchmail", "ispconfig3_filter", "ispconfig3_forward", "ispconfig3_wblist");
    I also tried changing it (like stephan1024 did) to
    // List of active plugins (in plugins/ directory)
    $rcmail_config['plugins'] = array(
    but without any success.

    web/plugins$ cat ispconfig3_account/config/

    $rcmail_config['remote_soap_user'] = 'remoterc';
    $rcmail_config['remote_soap_pass'] = 'longpassword';
    $rcmail_config['soap_url'] = '';

    Roundcube is installed in a separate web like:

    /web$ ls -alh

    insgesamt 120K
    drwx--x--- 12 web1 client0 4,0K  5. Mär 00:06 .
    drwxr-x--x  7 web1 client0 4,0K  5. Mär 00:16 ..
    drwxr-xr-x  2 web1 client0 4,0K  5. Mär 00:03 bin
    -rw-r--r--  1 web1 client0 9,0K  9. Feb 13:46 CHANGELOG
    drwxr-xr-x  2 web1 client0 4,0K  5. Mär 00:06 config
    drwxr-xr-x  2 web1 client0 4,0K  4. Mär 23:35 error
    -r--r--r--  1 web1 client0  103  4. Mär 23:56 .htaccess
    -rw-r--r--  1 web1 client0  11K  9. Feb 11:51 index.php
    -rw-r--r--  1 web1 client0 8,2K 29. Jan 15:55 INSTALL
    -rw-r--r--  1 web1 client0  18K 29. Okt 2008  LICENSE
    drwxr-xr-x  2 web1 client0 4,0K  5. Mär 00:03 logs
    drwxr-xr-x 34 web1 client0 4,0K  5. Mär 00:49 plugins
    drwxr-xr-x  7 web1 client0 4,0K  5. Mär 00:03 program
    -rw-r--r--  1 web1 client0 2,3K 12. Jan 16:54 README
    -rw-r--r--  1 web1 client0   26 22. Mär 2008  robots.txt
    drwxr-xr-x  3 web1 client0 4,0K  5. Mär 00:03 skins
    drwxr-xr-x  2 web1 client0 4,0K  5. Mär 00:03 SQL
    drwxr-xr-x  2 root root    4,0K  5. Mär 00:30 stats
    drwxr-xr-x  2 web1 client0 4,0K  5. Mär 00:03 temp
    -rw-r--r--  1 web1 client0 1,1K 15. Apr 2010  UPGRADING

    The webs php.ini is unchanged, except off:
    suhosin.session.encrypt = Off
    to get roundcube working.

    May I provide you any furthermore information?
  6. vStone

    vStone New Member

    Note: by using my plugin array, you have also enabled 3 other plugins. Check if they exist or try removing them to narrow the problem down.
  7. demmtrok

    demmtrok New Member

    Hi vStone,

    I did that from the beginning.

    [email protected] New Member

    Disabling Mail Filter, Auto Reply, Forwarding doesn't work

    Hello Everyone,

    Was able to successfully installed the plugins managed to make it work except that, for example creating a mail filter rule is ok but when deleting the filter it doesn't delete the one that is in the custom rules. The same problem also applies with forwarding. Disabling auto reply on RC doesn't work also.

    Is anyone experiencing the same problem?

    Am I missing something?

    RC 4.1
    Last edited: Mar 14, 2011
  9. itwillcome

    itwillcome New Member

    Successfully installed on CentOS 5.5:
    PHP 5.2, ISPConfig, RoundCubeMail 0.5.1

    Working like a charm!!

    Thanks Horfic for the wonderful plugin.
    Thanks Falko and Till for the amazing ISPConfig!!! :D

    Attached is the Traditional Chinese translation (zh_TW) for the plugin.

    Attached Files:


    [email protected] New Member

    Start and End date for autoreply plugin

    Hello everyone,

    Anyone experiencing problem with the start and end date of the auto reply plugin? It doesn't seem to reflect on the database once set.

    I have read somewhere in this thread that there seems to be a problem and there were requests of making it a select box rather than an input text box.
  11. radim_h

    radim_h Member HowtoForge Supporter

    Installed on Debian Squeeze, ISPC 3.0.3, Roudcube 0.5.1

    Version for Roudcube 0.4 still works in 0.5.1
    except the Start and End date autoreply plugin
    there is still same error, no matter what you set there is still
    Start on: 0000-00-00 00:00:00
    End by: 0000-00-00 00:00:00
    and date is not written into ISPC mail_user database

    at least in datab\se then is
    autoresponder_start_date 0000-00-00 00:00:00
    autoresponder_end_date 0000-00-00 00:00:00
    which means autoresponder is working all the time
  12. radim_h

    radim_h Member HowtoForge Supporter

    More problems With Roudcube 0.5.1

    EDIT: apology
    i was testing all this in 0.4.1 by mistake.
    So 0.5.1 works exactly same as 0.4.1 (there is also no mysql Alter for update from 0.4.1 to 0.5.1)


    Afer testing, there is more problems with Roudcube 0.4.1 & 0.5.1 (behaving same)

    you can set it and it works
    anything you set for Fetchmail in Roudcube, you cannot see in ISPConfig
    if set in ISPConfig you CAN see it in Roudcube
    is working, but any Forwarding you set in Roudcube, you cannot see in ISPConfig
    If you set in roudcube, canNOT see in webmail
    Auto reply, you can see in ISPConfig what was set in Webmail,
    only date From-To is not possible to set in Roudcube as i wrote above
    Mail Fiter
    if you set one in ISPConfig, you can modify it in Webmail
    if you set one in Webmail, you see it in list of mailfilters in ISPC, but you canNOT view the rule of modify it in ISPconfig, getting error "Error 1. error_no_view_permission"


    Black/White list, Junk are OK, you can see them in ISPConfig
    Last edited: Apr 15, 2011
  13. Horfic

    Horfic Member


    Autoreply is now working, was a bit difficult and got now the datetime widget

    Forwarding is now compatible with the one from ISPConfig.
    Fetchmail is working again correctly.

    I couldn't reproduce the mail filter problem, tried it, didn't got that problem.

    So go on and update the plugins.

    Tested with ISPConfig and Roundcube 0.5.1

    PS: Sorry for my long silent. I'm a bizzy man and this is one of the many non paid projects I got.
  14. gOOvER

    gOOvER Member

    Thank you for the great Update :)
  15. i-chat

    i-chat New Member

    probably a simple question (but ment as retorical one)

    where is the webmail client installed when running in a multi server setup.

    A: on the webserver (offcaurce).
    B: i dont know,
    C: on the mailserver silly, its email isn't it?

    the reason i ask is this: say you have 10's of websites hosted on your mulit server setup. thair databases all hosted on a dbserver ( a nice i7 16core server with 100gb ram,
    all email is hosted on a dedicated mail server, - its just your old database server - that got to slow for that job, but was still verry powerfull, and it had lots of disspace for mailboxes (right?) - but the thing is, email is verry verry cheap on resources, one server could easily run hundreds of mailboxes and still have many cpucicles to spare

    your webservers however do not, - running a simple joomla - mambo or worldpress site - or maybe wikkipress OScomece or even worse phpnuke, if anyone of you remembers.... actually costs your server many cilces. and lots of ram ... (up to 128 mb per websites)

    so is it really that obvious running a static sevice like webmail in multiple instances on all your webservers rather than on the same server as your smtp and imap servers. - it is aready runing most of the software required (ie: php + mysql ) - even if you dont want t run a fullblown apache on it, you could easily run a tiny https- server with just 1 webroot - your webmail aplication.
  16. radim_h

    radim_h Member HowtoForge Supporter

    Repository for 0.5.1 is still ?

    Because when i try update i only get the revision, but no files or functions is changed.
    Did i something wrong ?

    working now, there was some problem with file permissions
    Last edited: Apr 19, 2011
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats up to you. I would use option A.
  18. radim_h

    radim_h Member HowtoForge Supporter

    CZ localization

    i have sent you cs_CZ localization couple months ago..
    Can you integrate it with the plugin plz ?
  19. radim_h

    radim_h Member HowtoForge Supporter

    dependance on ?

    Are the new plugins depending on ISPC ?

    i have tried it on ISPC and Roundcube 0.5.1. and the only plugin "password change" is working and it is very slow...
  20. Horfic

    Horfic Member

Share This Page