Mailuser interface

Discussion in 'Plugins/Modules/Addons' started by Horfic, Aug 23, 2009.

?

Would you like to see a mailuser interface for Roundcube & Squirrelmail?

  1. Yes

    220 vote(s)
    98.7%
  2. No

    3 vote(s)
    1.3%
  1. radim_h

    radim_h Member HowtoForge Supporter

    thank you !

    now it works everything as expected (because i'm stupid and haven't set /plugins/ispconfig3_account/config/config.inc.php after new installation :| )

    anyway, it would be great to have name from
    ISPC =>Email=>Email Mailbox=>Realname
    bounded to RoundCube Settings=>Identities=>Display name
    (use Realname from ISPC db not from RC db)

    this suppose have this line in roudcubemail/config/main.inc.php
    // Set identities access level:
    // 0 - many identities with possibility to edit all params
    // 1 - many identities with possibility to edit all params but not email address
    // 2 - one identity with possibility to edit all params
    // 3 - one identity with possibility to edit all params but not email address
    $rcmail_config['identities_level'] = 3;
    other setting doest make sense anyway or aliases in RC may collide with aliases in ISPC
     
    Last edited: Jun 5, 2011
  2. smokers

    smokers New Member

    Hey guys,.. i have a big / small problem ;-)

    Everytime i'm clickin on
    Account --> Any new Button with this plugin

    there is an error like :

    Soap Error: SOAP-ERROR: Encoding: string 'XXXXXXX' is not a valid utf-8 string


    I'm using the newest ISPConfig from SVN dont know realy which rev and Roundcube Stable: 0.5.2

    And of course the newest version of the plugins from SVN.

    Can anyone help me please?
     
  3. Davide

    Davide Member

    Spanish and galician translations

    Hi, Horfic

    Could you add these translations to trunk?

    gl_ES is a new translation
    es_ES is correcting some strings

    Thank you!
     

    Attached Files:

  4. theWeird

    theWeird Member

    I've got a problem with the autoselect plugin.

    The plugin retrieves the correct hostname in the method authenticate.
    Let's say it is mymailserver.example.com.
    With this value returned for 'host' nobody can log in.
    If I overwrite the found hostname in method authenticate with imap.example.com (DNS entry points to the same server) the login works.

    Do you have any idea?
     
  5. demmtrok

    demmtrok New Member

    weird quota problem

    Hey,

    after installing roundcube 0.5.2 and reinstalling the mailuser interface everything worked fine. But I found another weird error:

    When a mailbox has a quota >2040MB and the user changes his password, the password change is done correctly, but in the mysql db (and ispconfig interface of course) ist set back to 2047.9999990463 MB.

    Can anybody reproduce that?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Do you have a 32- or 64-bit system?
     
  7. demmtrok

    demmtrok New Member

  8. theWeird

    theWeird Member

  9. falko

    falko Super Moderator ISPConfig Developer

    Ok, you are on a 32-bit system, and I guess the upper limit is 2047.9999990463 MB. I think you don't have this problem on a 64-bit system.
     
  10. demmtrok

    demmtrok New Member

    hm. I actually can grant more than 2 GB mailboxsize via the ispconfig panel (and change the password there without any problems), the mailboxsize is only messed up when changing the password via mailuser plugin
     
  11. pma_

    pma_ New Member

    I have problem with out-of-office plugin, I enabled ooo and checked in ISPConfig, message was ok but dates were missing and wasn't started.
    After clicking now atoresponder is working and changed dates are correct in roundcube.
    Any hint?
     
  12. demmtrok

    demmtrok New Member

    Hi,

    we found a bug or something :) If a user changes his password via the mailuser-interface, and the new password contains the special character "ß", the password change is accepted, but he cant use the new password after that.
     
  13. m.henze

    m.henze New Member

  14. Horfic

    Horfic Member

    you should always use the trunk version not the branches. try the trunk
     
  15. m.henze

    m.henze New Member

    Thanks for you reply. I've switched to "trunk" but with the plugin's enabled I still can't login. No messages any where ...
     
  16. Carlosole

    Carlosole New Member

    Attached Files:

  17. Horfic

    Horfic Member

    Try trunk version...

    Works for me and probably for everybody else, didn't got any errors for ui.
     
  18. vStone

    vStone New Member

    Attached Files:

  19. neobcn

    neobcn New Member

    Friend what is the correct manual for installing 6 integrate Roundcube =0.52???

    thx a lot
     
  20. wolfiedk

    wolfiedk New Member

    RoundCube 0.5.1 and ISPConfig 3.0.3.3 -> SOAP Error: Not found

    Hi!

    I have installed Mailuser interface like your manual said.... (at least I like to think so :))

    But I'm having some problem, I can login RC and see the Account tab, but when I clink on it, it says "SOAP Error: Not found".
    I can see all the functions: General, Password, Fetchmail and so on.

    I have searched for this error, but cant find anything about it. I have installed php-soap too, but it have not solved the error.

    PLease advise me, if I have to post some configurations files.

    Please help

    Best regards
    Wolfiedk


    SORRY for the mistake, I have made a configuration error in the config.inc.php file.

    But now I got the "SOAP Error: Error Fetching http headers". I can only read on the forum, that a reinstall of reoundcoube + plugins will solve my problem, but is there another way for solving this ?

    Best regards
    Wolfiedk
     
    Last edited: Jul 8, 2011

Share This Page