Mandriva Directory Server

Discussion in 'HOWTO-Related Questions' started by Nikitos, Feb 11, 2008.

  1. odcheck

    odcheck New Member

    DHCP IP-Reservation and Dynamic DNS Update

    Hi @ ALL

    before I've started to get known with LDAP, I had nearly the same setup in my network enviroment without LDAP.
    And I used the rcnd.key function so that DHCP and DNS could work together so that DHCP updated dynamic the dns zones. I've been also able to use reservation in conjuction with the MAC Address for some host so that they will only got a specified IP Address.

    Now I am wondering who can I (we) uses this feature with this LDAP Setup?

    Something like that for host IP reservation e.g.:
    dn: cn=stka, cn=DHCP Config, dc=lokal,dc=de
    cn: stka
    objectClass: top
    objectClass: dhcpHost
    dhcpHWAddress: ethernet 00:0a:e4:22:af:de
    dhcpStatements: fixed-address
    But how about the dns zone dynamic update?

    Maybe someone can give me a hint on that please.
  2. odcheck

    odcheck New Member

    Connection failed: NT_STATUS_LOGON_FAILURE

    net -U Administrator rpc rights grant 'DOMAIN\Domain Admins' SeMachineAccountPrivilege gets message
    Could not connect to server
    The username or password was not correct.
    Connection failed: NT_STATUS_LOGON_FAILURE

    1. the solution given in this forum
    2. or another solution
    check smb.conf regarding:

    interfaces = eth0
    bind interfaces only = true

    this was my failure so I could use the net command.
    Just comment out or correct those lines ;-)
  3. odcheck

    odcheck New Member

    How to use the MMC backup-tool ?

    I didn't figured out yet how to access the backup-tool - using the web-gui ? or what does the trick?

    Everyone how went through this How To of Falko,
    should have:

    there is a shell script

    For what did we create a archive share ?
    For what did we point to sharepath etc. in the ../plugins/base.ini ??

    Can anyone help me please
  4. GaulHahn

    GaulHahn New Member

    I had some problems and to save anyone else scratching their head for hours this may help you.

    When running

    smbldap-populate -m 512 -a Administrator
    I was getting auth errors even though my password was correct and matched the LDAP passwords entered at the beginning. My password was using unusual characters like $#@ etc. and simply wouldn't work. I tried a really basic password like "howtoforge" in the How To and this resolved the problem.

  5. GaulHahn

    GaulHahn New Member

    Oh and also I discovered when running

    /etc/init.d/mmc-agent start
    SAMBA option 'ldap delete dn' must be disabled.
    Plugin samba not loaded.

    I commented out the following in /etc/samba/ as follows

    #       ldap delete dn = yes
    And it fixed it
  6. SirLancelot

    SirLancelot New Member

    I tried this in order to fix the "chown: `:Domain Users': invalid group" problem in section 5.4 but it did not work for me.

    I've gone back through everything to ensure that I have made no errors, but I cant seem to figure it out.
    Anyone have any suggestions?

    Many thanks.
  7. HidX

    HidX New Member

    It is sorry, but to date a problem remained (((

    Did everything on instruction...copy.

    But at Command

    net -U Administrator rpc rights grant 'DOMAIN\Domain Admins' SeMachineAccountPrivilege

    gives out

    Could not connect to server
    Connection failed: NT_STATUS_LOGON_FAILURE

    Help please :(
    Last edited: Nov 25, 2008
  8. SirLancelot

    SirLancelot New Member

    Ok it was an error of mine. while adjusting the guide to fit my needs I overlooked a couple of areas that I had to ammend to my needs. All working now. A great guide and Mandriva DS is superb.
    Many thanks.
  9. HidX

    HidX New Member

    It too "net -U Administrator rpc rights grant 'DOMAIN\Domain Admins' SeMachineAccountPrivilege" works for you?
  10. SirLancelot

    SirLancelot New Member

    Yes this worked fine, might sound obvious but have you replaced:-

    "net -U Administrator rpc rights grant 'DOMAIN\Domain Admins' SeMachineAccountPrivilege"


    "net -U Administrator rpc rights grant 'YOUR_WORKGROUP_NAME_DEFINED_IN_SAMBA\Domain Admins' SeMachineAccountPrivilege"

    This is the Domain name you chose in section 3.2.2 Samba. of the guide

    This is one of the things I first overlooked.
  11. HidX

    HidX New Member

    Good afternoon.
    I did all as in how to, and have stopped on this problem.
    What you use Repositories?

    Please Lay out the /etc/apt/sources.list
    Last edited: Dec 5, 2008
  12. Brun

    Brun New Member

    I install Debian 4.0r6 and have trouble on first step.
    My sources.list
    When I try install all packege
    Why author don`t show your repositories list?
    So. What i must do?
  13. Brun

    Brun New Member

    Ok. I`m fix my first problem. My repository was the following.
    I installed everything, except for dcc-client.

    Then install went fine. He received only a few mistakes.
    debian:~# chown -R :"Domain Users" /home/samba/
    chown: `:Domain Users': invalid group

    debian:/etc/squid# net -U Administrator rpc rights grant 'PZAS\Domain Admins' SeMachineAccountPrivilege
    Could not connect to server
    The username or password was not correct.
    Connection failed: NT_STATUS_LOGON_FAILURE

    PZAS - is my workgroup name in samba. Password I put correct.

    Next were no errors. Set in Mandriva Managment Console. All items performed correctly. When you add a user, I do not see "Samba user properties".

    When start mmc-agent
    Explain why I have problems and how to fix them.
    Last edited: Dec 25, 2008
  14. Brun

    Brun New Member

    I fix my problem.
    In the tutorial given is not about editing the file /etc/mmc/plugins/samba.ini.
    There must indicate their preference.
    After restart mmc-agent i recive error. Samba is not started.
    Then in file /etc/samba/smb.conf i delete line ldap delete dn = yes.
    Restart samba, restart mmc-agent and all be work.

    But now i can`t join other computer to my domain.
    To be continiue.
    Last edited: Dec 26, 2008

Share This Page