Mariadb won't start Can't open the mysql.plugin table

Discussion in 'Installation/Configuration' started by razor7, Aug 19, 2016.

  1. razor7

    razor7 Member

    Hi! today I started to get this issue on my mariadb server with ISPConfig 3

    101126 10:29:53 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.

    Command mysql_upgrade didn't worked because the mysql server was stopped because of the error, so reading around the web I found this command as a possible soluton to the issue

    myisamchk –check /var/lib/mysql//.MYI

    So I ran it, but now, I'm getting this error:
    160818 23:14:51 [ERROR] Unknown/unsupported storage engine: InnoDB
    160818 23:14:51 [ERROR] Aborting
    160818 23:14:51 [Note] /usr/sbin/mysqld: Shutdown complete

    What can I do to get my server up and running again?


    Package: mariadb-server (10.0.25-0ubuntu0.16.04.1)
    Ubuntu server 16.04 x64
  2. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

  3. razor7

    razor7 Member

    Thanks jesee, finally I restored a server image and restored DB backups, because I tried the instructions on that link but didn't help.

    I think mariadb is the culprit. When I installed a fresh server using the perfect server tutorial, something went wrong with mariadb and had to reinstall everithing from scratch...

    Thanks for the reply

Share This Page