Master-master setup issues

Discussion in 'Installation/Configuration' started by _BM_, Apr 5, 2019.

  1. _BM_

    _BM_ New Member

    hi !
    i'm trying to make HA system with 4 virtual machines
    i'm installed ceph and mariadb cluster on 4 nodes
    2 of them i want to use like web hosting platform (in mirror mode), so i'm installing ispconfig on node #1, then add node#2 in expert install mode. i'm sucsessfuly connect to my local db and to node#1, then i set node#2 as mirrir to node#1, when i do this network interface on node#2 is down and hosts file change fqdn to name of node#1.
    I fix this by blocking access to /etc/hosts file (chmod 0000), and i'm manualy up newtwork interface. Also i change type from MyISAM to innodb, cos in 1st type i had issues with sync when i set mirror mode. (i.m not shure it OK, but i can fix this)
    Now i set mirror mode on node#2 -> node#1 and when i create user or set some settings from node#1 to node#2 in ISP panel everything works fine, but when i make some changes on node#2 panel, users creating only on this node, changes didn't pushes to node#1
    my i missed something, but at ISPconf v3.0 i set mirror mode on both servers, and it works fine. With current version of ispconf 3.1 i can mirror only node#1 to node#2, or node#2 to node#1, but not same time. i can't find any info about this changes.
    I just want to have 2 master-master nodes, which can change each other and sync if one of them suddenly down
    i used these tutorials
    OS Debian 9.8, ceph - 12.2.11, mariadb - v10.1
    ty for advance
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to copy /usr/local/ispconfig/interface/lib/ from node 1 to node 2 to be able to use the ISPConfig interface on both nodes.
  3. _BM_

    _BM_ New Member

    i did it, but now i can't login into ISPconfig on node#2, "Username or Password wrong." (2nd db have not data inside, only tables for some reason)
    and still i have a issues with crush network interface
    In /etc/hosts on node#2 FQDN of node#1 sets same as at node#2, if i try to change it back manualy, interface crushes everytime (i need correctly worked hosts coz i use cephfs)
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Probably you used the ispconfig UI on both nodes before you copied that file, this will cause conflicting data into the two databases which might cause issues. besdie that, you might want to use the ispconfig debug mode to see why server2 is not able to fetch data from server1 and you should double check if mysql replication is working correctly on both nodes and that it is really a master/master replication.

    Regarding hosts problem, try to set the hosts and hostname file correctly and then use:

    chattr +i /etc/hosts
    chattr +1 /etc/hostname

    to make uncahngable and undo the chmod that you did before.
  5. _BM_

    _BM_ New Member

    i got this
    2nd database is empty and its ok (if i got right), and i copy config file for connecting to 1st DB and use it
    i forgot to change type 1st DB to innodb, and i guess thats a reason why it wasn't started at first time

    it works now
    ty Till, have a nice day

Share This Page