Migrating to letsencrypt for sites on Ubuntu 14.04

Discussion in 'Installation/Configuration' started by tfboy, Feb 2, 2017.

  1. tfboy

    tfboy Member

    My existing ISPconfig3 has been working great. I am now running on 3.1.1p1 on Ubuntu 14.04.5 on a Linode. Server install was done a year or two ago using the perfect server procedure.
    Up till now, the various sites I run have SSL certs obtained via StartSSL. Last year, I paid for a Class 2 IV so I can generate my certs and all was going well. However, since the buyout by WoSign and the now distrust, any new certs I create will no longer be trusted by latest versions of browsers, so I'm looking at migrating to another CA. Due to the number of domains I have, this could be quite costly so I'm investigating using LetsEncrypt as an alternative.

    I've had a quick play, but before I really try things in anger and fear breaking my sites... What I've done so far:
    from /opt/:
    git clone https://github.com/Certbot/Certbot
    cd Certbot
    Upgrading certbot-auto 0.10.2 to 0.11.0...
    Replacing certbot-auto...
    An unexpected error occurred:
    IndexError: list index out of range
    Please see the logfile 'certbot.log' for more details.
    OK. cat certbot.log gives:
    Traceback (most recent call last):
      File "/root/.local/share/letsencrypt/bin/letsencrypt", line 11, in <module>
      File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/main.py", line 861, in main
      args = cli.prepare_and_parse_args(plugins, cli_args)
      File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/cli.py", line 814, in prepare_and_parse_args
      helpful = HelpfulArgumentParser(args, plugins, detect_defaults)
      File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/cli.py", line 442, in __init__
      if self.args[0] == 'help':
    IndexError: list index out of range
    So am I trying to do something silly? Is my existing Apache2 configuration causing a problem?
  2. sjau

    sjau Local Meanie Moderator

    doesn't look like your fault. Seems to be an issue with Certbot.
  3. tfboy

    tfboy Member

    Thaks sjau,
    In the end, as the server is on Linode and had less than half the storage assigned, I cloned the disk to have a fallback backup and then tried an upgrade which seems to have pretty much worked. I'm now on Ubuntu 16 and was able to install the letsencrypt package and it seems to be functioning OK - I've had a new cert delivered and installed through ISPconfig :)

Share This Page