mod_mono on suse 10.2 doesn't work

Discussion in 'Installation/Configuration' started by SupuS, Jun 22, 2007.

  1. SupuS

    SupuS Member HowtoForge Supporter

    Hi all

    Is there somebody who know how can I run mod_mono on suse 10.2?
    I followed all threads here but any of them didn't helps me. Allways I get

    500 error - Internal Server Error!

    I installed mod_mono with yast2 and put this configuration to the apache directives box in ispconfig setting:

    AddHandler mono .asp .aspx .asmx .ashx .asax .ascx .soap .rem .axd .cs .config .dll .rails
    SetHandler mono
    MonoApplications '/:/srv/www/web3/web'
    MonoDocumentRootDir '/srv/www/web3/web'

    to the /etc/apache2/httpd.conf this line

    Include /etc/apache2/mod_mono.conf
    but without success. My apache error log says nothing useful .. only this line:

    Another mod-mono-server with the same arguments is already running.
    which is .. as I read on mono discussion .. informational only.

    I get only one error if I run apache2ctl -f on vhost file:

    apache2ctl -f /etc/apache2/vhosts/Vhosts_ispconfig.conf
    Syntax error on line 22 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
    Invalid command 'MonoApplications', perhaps misspelled or defined by a module not included in the server configuration
    but modul is loaded

    # apache2ctl -M
    Loaded Modules:
     core_module (static)
     mpm_prefork_module (static)
     php5_module (shared)
     rewrite_module (shared)
     mono_module (shared)
    Syntax OK
    any help welcome

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please have a look in the error log of this website to see what causes the 500 error.
  3. SupuS

    SupuS Member HowtoForge Supporter

    hi till

    in /srv/www/web3/log/error.log is no related error .. only in /srv/www/web3/log/web.log are these strange lines:

    ::1 - - [19/Jun/2007:15:25:40 +0200] "GET / HTTP/1.0" 403 1051 "-" "Apache/2.2.3 (Linux/SUSE) (internal dummy connection)"

    but they are old .. no new lines here.
    Last edited: Jun 22, 2007
  4. falko

    falko Super Moderator ISPConfig Developer

    Is there another Apache error log somewhere in the /var/log directory?
  5. SupuS

    SupuS Member HowtoForge Supporter

    Hi falko

    It is clean suse installation .. and in apache logdir is only

    ls /var/log/apache2/
    access_log  error_log  rcapache2.out
    and in access_log I found this line:

    [22/Jun/2007:16:30:26 +0200] "GET /test/index.aspx HTTP/1.1" 500 1215 "-" "Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.7 (like Gecko)"
    it is lmy access to default test file from default mono installation .. nothing more


    I found one error error_log but probably not related with my problem:

    [Fri Jun 22 14:47:43 2007] [notice] Graceful restart requested, doing restart
    [Fri Jun 22 14:47:43 2007] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)
    [Fri Jun 22 14:47:44 2007] [notice] Apache/2.2.3 (Linux/SUSE) configured -- resuming normal operations
    [Fri Jun 22 14:47:44 2007] [warn] long lost child came home! (pid 2261)
    Last edited: Jun 23, 2007

Share This Page