multi server setup - database inconsistency

Discussion in 'General' started by craigfanman, Jul 25, 2017.

  1. craigfanman

    craigfanman Member

    hi. i've been migrating web servers from one multi server to another, done a few so far and gone fine but I've hit a problem with the latest one. It seemed to go fine, moved 500 sites but found about 50 of them were missing, no domain was created in the new ispconfig

    so I dug in my original database and found this: the 50 that werent copied are present in the web_domain table of the master ispconfig server, but on the web server that they are actually hosted on, they are not in the dbispconfig database. So this leads me to assume the migration tool is looking in the web server db, not the master db. This is fine, they should be in sync. I'm sure I've asked this before and been told to run the resync tool, so I have done this but still no luck, the sites are not present in dbispconfig on the web server. just for clairity these sites do load and run fine, the clients were copied over to new ispconfig just not the web_domain.

    no obvious errors from migrate.log that I can see, it doesnt even mention these missing sites it cant see them. I did note that each of the affected sites has a blank entry for 'added_by' whereas all the others are filled, so I dont know if this is the problem? Tried filling them all with null and running migration again but no dice.

    any ideas?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The migration tool indeed looks into the local database of the node that gets migrated, so if a site is not present there, then it will not be aware of it. The question indeed is why they are not there, so we have to find the source of this on the old setup. The best way to find out is that you enable debugging in the master for this affected slave, comment out the cronjob on the slave, then change a value in an affected site, e.g. website quota or similar and press save. Then run on the slave and check if any errors were shown. There must be an error when tries to insert or update the record in the database.

    I think it's just an indication that these have been created some time ago, I don't think that this is the issue as this field is just for the information of the admin, it is not used for the actual site creation.
  3. craigfanman

    craigfanman Member

    ok thanks for the tips, resolved a load of other issues and think i've got to the last step now. each site that fails to migrate has a line like this in the log:
    [WARN] Could not resolve 5889 for domain to new client id. This is normal on dry runs.

    the client has been copied but not site or DB. any ideas how to resolve this? thanks.
  4. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Please check that the website is really attached to the client (on the source) that is mentioned there (id 5889). Check the migrate.log for further messages regarding this client.

Share This Page