Multi Server setup, updated Master server from Ubuntu 16.04 to 20.04 and it crashed

Discussion in 'Installation/Configuration' started by swehes, Jun 1, 2022.

  1. swehes

    swehes Member

    So to try to make a long story somewhat shorter.
    I have a multi server setup. My master server has been on Ubuntu 16.04 for the longest of time because I didn't want things to crash. As 16.04 is now no longer supported I decided to bite the bullet and upgrade the OS. I took it to 18.04 and it all seemed to be doing OK. Then I took it to 20.04 and it no longer was doing so good. My slave servers was no longer able to connect to the Master server. I backed up the dbispconfig database and the mysql.user database and table. I did a fresh install of 20.04 and uploaded the databases to the new setup. After many hours, I have the Master server back up and running. However the slave servers are not getting the changes applied to them when I make changes in the Master server. I am able to run the update script on the slave servers and they all see and connect to the Master server. I don't see any error messages in any logs. I have run the test script on both Master and some of the Slave servers and I can't find any issues.
    I am at my wits end here not able to find where the issue is. The Master server doesn't put anything in the queue when I try to make changes to the the slave servers but if I try to make a change to the Master server I see the number for changes in the queue on the top of the dashboard.

    Test script gives the below results.

    I put ISPconfig in debug mode and still no issues that I can locate. If anyone know how to get the Master server to push the cron jobs to the slave servers that would be great. I did reinstall ispconfig per the Perfect Server instructions and then I uploaded the old database backup.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    It's the other way round, slave servers pull jobs from master. enable debug mode for the slave servers on the master and run on the slave servers to see why they can't connect to master anymore.
    swehes likes this.
  3. swehes

    swehes Member

    Thanks Till for pointing me in the right direction. Ran ./ and got the following error on one of my slave servers.
    01.06.2022-10:43 - WARNING - There is already a lockfile set, but no process running with this pid (3624754). Continuing.
    Datenbank nicht gefunden / Database not found PHP Fatal error: Uncaught Error: Call to a member function testConnection() on bool in /usr/local/ispconfig/server/server.php:64
    Stack trace:
    #0 {main}
    thrown in /usr/local/ispconfig/server/server.php on line 64
  4. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    What version is your php? (/usr/bin/php -v)
    ahrasis likes this.
  5. swehes

    swehes Member

    php 7.4.3
  6. swehes

    swehes Member

    So that is on one of my web servers (have two)
    On my database server I looked at the cron.log and found this information.
    I have looked at the logs and can't find the issue other than what is showing here.
    I still think that my ispconfig master server isn't creating the jobs for the other servers to process. It won't give me any queue if I create anything for one of the slave servers. I don't get any issues when I run an update.php on the slave servers. It all goes through.

Share This Page